Skip to content

Commit

Permalink
Make this package build on NetBSD-current by casting arguments to ctype
Browse files Browse the repository at this point in the history
macros where necessary.

Bump package revision.
  • Loading branch information
agc committed Dec 30, 2004
1 parent 40495b1 commit 7a12a18
Show file tree
Hide file tree
Showing 4 changed files with 40 additions and 2 deletions.
3 changes: 2 additions & 1 deletion chat/i2cbd/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.9 2004/04/11 05:50:10 snj Exp $
# $NetBSD: Makefile,v 1.10 2004/12/30 11:10:22 agc Exp $
#

DISTNAME= i2cbd-2.0_BETA1
PKGREVISION= 1
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_LOCAL}

Expand Down
4 changes: 3 additions & 1 deletion chat/i2cbd/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.4 2003/10/24 21:12:18 jwise Exp $
$NetBSD: distinfo,v 1.5 2004/12/30 11:10:22 agc Exp $

SHA1 (i2cbd-2.0_BETA1.tar.gz) = d3578637f834a8628c270e1e9fd6db7683d1603c
Size (i2cbd-2.0_BETA1.tar.gz) = 59007 bytes
SHA1 (patch-aa) = 0151f8e68be11e759425d2e9569df3d465c50931
SHA1 (patch-ab) = bca8ecb0f41be6405333f2bcf7722dc725ffc777
SHA1 (patch-ac) = ca8e6b7324a22fb9ecabf2374e34febb55196e28
SHA1 (patch-ad) = 3cf3cc389861f38fe6d12a896717f3716fa85bdf
SHA1 (patch-ae) = 52c7d65cfb4c453d9e3d135d903373f99a15131a
13 changes: 13 additions & 0 deletions chat/i2cbd/patches/patch-ad
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2004/12/30 11:10:22 agc Exp $

--- src/msgs.c 2004/12/30 11:06:20 1.1
+++ src/msgs.c 2004/12/30 11:06:33
@@ -207,7 +207,7 @@
access_file = open(ACCESS_FILE, O_RDONLY);
if (access_file >= 0) {
while ((i = read(access_file, &c, 1)) > 0) {
- if (isspace(c)) {
+ if (isspace((unsigned char)c)) {
ucaseit(three);
if (!fnmatch(three, one, 0)) {
snprintf(line, LINE_SIZE, "Login refused for %s", one);
22 changes: 22 additions & 0 deletions chat/i2cbd/patches/patch-ae
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
$NetBSD: patch-ae,v 1.1 2004/12/30 11:10:22 agc Exp $

--- src/strings.c 2004/12/30 11:07:38 1.1
+++ src/strings.c 2004/12/30 11:08:03
@@ -78,7 +78,7 @@
lcaseit(char *s)
{
for (; *s; s++)
- *s = tolower(*s);
+ *s = tolower((unsigned char)*s);
}

/* convert a string to upper case */
@@ -86,7 +86,7 @@
ucaseit(char *s)
{
for (; *s; s++)
- *s = toupper(*s);
+ *s = toupper((unsigned char)*s);
}

char *

0 comments on commit 7a12a18

Please sign in to comment.