-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
12 changed files
with
204 additions
and
27 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,13 +1,18 @@ | ||
$NetBSD: distinfo,v 1.8 2004/08/30 06:27:55 recht Exp $ | ||
$NetBSD: distinfo,v 1.9 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
SHA1 (plp_1_8.tar.gz) = cad586353091895b6efc556d2cb5fa16891a3749 | ||
Size (plp_1_8.tar.gz) = 58424 bytes | ||
SHA1 (patch-aa) = 0aa07f8542acbd9180cfbfb4230e50eb97e45cb9 | ||
SHA1 (patch-ab) = 41314372a3f5f5723393c0cf42c20d4257b170b6 | ||
SHA1 (patch-aa) = de823cbd6f27bfc4245af8d9de100a3a48ac258c | ||
SHA1 (patch-ab) = 9404e7c991d8b9e5abc358f90b91392833aa80d7 | ||
SHA1 (patch-ac) = 9f196ba3c236629c6ed1b59842fb6de2716917a6 | ||
SHA1 (patch-ad) = 4a6421d7256498df6293011bafc76e75cc5512e6 | ||
SHA1 (patch-ae) = 29b0cde6353c257a01a1630981f229c6673bbe73 | ||
SHA1 (patch-af) = f8c668a5891e51637f2b0cdaf7036c8632b3965d | ||
SHA1 (patch-ag) = 354183a25f00d951e5cbc25e64b11b1daac21939 | ||
SHA1 (patch-ah) = e0a90f7f8f70ab94f252af28d0d6ecbb878265df | ||
SHA1 (patch-ai) = 88ec3fd405e7b19003d91e37dbcf739f948e7c03 | ||
SHA1 (patch-af) = 0ab78ff48fbd42b45bd59468eb24297f44802ef5 | ||
SHA1 (patch-ag) = c6610f91ba3216aaca6fbf74620e64b1657e711e | ||
SHA1 (patch-ah) = bd381b9d8bbd68e985e6323c775324093fe7fbfe | ||
SHA1 (patch-ai) = 82b2a9af4d88bb27ea8c196f1b2ecdc39d7c9d24 | ||
SHA1 (patch-aj) = 4973bd796ce661c6a4dcf11c8a774e0d6450480b | ||
SHA1 (patch-ak) = 28ca61ae1f6b1a02f349bf57f5f351c55c3b7575 | ||
SHA1 (patch-al) = c8dc10319e174159efc6d838928a39bdb0446feb | ||
SHA1 (patch-am) = b3453d4cfb48a6daeae9aea896b261cae7db489f | ||
SHA1 (patch-ao) = eabe7562e75c3ab9900a889ffe14813a9faad01b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
$NetBSD: patch-aj,v 1.1 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
--- ncp/link.cc.orig 1999-04-12 23:49:12.000000000 +0200 | ||
+++ ncp/link.cc | ||
@@ -30,7 +30,7 @@ | ||
#include "bufferstore.h" | ||
#include "bufferarray.h" | ||
|
||
-link::link(const char *fname, int baud, IOWatch &iow, bool _s5, bool _verbose) : | ||
+Link::Link(const char *fname, int baud, IOWatch &iow, bool _s5, bool _verbose) : | ||
s5(_s5) | ||
{ | ||
p = new packet(fname, baud, iow, PACKET_LAYER_DIAGNOSTICS); | ||
@@ -43,16 +43,16 @@ link::link(const char *fname, int baud, | ||
failed = false; | ||
} | ||
|
||
-link::~link() { | ||
+Link::~Link() { | ||
delete p; | ||
} | ||
|
||
-void link::send(const bufferStore &buff) { | ||
+void Link::send(const bufferStore &buff) { | ||
if (buff.getLen() > 300) abort(); | ||
sendQueue.pushBuffer(buff); | ||
} | ||
|
||
-bufferArray link::poll() { | ||
+bufferArray Link::poll() { | ||
bufferArray ret; | ||
bufferStore buff; | ||
unsigned char type; | ||
@@ -145,10 +145,10 @@ bufferArray link::poll() { | ||
return ret; | ||
} | ||
|
||
-bool link::stuffToSend() { | ||
+bool Link::stuffToSend() { | ||
return (somethingToSend || !sendQueue.empty()); | ||
} | ||
|
||
-bool link::hasFailed() { | ||
+bool Link::hasFailed() { | ||
return failed; | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
$NetBSD: patch-ak,v 1.1 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
--- ncp/link.h.orig 1999-04-12 23:20:41.000000000 +0200 | ||
+++ ncp/link.h | ||
@@ -7,10 +7,10 @@ | ||
class packet; | ||
class IOWatch; | ||
|
||
-class link { | ||
+class Link { | ||
public: | ||
- link(const char *fname, int baud, IOWatch &iow, bool s5, bool _verbose = false); | ||
- ~link(); | ||
+ Link(const char *fname, int baud, IOWatch &iow, bool s5, bool _verbose = false); | ||
+ ~Link(); | ||
void send(const bufferStore &buff); | ||
bufferArray poll(); | ||
bool stuffToSend(); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
$NetBSD: patch-al,v 1.1 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
--- ncp/ncp.cc.orig 1999-04-12 23:27:06.000000000 +0200 | ||
+++ ncp/ncp.cc | ||
@@ -33,7 +33,7 @@ | ||
ncp::ncp(const char *fname, int baud, IOWatch &iow, bool _s5) : | ||
s5(_s5) | ||
{ | ||
- l = new link(fname, baud, iow, s5, LINK_LAYER_DIAGNOSTICS); | ||
+ l = new Link(fname, baud, iow, s5, LINK_LAYER_DIAGNOSTICS); | ||
gotLinkChan = false; | ||
failed = false; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
$NetBSD: patch-am,v 1.1 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
--- ncp/ncp.h.orig 1999-04-12 23:22:43.000000000 +0200 | ||
+++ ncp/ncp.h | ||
@@ -3,7 +3,7 @@ | ||
|
||
#include "bool.h" | ||
#include "bufferstore.h" | ||
-class link; | ||
+class Link; | ||
class channel; | ||
class IOWatch; | ||
|
||
@@ -21,6 +21,8 @@ public: | ||
bool gotLinkChannel(); | ||
|
||
private: | ||
+ friend class Link; | ||
+ | ||
enum c { MAX_LEN = 200, LAST_MESS = 1, NOT_LAST_MESS = 2 }; | ||
enum interControllerMessageType { | ||
// Inter controller message types | ||
@@ -37,7 +39,7 @@ private: | ||
void decodeControlMessage(bufferStore &buff); | ||
void controlChannel(int chan, enum interControllerMessageType t, bufferStore &command); | ||
|
||
- link *l; | ||
+ Link *l; | ||
channel *channelPtr[8]; | ||
bufferStore messageList[8]; | ||
int remoteChanList[8]; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-ao,v 1.1 2004/09/08 12:47:39 wiz Exp $ | ||
|
||
--- rfsv/rfsv32.h.orig 1999-04-12 23:17:21.000000000 +0200 | ||
+++ rfsv/rfsv32.h | ||
@@ -83,8 +83,8 @@ private: | ||
ARGUMENT=-6, | ||
TOTAL_LOSS_OF_PRECISION=-7, | ||
BAD_HANDLE=-8, | ||
- OVERFLOW=-9, | ||
- UNDERFLOW=-10, | ||
+ E_OVERFLOW=-9, | ||
+ E_UNDERFLOW=-10, | ||
ALREADY_EXISTS=-11, | ||
PATH_NOT_FOUND=-12, | ||
DIED=-13, |