Skip to content

Commit

Permalink
"BUILD_ENV" was misnamed. It's actually the environment that is passed
Browse files Browse the repository at this point in the history
to all internal recursive make processes.  As such, rename it to
"PKGSRC_MAKE_ENV".

XXX Note, some of the usage of this variable in package Makefiles seems
XXX incorrect.  They probably want "MAKE_ENV", which is the environment
XXX passed to the make process when running "make" within ${WRKSRC}.
  • Loading branch information
johnnylam88 committed Jul 21, 2006
1 parent bf3813d commit 7d1f4cc
Show file tree
Hide file tree
Showing 18 changed files with 44 additions and 44 deletions.
6 changes: 3 additions & 3 deletions devel/elib/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.1 2006/05/26 19:33:36 joerg Exp $
# $NetBSD: Makefile.common,v 1.2 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= elib-1.0
Expand All @@ -10,8 +10,8 @@ COMMENT= Library of utility functions for Emacs

.include "../../mk/emacs.mk"

BUILD_ENV+= EMACS=${EMACS_FLAVOR:Q}
MAKEFLAGS+= EMACS=${EMACS_FLAVOR:Q}
PKGSRC_MAKE_ENV+= EMACS=${EMACS_FLAVOR:Q}
MAKEFLAGS+= EMACS=${EMACS_FLAVOR:Q}

NO_CONFIGURE= yes
USE_TOOLS+= gmake makeinfo
Expand Down
4 changes: 2 additions & 2 deletions devel/monotone-viz/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2006/04/17 13:46:21 wiz Exp $
# $NetBSD: Makefile,v 1.13 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= monotone-viz-0.14
Expand All @@ -14,7 +14,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-local-lablgtk --with-shared-sqlite
USE_TOOLS+= gmake pkg-config
BUILD_TARGET= monotone-viz
BUILD_ENV+= BUILDLINK_DIR=${BUILDLINK_DIR}
PKGSRC_MAKE_ENV+= BUILDLINK_DIR=${BUILDLINK_DIR}
INSTALLATION_DIRS= bin

do-install:
Expand Down
4 changes: 2 additions & 2 deletions devel/semantic/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.20 2006/06/17 19:27:04 rillig Exp $
# $NetBSD: Makefile,v 1.21 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= semantic-1.4.4
Expand All @@ -15,7 +15,7 @@ DEPENDS+= ${EMACS_PKGNAME_PREFIX}eieio>=0.17:../../lang/eieio

.include "../../mk/emacs.mk"

BUILD_ENV+= EMACS=${EMACS_FLAVOR}
PKGSRC_MAKE_ENV+= EMACS=${EMACS_FLAVOR}

NO_CONFIGURE= yes
USE_TOOLS+= gmake
Expand Down
6 changes: 3 additions & 3 deletions editors/jde/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.19 2006/03/10 23:58:47 rillig Exp $
# $NetBSD: Makefile,v 1.20 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= jde-2.3.2
Expand Down Expand Up @@ -27,8 +27,8 @@ EMACS_VERSIONS_ACCEPTED=emacs21 # XXX Won't compile with emacs20...

PKG_DEFAULT_JVM= sun-jdk14

BUILD_ENV+= EMACS=${EMACS}
MAKE_ENV+= EMACS_LISPPREFIX=${EMACS_LISPPREFIX:Q}
PKGSRC_MAKE_ENV+= EMACS=${EMACS}
MAKE_ENV+= EMACS_LISPPREFIX=${EMACS_LISPPREFIX:Q}

NO_CONFIGURE= yes

Expand Down
4 changes: 2 additions & 2 deletions editors/speedbar/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2006/03/20 04:59:08 jlam Exp $
# $NetBSD: Makefile,v 1.17 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= speedbar-0.14beta4
Expand All @@ -13,7 +13,7 @@ COMMENT= Directory and code browser for emacs

.include "../../mk/emacs.mk"

BUILD_ENV+= EMACS=${EMACS}
PKGSRC_MAKE_ENV+= EMACS=${EMACS}

NO_CONFIGURE= yes
USE_TOOLS+= gmake
Expand Down
4 changes: 2 additions & 2 deletions graphics/MesaLib/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.48 2006/07/06 12:27:43 markd Exp $
# $NetBSD: Makefile,v 1.49 2006/07/21 14:27:56 jlam Exp $

PKGNAME= MesaLib-${MESA_VERSION}
PKGREVISION= 2
Expand All @@ -23,7 +23,7 @@ PTHREAD_STUBLIB= "-L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -lpthstub"
.else
PTHREAD_STUBLIB= # provided by libc
.endif
BUILD_ENV+= PTHREAD_STUBLIB=${PTHREAD_STUBLIB}
PKGSRC_MAKE_ENV+= PTHREAD_STUBLIB=${PTHREAD_STUBLIB}

pre-build:
cd ${WRKSRC} && ${RM} -fr src/glu src/glut progs
Expand Down
4 changes: 2 additions & 2 deletions graphics/TiffIO/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2006/04/17 13:46:36 wiz Exp $
# $NetBSD: Makefile,v 1.11 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= TiffIO-120e
Expand All @@ -15,7 +15,7 @@ COMMENT= Tiff support for QT image loader
USE_TOOLS+= gmake
USE_LANGUAGES= c c++

BUILD_ENV+= QTDIR=${QTDIR:Q}
PKGSRC_MAKE_ENV+= QTDIR=${QTDIR:Q}

.include "../../devel/zlib/buildlink3.mk"
BUILDLINK_API_DEPENDS.tiff+= tiff>=3.8.1
Expand Down
4 changes: 2 additions & 2 deletions lang/libtcl-nothread/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.5 2006/07/08 23:10:55 jlam Exp $
# $NetBSD: buildlink3.mk,v 1.6 2006/07/21 14:27:56 jlam Exp $

BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
TCLNT_BUILDLINK3_MK:= ${TCLNT_BUILDLINK3_MK}+
Expand All @@ -25,7 +25,7 @@ BUILDLINK_TRANSFORM+= l:tcl:tcl84-nothread
BUILDLINK_TRANSFORM+= l:tcl8.4:tcl84-nothread

TCLCONFIG_SH?= ${BUILDLINK_PREFIX.tcl}/lib/tclConfig-nothread.sh
BUILD_ENV+= _TCL_NOTHREAD=yes
PKGSRC_MAKE_ENV+= _TCL_NOTHREAD=yes

.endif # TCLNT_BUILDLINK3_MK

Expand Down
4 changes: 2 additions & 2 deletions mk/bsd.pkg.barrier.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: bsd.pkg.barrier.mk,v 1.7 2006/07/21 14:21:28 jlam Exp $
# $NetBSD: bsd.pkg.barrier.mk,v 1.8 2006/07/21 14:27:56 jlam Exp $

_COOKIE.barrier= ${WRKDIR}/.barrier_cookie

Expand Down Expand Up @@ -56,7 +56,7 @@ barrier: ${_BARRIER_PRE_TARGETS} ${_COOKIE.barrier}
. if defined(PKG_VERBOSE)
@${PHASE_MSG} "Invoking \`\`"${_BARRIER_CMDLINE_TARGETS:Q}"'' after barrier for ${PKGNAME}"
. endif
${_PKG_SILENT}${_PKG_DEBUG}cd ${.CURDIR} && ${SETENV} ${BUILD_ENV} ${MAKE} ${MAKEFLAGS} ALLOW_VULNERABLE_PACKAGES= ${_BARRIER_CMDLINE_TARGETS}
${_PKG_SILENT}${_PKG_DEBUG}cd ${.CURDIR} && ${SETENV} ${PKGSRC_MAKE_ENV} ${MAKE} ${MAKEFLAGS} ALLOW_VULNERABLE_PACKAGES= ${_BARRIER_CMDLINE_TARGETS}
. if defined(PKG_VERBOSE)
@${PHASE_MSG} "Leaving \`\`"${_BARRIER_CMDLINE_TARGETS:Q}"'' after barrier for ${PKGNAME}"
. endif
Expand Down
4 changes: 2 additions & 2 deletions mk/build/bsd.build-vars.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: bsd.build-vars.mk,v 1.1 2006/07/05 06:09:15 jlam Exp $
# $NetBSD: bsd.build-vars.mk,v 1.2 2006/07/21 14:27:56 jlam Exp $
#
# BUILD_DIRS is the list of directories in which to perform the build
# process. If the directories are relative paths, then they
Expand Down Expand Up @@ -44,4 +44,4 @@ MAKE_ENV+= ${USETOOLS:DUSETOOLS=${USETOOLS:Q}}
# Add these bits to the environment used when invoking the recursive make
# processes for build-related phases.
#
BUILD_ENV+= PATH=${PATH:Q}
PKGSRC_MAKE_ENV+= PATH=${PATH:Q}
6 changes: 3 additions & 3 deletions mk/compiler/ccache.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: ccache.mk,v 1.26 2005/01/24 18:20:57 tv Exp $
# $NetBSD: ccache.mk,v 1.27 2006/07/21 14:27:56 jlam Exp $
#
# Copyright (c) 2004 The NetBSD Foundation, Inc.
# All rights reserved.
Expand Down Expand Up @@ -98,10 +98,10 @@ BUILD_DEPENDS+= ccache-[0-9]*:../../devel/ccache
# Override the compiler-specific hash with the version string for the
# compiler.
#
BUILD_ENV+= CCACHE_HASHCC=${CC_VERSION_STRING:Q}
PKGSRC_MAKE_ENV+= CCACHE_HASHCC=${CC_VERSION_STRING:Q}

. if defined(CCACHE_DIR) && !empty(CCACHE_DIR)
BUILD_ENV+= CCACHE_DIR=${CCACHE_DIR:Q}
PKGSRC_MAKE_ENV+= CCACHE_DIR=${CCACHE_DIR:Q}
. endif

# Create symlinks for the compiler into ${WRKDIR}.
Expand Down
8 changes: 4 additions & 4 deletions mk/compiler/distcc.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: distcc.mk,v 1.27 2005/01/24 18:20:57 tv Exp $
# $NetBSD: distcc.mk,v 1.28 2006/07/21 14:27:56 jlam Exp $
#
# Copyright (c) 2004 The NetBSD Foundation, Inc.
# All rights reserved.
Expand Down Expand Up @@ -96,13 +96,13 @@ PREPEND_PATH+= ${_DISTCC_DIR}/bin
BUILD_DEPENDS+= distcc-[0-9]*:../../devel/distcc

. if defined(DISTCC_HOSTS) && !empty(DISTCC_HOSTS)
BUILD_ENV+= DISTCC_HOSTS=${DISTCC_HOSTS:Q}
PKGSRC_MAKE_ENV+= DISTCC_HOSTS=${DISTCC_HOSTS:Q}
. endif
. if defined(DISTCC_SSH) && !empty(DISTCC_SSH)
BUILD_ENV+= DISTCC_SSH=${DISTCC_SSH:Q}
PKGSRC_MAKE_ENV+= DISTCC_SSH=${DISTCC_SSH:Q}
. endif
. if defined(DISTCC_VERBOSE) && !empty(DISTCC_VERBOSE)
BUILD_ENV+= DISTCC_VERBOSE=${DISTCC_VERBOSE:Q}
PKGSRC_MAKE_ENV+= DISTCC_VERBOSE=${DISTCC_VERBOSE:Q}
. endif

# Create symlinks for the compiler into ${WRKDIR}.
Expand Down
4 changes: 2 additions & 2 deletions mk/compiler/f2c.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: f2c.mk,v 1.5 2005/03/24 17:46:01 tv Exp $
# $NetBSD: f2c.mk,v 1.6 2006/07/21 14:27:56 jlam Exp $
#
# Copyright (c) 2005 The NetBSD Foundation, Inc.
# All rights reserved.
Expand Down Expand Up @@ -99,7 +99,7 @@ PREPEND_PATH+= ${_F2C_DIR}/bin
. include "../../lang/f2c/buildlink3.mk"

. if defined(F2C_DIR) && !empty(F2C_DIR)
BUILD_ENV+= F2C_DIR=${F2C_DIR:Q}
PKGSRC_MAKE_ENV+= F2C_DIR=${F2C_DIR:Q}
. endif

# Create symlinks for the compiler into ${WRKDIR}.
Expand Down
4 changes: 2 additions & 2 deletions multimedia/gst-plugins0.10-ffmpeg/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2006/07/13 14:19:04 joerg Exp $
# $NetBSD: Makefile,v 1.3 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= gst-ffmpeg-0.10.1
Expand All @@ -14,7 +14,7 @@ USE_LIBTOOL= yes
GNU_CONFIGURE= yes
OVERRIDE_DIRDEPTH= 3
USE_TOOLS+= pkg-config gmake perl
BUILD_ENV+= PERL=${PERL5}
PKGSRC_MAKE_ENV+= PERL=${PERL5}

.include "../../multimedia/gstreamer0.10/buildlink3.mk"
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
Expand Down
4 changes: 2 additions & 2 deletions multimedia/xine-lib/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.33 2006/04/13 18:23:36 jlam Exp $
# $NetBSD: Makefile.common,v 1.34 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= xine-lib-${XINE_LIB_VER}a
Expand Down Expand Up @@ -29,7 +29,7 @@ CONFIGURE_ARGS+= --without-external-ffmpeg --disable-ffmpegtest
CONFIGURE_ENV+= have_libpng="yes"
CONFIGURE_ENV+= PNG_CFLAGS="-I${PREFIX}/include"
CONFIGURE_ENV+= PNG_LIBS="-L${PREFIX}/lib -Wl,-R${PREFIX}/lib -lpng"
BUILD_ENV+= "mkdir_p"="mkdir -p"
PKGSRC_MAKE_ENV+= "mkdir_p"="mkdir -p"

.include "../../mk/bsd.prefs.mk"

Expand Down
4 changes: 2 additions & 2 deletions net/netbsd-tap/options.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.3 2005/05/31 10:01:39 dillo Exp $
# $NetBSD: options.mk,v 1.4 2006/07/21 14:27:56 jlam Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.netbsd-tap
PKG_SUPPORTED_OPTIONS= bpf
Expand All @@ -7,7 +7,7 @@ PKG_SUGGESTED_OPTIONS= bpf
.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Mbpf)
BUILD_ENV+= USE_BPF=YES
PKGSRC_MAKE_ENV+= USE_BPF=YES
.endif

TAP_KERNEL_ENV?= # empty
Expand Down
8 changes: 4 additions & 4 deletions x11/xephem/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.42 2006/07/02 10:45:30 rillig Exp $
# $NetBSD: Makefile,v 1.43 2006/07/21 14:27:56 jlam Exp $

DISTNAME= xephem-3.7.1
PKGREVISION= 1
Expand Down Expand Up @@ -32,9 +32,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/GUI/xephem
USE_TOOLS+= gmake perl:run
REPLACE_PERL+= auxil/*.pl

LIBS.SunOS+= -lnsl -lsocket
X11_LDFLAGS+= ${LIBS}
BUILD_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}
LIBS.SunOS+= -lnsl -lsocket
X11_LDFLAGS+= ${LIBS}
PKGSRC_MAKE_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}

REPLACE_INTERPRETER+= perl
REPLACE.perl.old= .*/bin/perl
Expand Down
6 changes: 3 additions & 3 deletions x11/xhangglider/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2006/03/04 21:31:13 jlam Exp $
# $NetBSD: Makefile,v 1.10 2006/07/21 14:27:56 jlam Exp $
#

DISTNAME= xhangglider-0.94.0
Expand All @@ -10,8 +10,8 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.netfort.gr.jp/~take/linux/xhang-en.html
COMMENT= Hanggliders fly in the background of the X screen

USE_IMAKE= yes
BUILD_ENV+= PREFIX=${PREFIX}
USE_IMAKE= yes
PKGSRC_MAKE_ENV+= PREFIX=${PREFIX}

post-extract:
${RM} ${WRKSRC}/Makefile
Expand Down

0 comments on commit 7d1f4cc

Please sign in to comment.