-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Define two missing constants when sizeof(void*) == 8. It will fix
build on 64bit architecture.
- Loading branch information
Showing
2 changed files
with
15 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,9 @@ | ||
$NetBSD: distinfo,v 1.6 2004/03/06 06:26:21 minskim Exp $ | ||
$NetBSD: distinfo,v 1.7 2004/03/08 16:52:13 minskim Exp $ | ||
|
||
SHA1 (BLT2.4z.tar.gz) = 29f719aa762f1762dbf4a3b0e60dc5356118ba2f | ||
Size (BLT2.4z.tar.gz) = 2200973 bytes | ||
SHA1 (patch-aa) = 97b967b8b0cda8e30bd24b8d89fd0b5679a9edd4 | ||
SHA1 (patch-ab) = 37320a45666c5cb3a0da08cd7f74e9dcee5a66a0 | ||
SHA1 (patch-ac) = 696f90010831522f46d67052abc0c6068197cfd9 | ||
SHA1 (patch-ad) = be6bd157a084f5ad38ff3787f53e7aa4fcf80234 | ||
SHA1 (patch-ae) = bda9a14a3e65230fb214498c2265d83056df88a7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
$NetBSD: patch-ac,v 1.4 2004/03/08 16:52:14 minskim Exp $ | ||
|
||
--- src/bltTree.c.orig 2002-09-29 00:44:12.000000000 -0500 | ||
+++ src/bltTree.c | ||
@@ -99,6 +99,8 @@ static Value *TreeNextValue _ANSI_ARGS_( | ||
#if (SIZEOF_VOID_P == 8) | ||
#define RANDOM_INDEX(i) HashOneWord(mask, downshift, i) | ||
#define BITSPERWORD 64 | ||
+#define START_LOGSIZE 10 | ||
+#define MAX_LIST_VALUES 40 | ||
#else | ||
|
||
#define START_LOGSIZE 5 /* Initial hash table size is 32. */ |