-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Allow for customised groups of packages at the top-level of pkgsrc.
If SPECIFIC_PKGS is defined (at the top-level of pkgsrc), then instead of looping through all the categories and then all the packages within that, simply loop through ${SITE_SPECIFIC_PKGS}, ${HOST_SPECIFIC_PKGS}, ${GROUP_SPECIFIC_PKGS} and ${USER_SPECIFIC_PKGS}, which are whitespace separated lists of categories/packages e.g. SITE_SPECIFIC_PKGS+= devel/cvs security/ssh The default behaviour is unchanged - if SPECIFIC_PKGS is not defined, the whole hierarchy will be traversed. Modify mk.conf.example to reflect the settings of SPECIFIC_PKGS, SITE_SPECIFIC_PKGS, HOST_SPECIFIC_PKGS, GROUP_SPECIFIC_PKGS and USER_SPECIFIC_PKGS. Modify the ispell package to use the make definition ISPELL_LANG, rather than just LANG (which can clash with the environment variable of the same name), and modify mk.conf.example accordingly.
- Loading branch information
agc
committed
Feb 21, 1999
1 parent
aa7216f
commit 8e2ac8a
Showing
3 changed files
with
90 additions
and
48 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,65 +1,66 @@ | ||
# $NetBSD: Makefile,v 1.15 1998/12/21 00:35:59 frueauf Exp $ | ||
# $NetBSD: Makefile,v 1.16 1999/02/21 21:25:03 agc Exp $ | ||
# FreeBSD Id: Makefile,v 1.21 1997/08/13 23:29:52 jmz Exp | ||
# | ||
|
||
DISTNAME= ispell-3.1.20 | ||
WRKSRC= ${WRKDIR}/ispell-3.1 | ||
CATEGORIES= textproc | ||
MASTER_SITES= ftp://ftp.cs.ucla.edu/pub/ispell-3.1/ | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://www.gnu.org/software/ispell/ispell.html | ||
|
||
WRKSRC= ${WRKDIR}/ispell-3.1 | ||
|
||
MAKE_FLAGS= TMPDIR=${WRKDIR} | ||
SCRIPTS_ENV= "LANG=${LANG}" | ||
SCRIPTS_ENV= "LANG=${ISPELL_LANG}" | ||
|
||
USE_GTEXINFO= yes | ||
INFO_FILES= ispell.info | ||
|
||
.include "../../mk/bsd.prefs.mk" | ||
|
||
_INTTYPES!= if [ -e /usr/include/inttypes.h ]; then echo "Exists"; else echo "No go"; fi | ||
_INTTYPES!= if [ -e /usr/include/inttypes.h ]; then ${ECHO} "Exists"; else ${ECHO} "No go"; fi | ||
|
||
.if (${_INTTYPES} == "Exists") | ||
CFLAGS+= -DHAVE_INTTYPES_H | ||
.endif | ||
|
||
pre-extract pre-build pre-install: | ||
.if !defined(ISPELL_FR) | ||
@echo '******************************************************' | ||
@echo '* Note that you can build a french/english version *' | ||
@echo '* by typing "make french" *' | ||
@echo '******************************************************' | ||
@${ECHO} '******************************************************' | ||
@${ECHO} '* Note that you can build a french/english version *' | ||
@${ECHO} '* by typing "make french" *' | ||
@${ECHO} '******************************************************' | ||
.else | ||
EXTRA_DICT= francais-IREQ-1.4.tar.gz | ||
MASTER_SITES+= ftp://ftp.robot.ireq.ca/pub/ispell/ | ||
DISTFILES+= ${EXTRA_DICT} | ||
.endif | ||
|
||
pre-extract: | ||
.if !defined(LANG) | ||
@echo '******************************************************' | ||
@echo '* Note that you can build a british version by *' | ||
@echo '* typing "make british" following a "make clean" *' | ||
@echo '******************************************************' | ||
.if !defined(ISPELL_LANG) | ||
@${ECHO} '******************************************************' | ||
@${ECHO} '* Note that you can build a british version by *' | ||
@${ECHO} '* typing "make british" following a "make clean" *' | ||
@${ECHO} '******************************************************' | ||
.endif | ||
|
||
pre-configure: | ||
.if defined(EXTRA_DICT) | ||
@echo ${EXTRA_DICT} > ${WRKDIR}/extra_dict | ||
@${ECHO} ${EXTRA_DICT} > ${WRKDIR}/extra_dict | ||
.else | ||
@echo -n | ||
@${ECHO} -n | ||
.endif | ||
|
||
post-configure: | ||
@echo "#define CFLAGS \"${CFLAGS}\"" >> ${WRKSRC}/local.h | ||
@${ECHO} "#define CFLAGS \"${CFLAGS}\"" >> ${WRKSRC}/local.h | ||
|
||
british: | ||
@echo "Okay, making a british version of ispell...." | ||
@${MAKE} ${.MAKEFLAGS} LANG=british all | ||
@${ECHO} "Okay, making a british version of ispell...." | ||
@${MAKE} ${.MAKEFLAGS} ISPELL_LANG=british all | ||
|
||
french: | ||
@echo "Okay, making a french/english version of ispell...." | ||
@${ECHO} "Okay, making a french/english version of ispell...." | ||
@${MAKE} ${.MAKEFLAGS} ISPELL_FR=yes | ||
|
||
pre-install: | ||
|