-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Import multiskkserv-20100128 as inputmethod/multiskkserv.
Packagesd by Ryo ONODERA in pkgsrc-wip, import requested via PR#43819. multiskkserv is a skk server which can use multiple dictionaries. This server uses cdb format as the dictionary format. cdb is the efficient and constant (i.e. cannot add, delete, modify) database format by Dan J. Bernstein, which I think is the appropriate format for the system-wide constant dictionary storage.
- Loading branch information
obache
committed
Sep 18, 2010
1 parent
a299c3f
commit 98c98c2
Showing
5 changed files
with
81 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
multiskkserv is a skk server which can use multiple dictionaries. | ||
This server uses cdb format as the dictionary format. cdb is the | ||
efficient and constant (i.e. cannot add, delete, modify) database | ||
format by Dan J. Bernstein, which I think is the appropriate format | ||
for the system-wide constant dictionary storage. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 2010/09/18 11:04:17 obache Exp $ | ||
# | ||
|
||
DISTNAME= multiskkserv-20100128-ac | ||
PKGNAME= ${DISTNAME:S/-ac//} | ||
CATEGORIES= inputmethod japanese | ||
MASTER_SITES= http://ryo-on.users.sourceforge.net/distrib/ | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://github.com/sina-ht/multiskkserv/ | ||
COMMENT= Simple skk multi-dictionary server | ||
LICENSE= gnu-gpl-v2 | ||
|
||
DEPENDS= skk-jisyo-cdb-[0-9]*:../../inputmethod/skk-jisyo-cdb | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
FIND_PREFIX:= SKKJISYOCDBDIR=skk-jisyo-cdb | ||
|
||
DOCSDIR= ${PREFIX}/share/doc/${PKGBASE} | ||
INSTALLATION_DIRS= ${DOCSDIR} | ||
|
||
INSTALL_DOCS= README \ | ||
README.j | ||
|
||
USE_LIBTOOL= yes | ||
GNU_CONFIGURE= yes | ||
|
||
RCD_SCRIPTS= multiskkserv | ||
|
||
FILES_SUBST= SKKJISYOCDBDIR=${SKKJISYOCDBDIR} | ||
|
||
post-install: | ||
.for filename in ${INSTALL_DOCS} | ||
${INSTALL_DATA} ${WRKSRC}/${filename} ${DESTDIR}/${DOCSDIR} | ||
.endfor | ||
|
||
SUBST_CLASSES+= pthread | ||
SUBST_STAGE.pthread= pre-configure | ||
SUBST_FILES.pthread= configure | ||
SUBST_SED.pthread= -e 's/-D_REENTRANT/${PTHREAD_CFLAGS}/g' | ||
SUBST_SED.pthread+= -e 's/-lpthread/${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}/g' | ||
|
||
.include "../../mk/find-prefix.mk" | ||
.include "../../mk/pthread.buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/09/18 11:04:17 obache Exp $ | ||
bin/skkdic-p2cdb | ||
sbin/multiskkserv | ||
sbin/multiskkserv-ctl | ||
share/doc/multiskkserv/README | ||
share/doc/multiskkserv/README.j | ||
share/examples/rc.d/multiskkserv |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2010/09/18 11:04:17 obache Exp $ | ||
|
||
SHA1 (multiskkserv-20100128-ac.tar.bz2) = 0b6594439582a22a334f3a188a57c7ddf7c00bba | ||
RMD160 (multiskkserv-20100128-ac.tar.bz2) = 0116ef3b8b40ad46886a1687d20c738229338afe | ||
Size (multiskkserv-20100128-ac.tar.bz2) = 436233 bytes |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
#!@RCD_SCRIPTS_SHELL@ | ||
# | ||
# $NetBSD: multiskkserv.sh,v 1.1.1.1 2010/09/18 11:04:17 obache Exp $ | ||
# | ||
# PROVIDE: multiskkserv | ||
# REQUIRE: DAEMON | ||
|
||
. /etc/rc.subr | ||
|
||
name="multiskkserv" | ||
rcvar=$name | ||
command="@PREFIX@/sbin/${name}" | ||
|
||
multiskkserv_flags="@SKKJISYOCDBDIR@/share/skk/SKK-JISYO.L.cdb &" | ||
|
||
load_rc_config $name | ||
run_rc_command "$1" |