-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Initial import of adplug-2.1 from pkgsrc-wip, packaged by
jfranz at bsdprojects dot net. AdPlug is a free, cross-platform, hardware independent AdLib sound player library, mainly written in C++ and released under the LGPL. AdPlug plays sound data, originally created for the AdLib (OPL2) audio board, directly from its original format on top of an OPL2 emulator or by using the real hardware. No OPL chip is required for playback.
- Loading branch information
xtraeme
committed
Sep 10, 2007
1 parent
96a7eae
commit 9909a1b
Showing
5 changed files
with
114 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
AdPlug is a free, cross-platform, hardware independent AdLib sound player | ||
library, mainly written in C++ and released under the LGPL. AdPlug plays | ||
sound data, originally created for the AdLib (OPL2) audio board, directly | ||
from its original format on top of an OPL2 emulator or by using the real | ||
hardware. No OPL chip is required for playback. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 2007/09/10 16:02:26 xtraeme Exp $ | ||
# | ||
|
||
DISTNAME= adplug-2.1 | ||
CATEGORIES= audio devel | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=adplug/} | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://adplug.sourceforge.net/ | ||
COMMENT= AdLib emulator library supporting many formats | ||
|
||
GNU_CONFIGURE= yes | ||
USE_LIBTOOL= yes | ||
USE_TOOLS+= pkg-config | ||
USE_LANGUAGES= c c++ | ||
INFO_FILES= yes | ||
|
||
PKGCONFIG_OVERRIDE+= adplug.pc.in | ||
|
||
.include "../../devel/libbinio/buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
@comment $NetBSD: PLIST,v 1.1.1.1 2007/09/10 16:02:26 xtraeme Exp $ | ||
bin/adplugdb | ||
include/adplug/a2m.h | ||
include/adplug/adl.h | ||
include/adplug/adlibemu.h | ||
include/adplug/adplug.h | ||
include/adplug/adtrack.h | ||
include/adplug/amd.h | ||
include/adplug/analopl.h | ||
include/adplug/bam.h | ||
include/adplug/bmf.h | ||
include/adplug/cff.h | ||
include/adplug/d00.h | ||
include/adplug/database.h | ||
include/adplug/dfm.h | ||
include/adplug/diskopl.h | ||
include/adplug/dmo.h | ||
include/adplug/dro.h | ||
include/adplug/dtm.h | ||
include/adplug/emuopl.h | ||
include/adplug/flash.h | ||
include/adplug/fmc.h | ||
include/adplug/fmopl.h | ||
include/adplug/fprovide.h | ||
include/adplug/hsc.h | ||
include/adplug/hsp.h | ||
include/adplug/hybrid.h | ||
include/adplug/hyp.h | ||
include/adplug/imf.h | ||
include/adplug/kemuopl.h | ||
include/adplug/ksm.h | ||
include/adplug/lds.h | ||
include/adplug/mad.h | ||
include/adplug/mid.h | ||
include/adplug/mkj.h | ||
include/adplug/msc.h | ||
include/adplug/mtk.h | ||
include/adplug/opl.h | ||
include/adplug/player.h | ||
include/adplug/players.h | ||
include/adplug/protrack.h | ||
include/adplug/psi.h | ||
include/adplug/rad.h | ||
include/adplug/rat.h | ||
include/adplug/raw.h | ||
include/adplug/realopl.h | ||
include/adplug/rix.h | ||
include/adplug/rol.h | ||
include/adplug/s3m.h | ||
include/adplug/sa2.h | ||
include/adplug/silentopl.h | ||
include/adplug/sng.h | ||
include/adplug/temuopl.h | ||
include/adplug/u6m.h | ||
include/adplug/xad.h | ||
include/adplug/xsm.h | ||
info/libadplug.info | ||
lib/libadplug.la | ||
lib/pkgconfig/adplug.pc | ||
man/man1/adplugdb.1 | ||
@dirrm include/adplug |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2007/09/10 16:02:26 xtraeme Exp $ | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+ | ||
ADPLUG_BUILDLINK3_MK:= ${ADPLUG_BUILDLINK3_MK}+ | ||
|
||
.if ${BUILDLINK_DEPTH} == "+" | ||
BUILDLINK_DEPENDS+= adplug | ||
.endif | ||
|
||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nadplug} | ||
BUILDLINK_PACKAGES+= adplug | ||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}adplug | ||
|
||
.if ${ADPLUG_BUILDLINK3_MK} == "+" | ||
BUILDLINK_API_DEPENDS.adplug+= adplug>=2.1 | ||
BUILDLINK_PKGSRCDIR.adplug?= ../../audio/adplug | ||
.endif # ADPLUG_BUILDLINK3_MK | ||
|
||
.include "../../devel/libbinio/buildlink3.mk" | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2007/09/10 16:02:26 xtraeme Exp $ | ||
|
||
SHA1 (adplug-2.1.tar.bz2) = 49dd798467f194ece1863f18019912f8089cb9df | ||
RMD160 (adplug-2.1.tar.bz2) = 8788c174507fe39d3415f36e1ac60df6b84c889f | ||
Size (adplug-2.1.tar.bz2) = 730686 bytes |