Skip to content

Commit

Permalink
Don't leak rpath references to the work directory. Bump revision.
Browse files Browse the repository at this point in the history
  • Loading branch information
jsonn committed Jun 21, 2008
1 parent 90b3d7c commit 9a24468
Show file tree
Hide file tree
Showing 6 changed files with 61 additions and 2 deletions.
3 changes: 2 additions & 1 deletion lang/gauche/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.49 2008/05/26 22:37:30 tnn Exp $
# $NetBSD: Makefile,v 1.50 2008/06/21 17:17:51 joerg Exp $
#

DISTNAME= Gauche-0.8.13
CATEGORIES= lang
PKGREVISION= 1
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gauche/}
EXTRACT_SUFX= .tgz

Expand Down
6 changes: 5 additions & 1 deletion lang/gauche/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.22 2008/02/25 23:14:19 tnn Exp $
$NetBSD: distinfo,v 1.23 2008/06/21 17:17:51 joerg Exp $

SHA1 (Gauche-0.8.13.tgz) = fbbd3496a1088c5b36d446c4479f9db1dac2d1e0
RMD160 (Gauche-0.8.13.tgz) = 0430e6b99b85b5d1b5cc636d2ebbceac9ad1c80e
Expand All @@ -8,3 +8,7 @@ SHA1 (patch-ab) = 4dd53f094032099831ccdb71e5f4fb8ccb333742
SHA1 (patch-ae) = 2cfd522b94d7468ca671d6bd1c830b6edf7f5aa5
SHA1 (patch-af) = cfa1772da7f0dd90a9f4a53c2d1e0b27a74a24ee
SHA1 (patch-ag) = ee9946e364d6723b0efe3b260fc5d02ccb04621d
SHA1 (patch-ah) = 511cf477c22504573f791320a145f5e640d5176f
SHA1 (patch-ai) = f1903546a8d1b58aee27174fbd5ac07a491b5712
SHA1 (patch-aj) = 641075d941755cfa2dd39d1daf5dc69206751b5c
SHA1 (patch-ak) = 0ec1de6afe2d13505efcdd31135d5a36b437092b
13 changes: 13 additions & 0 deletions lang/gauche/patches/patch-ah
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
$NetBSD: patch-ah,v 1.5 2008/06/21 17:17:51 joerg Exp $

--- configure.ac.orig 2008-06-21 10:32:46.000000000 +0000
+++ configure.ac
@@ -614,7 +614,7 @@ if test "$try_rpath" = "yes"; then
ac_cv_linker_rpath_flag=no)])
CFLAGS="$cflags_save"
if test "$ac_cv_linker_rpath_flag" = "yes"; then
- RPATH_TMP='-Wl,--rpath "-Wl,`pwd`"'
+ RPATH_TMP='-Wl,--rpath-link "-Wl,`pwd`"'
RPATH_REAL='-Wl,--rpath "-Wl,$(LIB_INSTALL_DIR)"'
else
# solaris' ld uses -R instead of --rpath
13 changes: 13 additions & 0 deletions lang/gauche/patches/patch-ai
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1 2008/06/21 17:17:51 joerg Exp $

--- configure.orig 2008-06-21 10:42:01.000000000 +0000
+++ configure
@@ -10883,7 +10883,7 @@ fi
echo "${ECHO_T}$ac_cv_linker_rpath_flag" >&6; }
CFLAGS="$cflags_save"
if test "$ac_cv_linker_rpath_flag" = "yes"; then
- RPATH_TMP='-Wl,--rpath "-Wl,`pwd`"'
+ RPATH_TMP='-Wl,--rpath-link "-Wl,`pwd`"'
RPATH_REAL='-Wl,--rpath "-Wl,$(LIB_INSTALL_DIR)"'
else
# solaris' ld uses -R instead of --rpath
15 changes: 15 additions & 0 deletions lang/gauche/patches/patch-aj
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-aj,v 1.1 2008/06/21 17:17:51 joerg Exp $

--- ext/Makefile.ext.in.orig 2008-06-21 10:47:05.000000000 +0000
+++ ext/Makefile.ext.in
@@ -37,8 +37,8 @@ CCLD = $(CC)
LINK = $(CCLD) $(CFLAGS) $(LDFLAGS)
MODLINK = $(CCLD) $(CFLAGS) $(LDFLAGS)

-@CROSS_COMPILING_no@GOSH = $(top_builddir)/src/gosh -ftest
-@CROSS_COMPILING_no@GAUCHE_CONFIG = $(top_builddir)/src/gauche-config
+@CROSS_COMPILING_no@GOSH = LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$(top_builddir)/src $(top_builddir)/src/gosh -ftest
+@CROSS_COMPILING_no@GAUCHE_CONFIG = LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$(top_builddir)/src $(top_builddir)/src/gauche-config
@CROSS_COMPILING_yes@GOSH = gosh
@CROSS_COMPILING_yes@GAUCHE_CONFIG = $(top_builddir)/src/$(HOST)-gauche-config
GAUCHE_INSTALL = $(GOSH) $(top_srcdir)/src/gauche-install.in
13 changes: 13 additions & 0 deletions lang/gauche/patches/patch-ak
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
$NetBSD: patch-ak,v 1.1 2008/06/21 17:17:51 joerg Exp $

--- doc/Makefile.in.orig 2008-06-21 10:59:26.000000000 +0000
+++ doc/Makefile.in
@@ -9,7 +9,7 @@ MANPAGES = gosh.1 gauche-config.1
EXTRACTED = gauche-refe.texi gauche-refj.texi \
gauche-deve.texi gauche-devj.texi
GENERATED = Makefile $(MANPAGES)
-@CROSS_COMPILING_no@GOSH = ../src/gosh -q -I../src -I../lib -lgauche-init
+@CROSS_COMPILING_no@GOSH = LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:$(top_builddir)/src ../src/gosh -q -I../src -I../lib -lgauche-init
@CROSS_COMPILING_yes@GOSH = gosh -q -lgauche-init
INSTALL = @INSTALL@
MKINSTDIR = $(top_srcdir)/mkinstalldirs

0 comments on commit 9a24468

Please sign in to comment.