Skip to content

Commit

Permalink
Added a patch needed for gcc-2.95. Approved by jlam.
Browse files Browse the repository at this point in the history
  • Loading branch information
rillig committed Apr 12, 2005
1 parent b9a9b9a commit 9c97b4f
Show file tree
Hide file tree
Showing 6 changed files with 80 additions and 3 deletions.
3 changes: 2 additions & 1 deletion math/gcalctool/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.16 2005/03/22 16:30:14 jmmv Exp $
$NetBSD: distinfo,v 1.17 2005/04/12 00:51:22 rillig Exp $

SHA1 (gcalctool-5.5.41.tar.bz2) = 15e241aad6cbedf7c2d972bb633b21eabc05f5b8
RMD160 (gcalctool-5.5.41.tar.bz2) = ccc1f2e7de6e5edb451ac3fa0e323af9a62170ac
Size (gcalctool-5.5.41.tar.bz2) = 1043027 bytes
SHA1 (patch-aa) = ae3c2d5bfa1188987330825ef5123ae621aaf938
24 changes: 24 additions & 0 deletions math/gcalctool/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
$NetBSD: patch-aa,v 1.7 2005/04/12 00:51:22 rillig Exp $

Needed for gcc-2.95.

--- gcalctool/functions.c.orig Fri Feb 18 17:20:50 2005
+++ gcalctool/functions.c Mon Apr 11 00:52:32 2005
@@ -311,8 +311,6 @@ str_replace(char **str, char *from, char
void
trig_filter(char **func)
{
- assert(func);
-
enum mode {
normal = 0,
inv = 1,
@@ -322,6 +320,8 @@ trig_filter(char **func)

int inverse;
int hyperbolic;
+
+ assert(func);

inverse = (v->inverse) ? inv : 0;
hyperbolic = (v->hyperbolic) ? hyp : 0;
3 changes: 2 additions & 1 deletion x11/gnome-mag/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.12 2005/03/22 16:32:14 jmmv Exp $
$NetBSD: distinfo,v 1.13 2005/04/12 00:52:49 rillig Exp $

SHA1 (gnome-mag-0.12.0.tar.bz2) = 5dbbb5246d6f0d58d0b8325ac0c03256a4651a53
RMD160 (gnome-mag-0.12.0.tar.bz2) = 361c079bf7f6fd814ff17759a7af65699bfa7efc
Size (gnome-mag-0.12.0.tar.bz2) = 327407 bytes
SHA1 (patch-aa) = 20ad89bfabb3f0804a5d18ad0d2004d27202e277
SHA1 (patch-ab) = a228bbc32eadbed51a84961874c56ae2c23ffd86
16 changes: 16 additions & 0 deletions x11/gnome-mag/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1 2005/04/12 00:52:49 rillig Exp $

Needed for gcc-2.95.

--- magnifier/magnifier.c.orig Fri Feb 4 19:15:59 2005
+++ magnifier/magnifier.c Mon Apr 11 01:33:34 2005
@@ -675,8 +675,8 @@ magnifier_get_display_rect_bounds (Magni
static void magnifier_adjust_source_size (Magnifier *magnifier)
{
GNOME_Magnifier_RectBounds rect_bounds;
- magnifier_get_display_rect_bounds (magnifier, &rect_bounds, FALSE);
gdouble vfract, hfract;
+ magnifier_get_display_rect_bounds (magnifier, &rect_bounds, FALSE);
hfract = (double) (magnifier->target_bounds.x2 - magnifier->target_bounds.x1) / (double) (rect_bounds.x2 - rect_bounds.x1);
vfract = (double) (magnifier->target_bounds.y2 - magnifier->target_bounds.y1) / (double) (rect_bounds.y2 - rect_bounds.y1);
if (vfract > hfract) /* vertical splitpane, approximately */
3 changes: 2 additions & 1 deletion x11/gnome2-control-center/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.18 2005/03/22 16:17:10 jmmv Exp $
$NetBSD: distinfo,v 1.19 2005/04/12 00:56:19 rillig Exp $

SHA1 (control-center-2.10.0.tar.bz2) = 586eaac12d2646ea4fbc5286c5d0d23839457e06
RMD160 (control-center-2.10.0.tar.bz2) = 105a409eb7b74a78cb5d1999aa35ce338c1fc749
Expand All @@ -7,3 +7,4 @@ SHA1 (patch-aa) = 826bd6ef91135a61a86450ff150662156c833ae8
SHA1 (patch-ab) = a522bf7b8d1108b2350bbc35125bc794a1fb0ac7
SHA1 (patch-ac) = 0bec26fa35730ddd706ec8e80855d1bc72b1dd7d
SHA1 (patch-ad) = 15aeffd62733036840d402f1ed3a2f1a89c8945d
SHA1 (patch-ae) = 1c6e2ff7ca214c5cca74d6447a01eed718a79b4a
34 changes: 34 additions & 0 deletions x11/gnome2-control-center/patches/patch-ae
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
$NetBSD: patch-ae,v 1.1 2005/04/12 00:56:19 rillig Exp $

Needed for gcc-2.95.

--- capplets/keyboard/gnome-keyboard-properties-xkbot.c.orig Thu Jan 20 00:16:13 2005
+++ capplets/keyboard/gnome-keyboard-properties-xkbot.c Sat Apr 9 14:00:39 2005
@@ -243,20 +243,22 @@ xkb_options_add_group (const XklConfigIt
GladeXML * dialog)
{
GSList * expanders_list = g_object_get_data (G_OBJECT (dialog), EXPANDERS_PROP);
+ gchar *utfGroupName, *titlemarkup;
+ GtkWidget *expander, *align, *vbox;

current1stLevelId = configItem->name;

- gchar *utfGroupName = xci_desc_to_utf8 (configItem);
- gchar *titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL);
+ utfGroupName = xci_desc_to_utf8 (configItem);
+ titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL);

- GtkWidget *expander = gtk_expander_new (titlemarkup);
+ expander = gtk_expander_new (titlemarkup);
g_object_set_data_full (G_OBJECT (expander), "utfGroupName", utfGroupName, g_free);

g_free (titlemarkup);
gtk_expander_set_use_markup (GTK_EXPANDER (expander), TRUE);
- GtkWidget *align = gtk_alignment_new (0, 0, 1, 1);
+ align = gtk_alignment_new (0, 0, 1, 1);
gtk_alignment_set_padding (GTK_ALIGNMENT (align), 6, 12, 12, 0);
- GtkWidget *vbox = gtk_vbox_new (TRUE, 6);
+ vbox = gtk_vbox_new (TRUE, 6);
gtk_container_add (GTK_CONTAINER (align), vbox);
gtk_container_add (GTK_CONTAINER (expander), align);
currentVbox = vbox;

0 comments on commit 9c97b4f

Please sign in to comment.