-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Added a patch needed for gcc-2.95. Approved by jlam.
- Loading branch information
Showing
6 changed files
with
80 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.16 2005/03/22 16:30:14 jmmv Exp $ | ||
$NetBSD: distinfo,v 1.17 2005/04/12 00:51:22 rillig Exp $ | ||
|
||
SHA1 (gcalctool-5.5.41.tar.bz2) = 15e241aad6cbedf7c2d972bb633b21eabc05f5b8 | ||
RMD160 (gcalctool-5.5.41.tar.bz2) = ccc1f2e7de6e5edb451ac3fa0e323af9a62170ac | ||
Size (gcalctool-5.5.41.tar.bz2) = 1043027 bytes | ||
SHA1 (patch-aa) = ae3c2d5bfa1188987330825ef5123ae621aaf938 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
$NetBSD: patch-aa,v 1.7 2005/04/12 00:51:22 rillig Exp $ | ||
|
||
Needed for gcc-2.95. | ||
|
||
--- gcalctool/functions.c.orig Fri Feb 18 17:20:50 2005 | ||
+++ gcalctool/functions.c Mon Apr 11 00:52:32 2005 | ||
@@ -311,8 +311,6 @@ str_replace(char **str, char *from, char | ||
void | ||
trig_filter(char **func) | ||
{ | ||
- assert(func); | ||
- | ||
enum mode { | ||
normal = 0, | ||
inv = 1, | ||
@@ -322,6 +320,8 @@ trig_filter(char **func) | ||
|
||
int inverse; | ||
int hyperbolic; | ||
+ | ||
+ assert(func); | ||
|
||
inverse = (v->inverse) ? inv : 0; | ||
hyperbolic = (v->hyperbolic) ? hyp : 0; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,7 @@ | ||
$NetBSD: distinfo,v 1.12 2005/03/22 16:32:14 jmmv Exp $ | ||
$NetBSD: distinfo,v 1.13 2005/04/12 00:52:49 rillig Exp $ | ||
|
||
SHA1 (gnome-mag-0.12.0.tar.bz2) = 5dbbb5246d6f0d58d0b8325ac0c03256a4651a53 | ||
RMD160 (gnome-mag-0.12.0.tar.bz2) = 361c079bf7f6fd814ff17759a7af65699bfa7efc | ||
Size (gnome-mag-0.12.0.tar.bz2) = 327407 bytes | ||
SHA1 (patch-aa) = 20ad89bfabb3f0804a5d18ad0d2004d27202e277 | ||
SHA1 (patch-ab) = a228bbc32eadbed51a84961874c56ae2c23ffd86 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
$NetBSD: patch-ab,v 1.1 2005/04/12 00:52:49 rillig Exp $ | ||
|
||
Needed for gcc-2.95. | ||
|
||
--- magnifier/magnifier.c.orig Fri Feb 4 19:15:59 2005 | ||
+++ magnifier/magnifier.c Mon Apr 11 01:33:34 2005 | ||
@@ -675,8 +675,8 @@ magnifier_get_display_rect_bounds (Magni | ||
static void magnifier_adjust_source_size (Magnifier *magnifier) | ||
{ | ||
GNOME_Magnifier_RectBounds rect_bounds; | ||
- magnifier_get_display_rect_bounds (magnifier, &rect_bounds, FALSE); | ||
gdouble vfract, hfract; | ||
+ magnifier_get_display_rect_bounds (magnifier, &rect_bounds, FALSE); | ||
hfract = (double) (magnifier->target_bounds.x2 - magnifier->target_bounds.x1) / (double) (rect_bounds.x2 - rect_bounds.x1); | ||
vfract = (double) (magnifier->target_bounds.y2 - magnifier->target_bounds.y1) / (double) (rect_bounds.y2 - rect_bounds.y1); | ||
if (vfract > hfract) /* vertical splitpane, approximately */ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
$NetBSD: patch-ae,v 1.1 2005/04/12 00:56:19 rillig Exp $ | ||
|
||
Needed for gcc-2.95. | ||
|
||
--- capplets/keyboard/gnome-keyboard-properties-xkbot.c.orig Thu Jan 20 00:16:13 2005 | ||
+++ capplets/keyboard/gnome-keyboard-properties-xkbot.c Sat Apr 9 14:00:39 2005 | ||
@@ -243,20 +243,22 @@ xkb_options_add_group (const XklConfigIt | ||
GladeXML * dialog) | ||
{ | ||
GSList * expanders_list = g_object_get_data (G_OBJECT (dialog), EXPANDERS_PROP); | ||
+ gchar *utfGroupName, *titlemarkup; | ||
+ GtkWidget *expander, *align, *vbox; | ||
|
||
current1stLevelId = configItem->name; | ||
|
||
- gchar *utfGroupName = xci_desc_to_utf8 (configItem); | ||
- gchar *titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL); | ||
+ utfGroupName = xci_desc_to_utf8 (configItem); | ||
+ titlemarkup = g_strconcat ("<span>", utfGroupName, "</span>", NULL); | ||
|
||
- GtkWidget *expander = gtk_expander_new (titlemarkup); | ||
+ expander = gtk_expander_new (titlemarkup); | ||
g_object_set_data_full (G_OBJECT (expander), "utfGroupName", utfGroupName, g_free); | ||
|
||
g_free (titlemarkup); | ||
gtk_expander_set_use_markup (GTK_EXPANDER (expander), TRUE); | ||
- GtkWidget *align = gtk_alignment_new (0, 0, 1, 1); | ||
+ align = gtk_alignment_new (0, 0, 1, 1); | ||
gtk_alignment_set_padding (GTK_ALIGNMENT (align), 6, 12, 12, 0); | ||
- GtkWidget *vbox = gtk_vbox_new (TRUE, 6); | ||
+ vbox = gtk_vbox_new (TRUE, 6); | ||
gtk_container_add (GTK_CONTAINER (align), vbox); | ||
gtk_container_add (GTK_CONTAINER (expander), align); | ||
currentVbox = vbox; |