Skip to content

Commit

Permalink
Rename print/cups to print/cups-base to depend on cups-filters
Browse files Browse the repository at this point in the history
This change:
- renames print/cups to print/cups-base,
- lets print/cups-filters depend on print/cups-base instead of cups,
- adds a package print/cups depending on print/cups-base and
  print/cups-filters.

This makes sure installing print/cups always installs
print/cups-filters, as it is necessary for being able to print outside
of Mac OS X since CUPS 1.6.0. You're welcome.

I do not think superseding is necessary, since print/cups will also
install print/cups-base, which really is the same as before. In practice
it is like a new dependency. I do not want to risk a bad "cvs import"
either, sorry.

Bumps PKGREVISION for print/cups and print/cups-filters, since they have
new dependencies now. This is also necessary for everything else currently
depending on print/cups; I will try to commit this right after this one.

Tested on NetBSD/amd64, as reviewed on tech-pkg@.
No breakage observed, apologies if anything goes wrong.
  • Loading branch information
khorben committed Nov 12, 2017
1 parent cbee1d7 commit 9dfb097
Show file tree
Hide file tree
Showing 38 changed files with 285 additions and 224 deletions.
12 changes: 12 additions & 0 deletions print/cups-base/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
The Common UNIX Printing System provides a portable printing layer for
UNIX operating systems. It has been developed by Easy Software Products
to promote a standard printing solution for all UNIX vendors and users.
CUPS provides the System V and Berkeley command-line interfaces.

CUPS uses the Internet Printing Protocol (IETF-IPP) as the basis for
managing print jobs and queues. The Line Printer Daemon (LPD, RFC1179)
and AppSocket protocols are also supported with reduced functionality.

CUPS adds network printer browsing and PostScript Printer Description
("PPD")-based printing options to support real world applications under
UNIX.
2 changes: 1 addition & 1 deletion print/cups/MESSAGE → print/cups-base/MESSAGE
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
===========================================================================
$NetBSD: MESSAGE,v 1.10 2008/12/14 17:17:55 ahoka Exp $
$NetBSD: MESSAGE,v 1.1 2017/11/12 14:10:15 khorben Exp $

You will need to also install print/ghostscript if you wish to
print to non-Postscript printers.
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
===========================================================================
$NetBSD: MESSAGE.libusb,v 1.2 2010/06/10 10:28:35 gdt Exp $
$NetBSD: MESSAGE.libusb,v 1.1 2017/11/12 14:10:15 khorben Exp $

With cups 1.4 from pkgsrc, USB printing can use libusb in addition to
traditional USB printer devices.
Expand Down
2 changes: 1 addition & 1 deletion print/cups/MESSAGE.pam → print/cups-base/MESSAGE.pam
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
===========================================================================
$NetBSD: MESSAGE.pam,v 1.2 2002/09/24 12:30:32 wiz Exp $
$NetBSD: MESSAGE.pam,v 1.1 2017/11/12 14:10:15 khorben Exp $

To authenticate for CUPS using PAM, add the contents of the file:

Expand Down
176 changes: 176 additions & 0 deletions print/cups-base/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,176 @@
# $NetBSD: Makefile,v 1.1 2017/11/12 14:10:15 khorben Exp $

.include "../../print/cups/Makefile.common"

DISTNAME= cups-${CUPS_VERS}-source
PKGNAME= cups-base-${CUPS_VERS}
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GITHUB:=apple/}

MAINTAINER= [email protected]
HOMEPAGE= https://www.cups.org/
COMMENT= Common UNIX Printing System
LICENSE= gnu-gpl-v2 AND gnu-lgpl-v2

GITHUB_RELEASE= v${PKGVERSION_NOREV}

CONFLICTS+= LPRng-[0-9]* LPRng-core-[0-9]*

WRKSRC= ${WRKDIR}/${DISTNAME:S/-source//}
UNLIMIT_RESOURCES= datasize memorysize
USE_LANGUAGES= c c++ # pdftops is a C++ application
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= aclocal autoconf automake gmake pkg-config

GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localedir=${PREFIX}/${PKGLOCALEDIR}/locale
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR}
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
CONFIGURE_ARGS+= --with-cachedir=${CUPS_CACHE:Q}
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/cups
CONFIGURE_ARGS+= --with-serverbindir=${PREFIX}/libexec/cups
CONFIGURE_ARGS+= --with-cups-user=${CUPS_USER}
CONFIGURE_ARGS+= --with-cups-group=${CUPS_GROUP}
CONFIGURE_ARGS+= --with-system-groups=${CUPS_SYSTEM_GROUPS:Q}
CONFIGURE_ARGS+= --with-exe-file-perm=0755
CONFIGURE_ARGS+= --enable-libpaper
CONFIGURE_ARGS+= --enable-libtool
CONFIGURE_ARGS+= --enable-ssl
CONFIGURE_ARGS+= --with-manext=bsd
CONFIGURE_ARGS+= --without-bundledir
CONFIGURE_ARGS+= --without-icondir
CONFIGURE_ARGS+= --without-menudir
CONFIGURE_ARGS+= --without-perl
CONFIGURE_ARGS+= --without-php
CONFIGURE_ARGS+= --without-python
CONFIGURE_ARGS+= --without-java
CONFIGURE_ARGS+= --disable-gssapi

CONFIGURE_ENV+= DSOFLAGS=${LDFLAGS:M*:Q}

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

.if ${OPSYS} == "SunOS"
LIBS_SSP= -lssp_nonshared -lssp
CONFIGURE_ENV+= LIBS_SSP=${LIBS_SSP:M*:Q}
# Explicitly disable epoll on illumos, it is provided for Linux compat only.
CONFIGURE_ENV+= ac_cv_func_epoll_create=no
.endif
LIBS+= ${BUILDLINK_LDADD.iconv}

# Avoid the following error when compiling with clang.
# /usr/local/bin/ld: /usr/lib/crt1.o: relocation R_X86_64_32 against `_DYNAMIC'
# can not be used when making a shared object; recompile with -fPIC
BUILDLINK_TRANSFORM.FreeBSD+= rm:-Wl,-pie

# CUPS_USER user to run filter and CGI programs as
# CUPS_GROUP group to run filter and CGI programs as
# CUPS_SYSTEM_GROUPS group for system administration
#
CUPS_USER?= lp
CUPS_GROUP?= lp
CUPS_SYSTEM_GROUPS?= ${REAL_ROOT_GROUP}
FILES_SUBST+= CUPS_USER=${CUPS_USER}
FILES_SUBST+= CUPS_GROUP=${CUPS_GROUP}
FILES_SUBST+= CUPS_SYSTEM_GROUPS=${CUPS_SYSTEM_GROUPS:Q}

PKG_GROUPS_VARS+= CUPS_GROUP CUPS_SYSTEM_GROUPS
PKG_USERS_VARS= CUPS_USER

BUILD_DEFS+= CUPS_USER CUPS_GROUP CUPS_SYSTEM_GROUPS VARBASE

DOCDIR= ${PREFIX}/share/doc/cups
EGDIR= ${PREFIX}/share/examples/cups
MIMEDIR= ${PREFIX}/share/cups/mime
PKG_SYSCONFSUBDIR= cups
CUPS_CONFDIR= ${PKG_SYSCONFDIR}
CUPS_LOGDIR= ${VARBASE}/log/cups
CUPS_REQUESTS= ${VARBASE}/spool/cups
CUPS_CACHE= ${VARBASE}/cache/cups
CUPS_STATEDIR= ${VARBASE}/run/cups

PKG_GROUPS= ${CUPS_GROUP}
PKG_USERS= ${CUPS_USER}:${CUPS_GROUP}
PKG_GECOS.${CUPS_USER}= Common UNIX Printing System user
PKG_SHELL.${CUPS_USER}= ${SH}

CONF_FILES+= ${EGDIR}/cupsd.conf ${CUPS_CONFDIR}/cupsd.conf
CONF_FILES+= ${EGDIR}/cups-files.conf ${CUPS_CONFDIR}/cups-files.conf
CONF_FILES+= ${EGDIR}/snmp.conf ${CUPS_CONFDIR}/snmp.conf
RCD_SCRIPTS= cupsd

OWN_DIRS= ${CUPS_CONFDIR}
OWN_DIRS+= ${CUPS_CONFDIR}/interfaces
OWN_DIRS+= ${CUPS_CONFDIR}/ppd
OWN_DIRS+= ${PREFIX}/libexec/cups/driver
OWN_DIRS+= ${CUPS_LOGDIR}
OWN_DIRS+= ${CUPS_STATEDIR}
OWN_DIRS_PERMS= ${CUPS_STATEDIR}/certs ${CUPS_USER} ${CUPS_GROUP} 0711
OWN_DIRS_PERMS+= ${CUPS_CONFDIR}/ssl ${REAL_ROOT_USER} ${CUPS_GROUP} 0700
OWN_DIRS_PERMS+= ${CUPS_REQUESTS} ${REAL_ROOT_USER} ${CUPS_GROUP} 0710
OWN_DIRS_PERMS+= ${CUPS_REQUESTS}/tmp ${REAL_ROOT_USER} ${CUPS_GROUP} 1770
OWN_DIRS_PERMS+= ${CUPS_CACHE} ${REAL_ROOT_USER} ${CUPS_GROUP} 0775
OWN_DIRS_PERMS+= ${CUPS_CACHE}/rss ${REAL_ROOT_USER} ${CUPS_GROUP} 0775

SUBST_CLASSES+= paths
SUBST_FILES.paths= ${WRKDIR}/cups.pam
SUBST_SED.paths+= -e 's,@LOCALBASE@,${LOCALBASE},g'
SUBST_STAGE.paths= post-patch

SUBST_CLASSES+= rpathfix
SUBST_FILES.rpathfix= cups-config.in
SUBST_MESSAGE.rpathfix= Adding rpath to cups-config.
SUBST_SED.rpathfix= -e 's|@EXPORT_LDFLAGS@|${COMPILER_RPATH_FLAG}${PREFIX}/lib|g'
SUBST_STAGE.rpathfix= post-patch

.if !empty(OPSYS:MNetBSD) && !empty(MACHINE_ARCH:Mpowerpc)
SUBST_CLASSES+= piefix
SUBST_FILES.piefix= Makedefs.in
SUBST_MESSAGE.piefix= Removing PIE flags
SUBST_SED.piefix= -e 's|@PIEFLAGS@||g'
SUBST_STAGE.piefix= post-patch
.endif

INSTALLATION_DIRS= ${DOCDIR} ${EGDIR} ${MIMEDIR}
INSTALL_ENV+= DSTROOT=${DESTDIR}

pre-configure:
.if !empty(CUPS_SYSTEM_GROUPS:M${CUPS_GROUP})
${ERROR_MSG} "CUPS_SYSTEM_GROUPS may not contain the CUPS_GROUP"
exit 1
.endif
cd ${WRKSRC} && aclocal && autoconf

post-extract:
${CP} ${FILESDIR}/cups.pam ${WRKDIR}/cups.pam

post-install:
set -e; for file in LICENSE.txt README.md; do \
${INSTALL_DATA} ${WRKSRC}/$${file} \
${DESTDIR}${DOCDIR}/$${file}; \
done
${RUN} for file in cupsd.conf cups-files.conf snmp.conf ; do \
${INSTALL_DATA} ${WRKSRC}/conf/$${file} \
${DESTDIR}${EGDIR}/$${file}; \
done
${CHMOD} g-w ${DESTDIR}${PREFIX}/libexec/cups/cgi-bin
.if !empty(PKG_OPTIONS:Mpam)
${INSTALL_DATA} ${WRKDIR}/cups.pam ${DESTDIR}${EGDIR}
.endif
.if !empty(PKG_OPTIONS:Mdnssd)
${LN} -sf ${DESTDIR}${PREFIX}/libexec/cups/backend/dnssd ${DESTDIR}${PREFIX}/libexec/cups/backend/mdns
.endif

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../print/libpaper/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../textproc/libunistring/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
2 changes: 1 addition & 1 deletion print/cups/PLIST → print/cups-base/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.60 2017/10/23 12:34:54 leot Exp $
@comment $NetBSD: PLIST,v 1.1 2017/11/12 14:10:15 khorben Exp $
bin/cancel
bin/cups-config
bin/cupstestdsc
Expand Down
33 changes: 33 additions & 0 deletions print/cups-base/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# $NetBSD: buildlink3.mk,v 1.1 2017/11/12 14:10:15 khorben Exp $

BUILDLINK_TREE+= cups-base

.if !defined(CUPS_BASE_BUILDLINK3_MK)
CUPS_BASE_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.cups-base+= cups-base>=1.1.19nb3
BUILDLINK_ABI_DEPENDS.cups-base+= cups-base>=2.2.2nb2
BUILDLINK_PKGSRCDIR.cups-base?= ../../print/cups-base

pkgbase := cups-base
.include "../../mk/pkg-build-options.mk"

.if !empty(PKG_BUILD_OPTIONS.cups:Mkerberos)
.include "../../mk/krb5.buildlink3.mk"
.endif

.if !empty(PKG_BUILD_OPTIONS.cups:Mdnssd)
.include "../../net/mDNSResponder/buildlink3.mk"
.endif

.if ${OPSYS} != "Darwin" && !empty(PKG_BUILD_OPTIONS.cups:Mavahi)
.include "../../net/avahi/buildlink3.mk"
.endif

.include "../../converters/libiconv/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.endif # CUPS_BASE_BUILDLINK3_MK

BUILDLINK_TREE+= -cups-base
2 changes: 1 addition & 1 deletion print/cups/distinfo → print/cups-base/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.125 2017/10/23 12:34:54 leot Exp $
$NetBSD: distinfo,v 1.1 2017/11/12 14:10:15 khorben Exp $

SHA1 (cups-2.2.5-source.tar.gz) = b6b1967e0329768708f89b42adb4c6810a77a195
RMD160 (cups-2.2.5-source.tar.gz) = fc69142955bfdf30668598ca2c8dcb553ea8eaee
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: cups.pam,v 1.2 2002/10/20 18:57:38 jlam Exp $
# $NetBSD: cups.pam,v 1.1 2017/11/12 14:10:15 khorben Exp $
#
# PAM configuration for Common UNIX Printing System
#
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: cupsd.sh,v 1.22 2017/07/27 08:54:26 wiz Exp $
# $NetBSD: cupsd.sh,v 1.1 2017/11/12 14:10:15 khorben Exp $
#
# Common UNIX Printing System daemon
#
Expand Down
2 changes: 1 addition & 1 deletion print/cups/options.mk → print/cups-base/options.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.21 2017/02/17 23:45:48 wiz Exp $
# $NetBSD: options.mk,v 1.1 2017/11/12 14:10:15 khorben Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.cups
PKG_SUPPORTED_OPTIONS= acl dnssd kerberos pam tcpwrappers
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ae,v 1.35 2017/10/23 12:34:54 leot Exp $
$NetBSD: patch-ae,v 1.1 2017/11/12 14:10:15 khorben Exp $

- Do not pass `-z' option to install(1)
- Honor optimization flags.
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-af,v 1.24 2016/01/03 19:56:18 bsiegert Exp $
$NetBSD: patch-af,v 1.1 2017/11/12 14:10:15 khorben Exp $

* Remove unneeded $(LIBTOOL), it's now in $(INSTALL_BIN).

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ai,v 1.20 2014/06/07 07:34:05 wiz Exp $
$NetBSD: patch-ai,v 1.1 2017/11/12 14:10:15 khorben Exp $

Don't create directories, do that with OWN_DIRS and OWN_DIRS_PERMS

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-at,v 1.14 2015/12/02 21:14:16 leot Exp $
$NetBSD: patch-at,v 1.1 2017/11/12 14:10:15 khorben Exp $

Don't create directories, do that with OWN_DIRS and OWN_DIRS_PERMS

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-conf-cups-files.conf.in,v 1.1 2017/07/27 08:54:26 wiz Exp $
$NetBSD: patch-conf-cups-files.conf.in,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-conf_Makefile,v 1.4 2015/09/03 21:15:41 wiz Exp $
$NetBSD: patch-conf_Makefile,v 1.1 2017/11/12 14:10:15 khorben Exp $

Don't install the config files (leave it up to pkgsrc).

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-config-scripts_cups-compiler.m4,v 1.4 2017/09/03 11:30:54 leot Exp $
$NetBSD: patch-config-scripts_cups-compiler.m4,v 1.1 2017/11/12 14:10:15 khorben Exp $

Some builds of gcc seem to support this for compiling but then fail during
linking with undefined reference to `__stack_chk_fail_local'
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-config-scripts_cups-directories.m4,v 1.4 2017/09/03 11:30:54 leot Exp $
$NetBSD: patch-config-scripts_cups-directories.m4,v 1.1 2017/11/12 14:10:15 khorben Exp $

The '$' while loops expand the variables as long as possible so that no
references to other variables occur. This is necessary because fontpath
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-config-scripts_cups-gssapi.m4,v 1.6 2017/09/03 11:30:54 leot Exp $
$NetBSD: patch-config-scripts_cups-gssapi.m4,v 1.1 2017/11/12 14:10:15 khorben Exp $

builtin krb5-config in platforms such as solaris do not support
the gssapi option, and need an explicit -lgss
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-config-scripts_cups-libtool.m4,v 1.1 2017/10/23 12:34:54 leot Exp $
$NetBSD: patch-config-scripts_cups-libtool.m4,v 1.1 2017/11/12 14:10:15 khorben Exp $

Fix non-portable `==' test(1) operator.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-config-scripts_cups-manpages.m4,v 1.5 2017/09/03 11:30:54 leot Exp $
$NetBSD: patch-config-scripts_cups-manpages.m4,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add '--with-manext' configure option.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-cups-tls.c,v 1.2 2015/12/02 21:14:16 leot Exp $
$NetBSD: patch-cups-tls.c,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add missing stub.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-doc-help-man-cups-files.conf.html,v 1.1 2017/07/27 08:54:26 wiz Exp $
$NetBSD: patch-doc-help-man-cups-files.conf.html,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-man-cups-files.conf.man.in,v 1.1 2017/07/27 08:54:26 wiz Exp $
$NetBSD: patch-man-cups-files.conf.man.in,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ppdc_Makefile,v 1.4 2017/10/23 12:34:54 leot Exp $
$NetBSD: patch-ppdc_Makefile,v 1.1 2017/11/12 14:10:15 khorben Exp $

--- ppdc/Makefile.orig 2017-10-13 18:22:26.000000000 +0000
+++ ppdc/Makefile
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-scheduler-conf.c,v 1.1 2017/07/27 08:54:26 wiz Exp $
$NetBSD: patch-scheduler-conf.c,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-scheduler-conf.h,v 1.1 2017/07/27 08:54:26 wiz Exp $
$NetBSD: patch-scheduler-conf.h,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-scheduler-main.c,v 1.3 2017/10/23 12:34:54 leot Exp $
$NetBSD: patch-scheduler-main.c,v 1.1 2017/11/12 14:10:15 khorben Exp $

Add a PidFile configuration directive to write a PID file.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-scheduler_auth.c,v 1.5 2015/12/02 21:14:16 leot Exp $
$NetBSD: patch-scheduler_auth.c,v 1.1 2017/11/12 14:10:15 khorben Exp $

Don't pull in sys/ucred.h on Solaris as it results in procfs.h being
included and conflicts between _FILE_OFFSET_BITS=64 and 32-bit procfs.
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-scheduler_dirsvc.c,v 1.6 2015/12/02 21:14:16 leot Exp $
$NetBSD: patch-scheduler_dirsvc.c,v 1.1 2017/11/12 14:10:15 khorben Exp $

o net/mDNSResponder-258.14 does not define kDNSServiceErr_Timeout, just threat
it like kDNSServiceErr_Unknown.
Expand Down
Loading

0 comments on commit 9dfb097

Please sign in to comment.