-
Notifications
You must be signed in to change notification settings - Fork 162
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Rename print/cups to print/cups-base to depend on cups-filters
This change: - renames print/cups to print/cups-base, - lets print/cups-filters depend on print/cups-base instead of cups, - adds a package print/cups depending on print/cups-base and print/cups-filters. This makes sure installing print/cups always installs print/cups-filters, as it is necessary for being able to print outside of Mac OS X since CUPS 1.6.0. You're welcome. I do not think superseding is necessary, since print/cups will also install print/cups-base, which really is the same as before. In practice it is like a new dependency. I do not want to risk a bad "cvs import" either, sorry. Bumps PKGREVISION for print/cups and print/cups-filters, since they have new dependencies now. This is also necessary for everything else currently depending on print/cups; I will try to commit this right after this one. Tested on NetBSD/amd64, as reviewed on tech-pkg@. No breakage observed, apologies if anything goes wrong.
- Loading branch information
Showing
38 changed files
with
285 additions
and
224 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
The Common UNIX Printing System provides a portable printing layer for | ||
UNIX operating systems. It has been developed by Easy Software Products | ||
to promote a standard printing solution for all UNIX vendors and users. | ||
CUPS provides the System V and Berkeley command-line interfaces. | ||
|
||
CUPS uses the Internet Printing Protocol (IETF-IPP) as the basis for | ||
managing print jobs and queues. The Line Printer Daemon (LPD, RFC1179) | ||
and AppSocket protocols are also supported with reduced functionality. | ||
|
||
CUPS adds network printer browsing and PostScript Printer Description | ||
("PPD")-based printing options to support real world applications under | ||
UNIX. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,176 @@ | ||
# $NetBSD: Makefile,v 1.1 2017/11/12 14:10:15 khorben Exp $ | ||
|
||
.include "../../print/cups/Makefile.common" | ||
|
||
DISTNAME= cups-${CUPS_VERS}-source | ||
PKGNAME= cups-base-${CUPS_VERS} | ||
CATEGORIES= print | ||
MASTER_SITES= ${MASTER_SITE_GITHUB:=apple/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= https://www.cups.org/ | ||
COMMENT= Common UNIX Printing System | ||
LICENSE= gnu-gpl-v2 AND gnu-lgpl-v2 | ||
|
||
GITHUB_RELEASE= v${PKGVERSION_NOREV} | ||
|
||
CONFLICTS+= LPRng-[0-9]* LPRng-core-[0-9]* | ||
|
||
WRKSRC= ${WRKDIR}/${DISTNAME:S/-source//} | ||
UNLIMIT_RESOURCES= datasize memorysize | ||
USE_LANGUAGES= c c++ # pdftops is a C++ application | ||
USE_LIBTOOL= yes | ||
USE_PKGLOCALEDIR= yes | ||
USE_TOOLS+= aclocal autoconf automake gmake pkg-config | ||
|
||
GNU_CONFIGURE= yes | ||
CONFIGURE_ARGS+= --localedir=${PREFIX}/${PKGLOCALEDIR}/locale | ||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR} | ||
CONFIGURE_ARGS+= --localstatedir=${VARBASE} | ||
CONFIGURE_ARGS+= --with-cachedir=${CUPS_CACHE:Q} | ||
CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/cups | ||
CONFIGURE_ARGS+= --with-serverbindir=${PREFIX}/libexec/cups | ||
CONFIGURE_ARGS+= --with-cups-user=${CUPS_USER} | ||
CONFIGURE_ARGS+= --with-cups-group=${CUPS_GROUP} | ||
CONFIGURE_ARGS+= --with-system-groups=${CUPS_SYSTEM_GROUPS:Q} | ||
CONFIGURE_ARGS+= --with-exe-file-perm=0755 | ||
CONFIGURE_ARGS+= --enable-libpaper | ||
CONFIGURE_ARGS+= --enable-libtool | ||
CONFIGURE_ARGS+= --enable-ssl | ||
CONFIGURE_ARGS+= --with-manext=bsd | ||
CONFIGURE_ARGS+= --without-bundledir | ||
CONFIGURE_ARGS+= --without-icondir | ||
CONFIGURE_ARGS+= --without-menudir | ||
CONFIGURE_ARGS+= --without-perl | ||
CONFIGURE_ARGS+= --without-php | ||
CONFIGURE_ARGS+= --without-python | ||
CONFIGURE_ARGS+= --without-java | ||
CONFIGURE_ARGS+= --disable-gssapi | ||
|
||
CONFIGURE_ENV+= DSOFLAGS=${LDFLAGS:M*:Q} | ||
|
||
.include "../../mk/bsd.prefs.mk" | ||
.include "options.mk" | ||
|
||
.if ${OPSYS} == "SunOS" | ||
LIBS_SSP= -lssp_nonshared -lssp | ||
CONFIGURE_ENV+= LIBS_SSP=${LIBS_SSP:M*:Q} | ||
# Explicitly disable epoll on illumos, it is provided for Linux compat only. | ||
CONFIGURE_ENV+= ac_cv_func_epoll_create=no | ||
.endif | ||
LIBS+= ${BUILDLINK_LDADD.iconv} | ||
|
||
# Avoid the following error when compiling with clang. | ||
# /usr/local/bin/ld: /usr/lib/crt1.o: relocation R_X86_64_32 against `_DYNAMIC' | ||
# can not be used when making a shared object; recompile with -fPIC | ||
BUILDLINK_TRANSFORM.FreeBSD+= rm:-Wl,-pie | ||
|
||
# CUPS_USER user to run filter and CGI programs as | ||
# CUPS_GROUP group to run filter and CGI programs as | ||
# CUPS_SYSTEM_GROUPS group for system administration | ||
# | ||
CUPS_USER?= lp | ||
CUPS_GROUP?= lp | ||
CUPS_SYSTEM_GROUPS?= ${REAL_ROOT_GROUP} | ||
FILES_SUBST+= CUPS_USER=${CUPS_USER} | ||
FILES_SUBST+= CUPS_GROUP=${CUPS_GROUP} | ||
FILES_SUBST+= CUPS_SYSTEM_GROUPS=${CUPS_SYSTEM_GROUPS:Q} | ||
|
||
PKG_GROUPS_VARS+= CUPS_GROUP CUPS_SYSTEM_GROUPS | ||
PKG_USERS_VARS= CUPS_USER | ||
|
||
BUILD_DEFS+= CUPS_USER CUPS_GROUP CUPS_SYSTEM_GROUPS VARBASE | ||
|
||
DOCDIR= ${PREFIX}/share/doc/cups | ||
EGDIR= ${PREFIX}/share/examples/cups | ||
MIMEDIR= ${PREFIX}/share/cups/mime | ||
PKG_SYSCONFSUBDIR= cups | ||
CUPS_CONFDIR= ${PKG_SYSCONFDIR} | ||
CUPS_LOGDIR= ${VARBASE}/log/cups | ||
CUPS_REQUESTS= ${VARBASE}/spool/cups | ||
CUPS_CACHE= ${VARBASE}/cache/cups | ||
CUPS_STATEDIR= ${VARBASE}/run/cups | ||
|
||
PKG_GROUPS= ${CUPS_GROUP} | ||
PKG_USERS= ${CUPS_USER}:${CUPS_GROUP} | ||
PKG_GECOS.${CUPS_USER}= Common UNIX Printing System user | ||
PKG_SHELL.${CUPS_USER}= ${SH} | ||
|
||
CONF_FILES+= ${EGDIR}/cupsd.conf ${CUPS_CONFDIR}/cupsd.conf | ||
CONF_FILES+= ${EGDIR}/cups-files.conf ${CUPS_CONFDIR}/cups-files.conf | ||
CONF_FILES+= ${EGDIR}/snmp.conf ${CUPS_CONFDIR}/snmp.conf | ||
RCD_SCRIPTS= cupsd | ||
|
||
OWN_DIRS= ${CUPS_CONFDIR} | ||
OWN_DIRS+= ${CUPS_CONFDIR}/interfaces | ||
OWN_DIRS+= ${CUPS_CONFDIR}/ppd | ||
OWN_DIRS+= ${PREFIX}/libexec/cups/driver | ||
OWN_DIRS+= ${CUPS_LOGDIR} | ||
OWN_DIRS+= ${CUPS_STATEDIR} | ||
OWN_DIRS_PERMS= ${CUPS_STATEDIR}/certs ${CUPS_USER} ${CUPS_GROUP} 0711 | ||
OWN_DIRS_PERMS+= ${CUPS_CONFDIR}/ssl ${REAL_ROOT_USER} ${CUPS_GROUP} 0700 | ||
OWN_DIRS_PERMS+= ${CUPS_REQUESTS} ${REAL_ROOT_USER} ${CUPS_GROUP} 0710 | ||
OWN_DIRS_PERMS+= ${CUPS_REQUESTS}/tmp ${REAL_ROOT_USER} ${CUPS_GROUP} 1770 | ||
OWN_DIRS_PERMS+= ${CUPS_CACHE} ${REAL_ROOT_USER} ${CUPS_GROUP} 0775 | ||
OWN_DIRS_PERMS+= ${CUPS_CACHE}/rss ${REAL_ROOT_USER} ${CUPS_GROUP} 0775 | ||
|
||
SUBST_CLASSES+= paths | ||
SUBST_FILES.paths= ${WRKDIR}/cups.pam | ||
SUBST_SED.paths+= -e 's,@LOCALBASE@,${LOCALBASE},g' | ||
SUBST_STAGE.paths= post-patch | ||
|
||
SUBST_CLASSES+= rpathfix | ||
SUBST_FILES.rpathfix= cups-config.in | ||
SUBST_MESSAGE.rpathfix= Adding rpath to cups-config. | ||
SUBST_SED.rpathfix= -e 's|@EXPORT_LDFLAGS@|${COMPILER_RPATH_FLAG}${PREFIX}/lib|g' | ||
SUBST_STAGE.rpathfix= post-patch | ||
|
||
.if !empty(OPSYS:MNetBSD) && !empty(MACHINE_ARCH:Mpowerpc) | ||
SUBST_CLASSES+= piefix | ||
SUBST_FILES.piefix= Makedefs.in | ||
SUBST_MESSAGE.piefix= Removing PIE flags | ||
SUBST_SED.piefix= -e 's|@PIEFLAGS@||g' | ||
SUBST_STAGE.piefix= post-patch | ||
.endif | ||
|
||
INSTALLATION_DIRS= ${DOCDIR} ${EGDIR} ${MIMEDIR} | ||
INSTALL_ENV+= DSTROOT=${DESTDIR} | ||
|
||
pre-configure: | ||
.if !empty(CUPS_SYSTEM_GROUPS:M${CUPS_GROUP}) | ||
${ERROR_MSG} "CUPS_SYSTEM_GROUPS may not contain the CUPS_GROUP" | ||
exit 1 | ||
.endif | ||
cd ${WRKSRC} && aclocal && autoconf | ||
|
||
post-extract: | ||
${CP} ${FILESDIR}/cups.pam ${WRKDIR}/cups.pam | ||
|
||
post-install: | ||
set -e; for file in LICENSE.txt README.md; do \ | ||
${INSTALL_DATA} ${WRKSRC}/$${file} \ | ||
${DESTDIR}${DOCDIR}/$${file}; \ | ||
done | ||
${RUN} for file in cupsd.conf cups-files.conf snmp.conf ; do \ | ||
${INSTALL_DATA} ${WRKSRC}/conf/$${file} \ | ||
${DESTDIR}${EGDIR}/$${file}; \ | ||
done | ||
${CHMOD} g-w ${DESTDIR}${PREFIX}/libexec/cups/cgi-bin | ||
.if !empty(PKG_OPTIONS:Mpam) | ||
${INSTALL_DATA} ${WRKDIR}/cups.pam ${DESTDIR}${EGDIR} | ||
.endif | ||
.if !empty(PKG_OPTIONS:Mdnssd) | ||
${LN} -sf ${DESTDIR}${PREFIX}/libexec/cups/backend/dnssd ${DESTDIR}${PREFIX}/libexec/cups/backend/mdns | ||
.endif | ||
|
||
.include "../../converters/libiconv/buildlink3.mk" | ||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../graphics/png/buildlink3.mk" | ||
.include "../../graphics/tiff/buildlink3.mk" | ||
.include "../../print/libpaper/buildlink3.mk" | ||
.include "../../security/gnutls/buildlink3.mk" | ||
.include "../../textproc/libunistring/buildlink3.mk" | ||
.include "../../mk/curses.buildlink3.mk" | ||
.include "../../mk/jpeg.buildlink3.mk" | ||
.include "../../mk/pthread.buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2017/11/12 14:10:15 khorben Exp $ | ||
|
||
BUILDLINK_TREE+= cups-base | ||
|
||
.if !defined(CUPS_BASE_BUILDLINK3_MK) | ||
CUPS_BASE_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.cups-base+= cups-base>=1.1.19nb3 | ||
BUILDLINK_ABI_DEPENDS.cups-base+= cups-base>=2.2.2nb2 | ||
BUILDLINK_PKGSRCDIR.cups-base?= ../../print/cups-base | ||
|
||
pkgbase := cups-base | ||
.include "../../mk/pkg-build-options.mk" | ||
|
||
.if !empty(PKG_BUILD_OPTIONS.cups:Mkerberos) | ||
.include "../../mk/krb5.buildlink3.mk" | ||
.endif | ||
|
||
.if !empty(PKG_BUILD_OPTIONS.cups:Mdnssd) | ||
.include "../../net/mDNSResponder/buildlink3.mk" | ||
.endif | ||
|
||
.if ${OPSYS} != "Darwin" && !empty(PKG_BUILD_OPTIONS.cups:Mavahi) | ||
.include "../../net/avahi/buildlink3.mk" | ||
.endif | ||
|
||
.include "../../converters/libiconv/buildlink3.mk" | ||
.include "../../graphics/png/buildlink3.mk" | ||
.include "../../graphics/tiff/buildlink3.mk" | ||
.include "../../security/gnutls/buildlink3.mk" | ||
.endif # CUPS_BASE_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -cups-base |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...ups/patches/patch-conf-cups-files.conf.in → ...ase/patches/patch-conf-cups-files.conf.in
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-conf_Makefile → print/cups-base/patches/patch-conf_Makefile
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...hes/patch-config-scripts_cups-compiler.m4 → ...hes/patch-config-scripts_cups-compiler.m4
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
.../patch-config-scripts_cups-directories.m4 → .../patch-config-scripts_cups-directories.m4
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...tches/patch-config-scripts_cups-gssapi.m4 → ...tches/patch-config-scripts_cups-gssapi.m4
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...ches/patch-config-scripts_cups-libtool.m4 → ...ches/patch-config-scripts_cups-libtool.m4
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...hes/patch-config-scripts_cups-manpages.m4 → ...hes/patch-config-scripts_cups-manpages.m4
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-cups-tls.c → print/cups-base/patches/patch-cups-tls.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
...s/patch-doc-help-man-cups-files.conf.html → ...s/patch-doc-help-man-cups-files.conf.html
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
.../patches/patch-man-cups-files.conf.man.in → .../patches/patch-man-cups-files.conf.man.in
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-ppdc_Makefile → print/cups-base/patches/patch-ppdc_Makefile
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-scheduler-conf.c → .../cups-base/patches/patch-scheduler-conf.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-scheduler-conf.h → .../cups-base/patches/patch-scheduler-conf.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-scheduler-main.c → .../cups-base/patches/patch-scheduler-main.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-scheduler_auth.c → .../cups-base/patches/patch-scheduler_auth.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
2 changes: 1 addition & 1 deletion
2
print/cups/patches/patch-scheduler_dirsvc.c → ...ups-base/patches/patch-scheduler_dirsvc.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.