Skip to content

Commit

Permalink
openh264: Support illumos.
Browse files Browse the repository at this point in the history
  • Loading branch information
jperkin committed Nov 7, 2024
1 parent 02f82e0 commit a5f6085
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 1 deletion.
4 changes: 3 additions & 1 deletion multimedia/openh264/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.3 2024/02/02 13:08:51 adam Exp $
$NetBSD: distinfo,v 1.4 2024/11/07 10:48:02 jperkin Exp $

BLAKE2s (openh264-2.4.1.tar.gz) = e0c2a4ce7016d5ff226021f4cd4cdcfd2b67bc63ec36dda2d49a91679a120769
SHA512 (openh264-2.4.1.tar.gz) = eb99144addd2e9c352bb95e752366e104ac6b0ddc84311dc7c87dafb803f8e7fe4d1e726833d49f8cc6d3914508e19c3a25ef82637a4993e8af3f504aa005baf
Size (openh264-2.4.1.tar.gz) = 60297304 bytes
SHA1 (patch-Makefile) = 8dfd1e2bba933ec8280ac8db8b7c661fee64ba47
SHA1 (patch-codec_common_generate__version.sh) = 5f0d3b33c6730e3da824acb503ceb4c84347a320
SHA1 (patch-codec_common_src_WelsThreadLib.cpp) = 06a6154330f58c5cca96ab9c3287258796248aaa
15 changes: 15 additions & 0 deletions multimedia/openh264/patches/patch-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-Makefile,v 1.1 2024/11/07 10:48:03 jperkin Exp $

Support SunOS.

--- Makefile.orig 2024-11-07 10:09:16.629799962 +0000
+++ Makefile
@@ -7,7 +7,7 @@ vpath %.S $(SRC_PATH)
vpath %.rc $(SRC_PATH)
vpath %.pc.in $(SRC_PATH)

-OS=$(shell uname | tr A-Z a-z | tr -d \\-0-9. | sed -E 's/^(net|open|free)bsd/bsd/')
+OS=$(shell uname | tr A-Z a-z | tr -d \\-0-9. | sed -E -e 's/^(net|open|free)bsd/bsd/' -e 's/sunos/bsd/')
ARCH=$(shell uname -m)
LIBPREFIX=lib
LIBSUFFIX=a
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
$NetBSD: patch-codec_common_src_WelsThreadLib.cpp,v 1.1 2024/11/07 10:48:03 jperkin Exp $

Support illumos.

--- codec/common/src/WelsThreadLib.cpp.orig 2024-11-07 10:13:29.225625539 +0000
+++ codec/common/src/WelsThreadLib.cpp
@@ -50,7 +50,7 @@
#include <unistd.h>
#ifdef __EMSCRIPTEN__
#include <emscripten/threading.h>
-#elif !defined(__Fuchsia__)
+#elif !defined(__Fuchsia__) && !defined(__illumos__)
#include <sys/sysctl.h>
#endif
#ifdef __APPLE__
@@ -513,7 +513,7 @@ WELS_THREAD_ERROR_CODE WelsQueryLogic
pInfo->ProcessorCount = emscripten_num_logical_cores();
return WELS_THREAD_ERROR_OK;

-#elif defined(__Fuchsia__)
+#elif defined(__Fuchsia__) || defined(__illumos__)

pInfo->ProcessorCount = sysconf(_SC_NPROCESSORS_ONLN);
return WELS_THREAD_ERROR_OK;

0 comments on commit a5f6085

Please sign in to comment.