-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Added a testcase for the pkgsrc compilers.
- Loading branch information
Showing
3 changed files
with
48 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# $NetBSD: Makefile,v 1.1 2006/07/11 05:03:11 rillig Exp $ | ||
# | ||
|
||
DISTNAME= compiler-1.0 | ||
CATEGORIES= regress | ||
MASTER_SITES= # none | ||
DISTFILES= # none | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Tests whether the pkgsrc compilers work as expected | ||
|
||
NO_CHECKSUM= yes | ||
WRKSRC= ${WRKDIR} | ||
USE_TOOLS+= printf | ||
|
||
SRC_CMD= ${PRINTF} '\#if defined(__cplusplus)\nLANG: Cplus\n\#else\nLANG: Cplain\n\#endif\n' | ||
|
||
do-build: | ||
# Test whether CPP is a C preprocessor. | ||
${SRC_CMD} | ${CPP} -DLANG=Cplain | ||
# Test whether CXXCPP is a C++ preprocessor. | ||
# CXXCPP is not (yet)? defined. | ||
#${SRC_CMD} | ${CXXCPP} -DLANG=Cplus | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# $NetBSD: spec,v 1.1 2006/07/11 05:03:11 rillig Exp $ | ||
# | ||
|
||
do_cleanup() { | ||
|
||
${TEST_MAKE} "clean" | ||
} | ||
|
||
do_test() { | ||
|
||
do_cleanup | ||
|
||
${TEST_MAKE} 1>"${TEST_OUTFILE}" 2>&1 | ||
} | ||
|
||
check_result() { | ||
|
||
exit_status "0" | ||
output_require "^Cplain.*:.*Cplain" | ||
#output_require "^Cplus.*:.*Cplus" | ||
} |