-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
1) Simplify the way how an emacs version is picked when no emacs is installed, but a user try to install an Emacs Lisp package. Just pick up the version set as EMACS_TYPE than searching for versions already installed etc. If the EMACS_TYPE version is not supported by the Emacs Lisp Package, just fail. EMACS_TYPE be default to GNU Emacs 21. (In other words, users should set EMACS_TYPE as they want. Otherwise GNU Emacs 21 is used.) 2) All Emacs Lisp Packages *must* prepend EMACS_PKGNAME_PREFIX to a) the PKGNAME itself, and b) PKGNAME in its dependency lines. EMACS_PKGNAME_PREFIX is expanded to "xemacs-" when XEmacs is used. This keeps dependency graph of Emacs-Lisp-packages- installed-for-XEmacs consistent. 3) Document EMACS_* variables as much as possible. 4) Provide more cookies for PLIST. Maybe utilized later. Note that the 2) change doesn't affect the default, GNU Emacs 21 behaviour. So no version / revision bumps in this commit.
- Loading branch information
uebayasi
committed
Aug 28, 2005
1 parent
6192820
commit aa8e85b
Showing
58 changed files
with
504 additions
and
341 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,16 +1,16 @@ | ||
# $NetBSD: Makefile,v 1.2 2003/07/17 21:24:48 grant Exp $ | ||
# $NetBSD: Makefile,v 1.3 2005/08/28 04:25:28 uebayasi Exp $ | ||
# | ||
|
||
DISTNAME= dinotrace-9.1i | ||
PKGNAME= dinotrace-mode-9.1i | ||
PKGNAME= ${EMACS_PKGNAME_PREFIX}dinotrace-mode-9.1i | ||
CATEGORIES= cad editors | ||
MASTER_SITES= http://www.veripool.com/ftp/ | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://www.veripool.com/dinotrace/ | ||
COMMENT= Emacs major mode for dinotrace | ||
|
||
DEPENDS+= verilog-mode>=3.13:../../cad/verilog-mode | ||
DEPENDS+= ${EMACS_PKGNAME_PREFIX}verilog-mode>=3.13:../../cad/verilog-mode | ||
|
||
.include "../../mk/bsd.prefs.mk" | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,33 +1,30 @@ | ||
# $NetBSD: Makefile,v 1.14 2005/06/16 06:57:48 jlam Exp $ | ||
# $NetBSD: Makefile,v 1.15 2005/08/28 04:25:29 uebayasi Exp $ | ||
# | ||
|
||
DISTNAME= semantic-1.4.2 | ||
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME} | ||
CATEGORIES= devel | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=cedet/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://cedet.sourceforge.net/semantic.shtml | ||
COMMENT= Lexer, parser-generator, and parser written for Emacs | ||
|
||
DEPENDS+= speedbar>=0.13:../../editors/speedbar | ||
DEPENDS+= eieio>=0.17:../../lang/eieio | ||
DEPENDS+= ${EMACS_PKGNAME_PREFIX}speedbar>=0.13:../../editors/speedbar | ||
DEPENDS+= ${EMACS_PKGNAME_PREFIX}eieio>=0.17:../../lang/eieio | ||
|
||
.include "../../mk/emacs.mk" | ||
|
||
.if ${EMACS_FLAVOR} == "emacs" | ||
EMACS= emacs | ||
.else | ||
EMACS= xemacs | ||
.endif | ||
|
||
BUILD_ENV+= EMACS=${EMACS} | ||
BUILD_ENV+= EMACS=${EMACS_FLAVOR} | ||
|
||
NO_CONFIGURE= # set | ||
USE_TOOLS+= gmake | ||
|
||
INFO_FILES= semantic.info | ||
OTHER_INFO= semantic.info-1 semantic.info-2 | ||
|
||
MAKE_ENV+= EMACS=${EMACS_FLAVOR} | ||
|
||
# XXX cd ${WRKSRC}; ${MAKE} -V semantic_LISP | ||
SRCS= semantic.el semantic-util.el semantic-bnf.el semantic-ctxt.el | ||
# XXX cd ${WRKSRC}; ${MAKE} -V Languages_LISP | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
$NetBSD: distinfo,v 1.5 2005/02/23 22:24:33 agc Exp $ | ||
$NetBSD: distinfo,v 1.6 2005/08/28 04:25:29 uebayasi Exp $ | ||
|
||
SHA1 (semantic-1.4.2.tar.gz) = a8898745055319de676c61a5d529d4dfb6eb2878 | ||
RMD160 (semantic-1.4.2.tar.gz) = 38243d5b84443430565100d2cfb1add45383e92f | ||
Size (semantic-1.4.2.tar.gz) = 313881 bytes | ||
SHA1 (patch-aa) = 7747913d4db505d1bc287b1d9bd986cbfaf53c7a | ||
SHA1 (patch-aa) = 28b97231dadb920be67d853de531f0b273e1b870 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.