-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Use PKG_SYSCONFSUBDIR so PKG_SYSCONFBASE can be set
Use REPLACE_PERL on all plugins Adjust sensors_ to work with NetBSD 3 Bump PKGREVISION
- Loading branch information
abs
committed
Jul 21, 2006
1 parent
f1156af
commit b99437c
Showing
6 changed files
with
79 additions
and
82 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,12 +1,12 @@ | ||
# $NetBSD: Makefile,v 1.6 2006/07/07 22:10:07 jlam Exp $ | ||
# $NetBSD: Makefile,v 1.7 2006/07/21 23:28:37 abs Exp $ | ||
# | ||
|
||
DISTNAME= munin_${VER} | ||
VER= 1.3.1 | ||
PKGNAME= munin-node-${VER} | ||
CATEGORIES= sysutils | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=munin/} | ||
PKGREVISION= 3 | ||
PKGREVISION= 4 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://munin.sourceforge.net/ | ||
|
@@ -27,6 +27,8 @@ MUNIN_USER?= munin | |
|
||
PKG_GROUPS= ${MUNIN_GROUP} | ||
PKG_USERS= ${MUNIN_USER}:${MUNIN_GROUP}::Munin\\ user | ||
PKG_SYSCONFSUBDIR?= munin | ||
REPLACE_PERL+= node/node.d/*.in | ||
|
||
STATEDIR?= ${VARBASE}/munin/plugin-state | ||
MUNIN_RUN?= ${VARBASE}/run/munin | ||
|
@@ -51,6 +53,7 @@ INSTALL_TARGET= install-node install-node-plugins | |
BUILD_TARGET= build | ||
|
||
#MAKE_ENV+= PERL5_SITELIB=${PERL5_SITELIB} | ||
MAKE_ENV+= CONFDIR=${PKG_SYSCONFDIR} | ||
MAKE_ENV+= MUNIN_USER=${MUNIN_USER} | ||
MAKE_ENV+= MUNIN_GROUP=${MUNIN_GROUP} | ||
MAKE_ENV+= PERL5=${PERL5:Q} | ||
|
@@ -68,7 +71,7 @@ RCD_SCRIPTS+= munin-node | |
|
||
EGDIR= ${PREFIX}/share/examples/munin | ||
|
||
CONF_FILES+= ${EGDIR}/munin-node.conf ${PKG_SYSCONFDIR}/munin/munin-node.conf | ||
CONF_FILES+= ${EGDIR}/munin-node.conf ${PKG_SYSCONFDIR}/munin-node.conf | ||
|
||
|
||
pre-configure: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,10 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2006/06/04 20:53:57 he Exp $ | ||
$NetBSD: distinfo,v 1.2 2006/07/21 23:28:37 abs Exp $ | ||
|
||
SHA1 (munin_1.3.1.tar.gz) = f7783b645abbb25524c3f1b6e0fe27185f1de3db | ||
RMD160 (munin_1.3.1.tar.gz) = a6ea4e1839f4c787457e4051d55007b7bcebd1d4 | ||
Size (munin_1.3.1.tar.gz) = 315743 bytes | ||
SHA1 (patch-aa) = f4c75a11a5fa026d968a2685f55061c74f51e537 | ||
SHA1 (patch-aa) = df9b128721166912c086a54b29b7971a00581ea0 | ||
SHA1 (patch-ab) = bb0f63cdef893d8c224cdd03a4a4125d03f85f80 | ||
SHA1 (patch-ac) = 9ef503b4d20f65e990c332c7789188a6fbad618e | ||
SHA1 (patch-ad) = 8accd3875324035f2c95903fc37cee4b4a55948a | ||
SHA1 (patch-ae) = 63b6acf126bc8baaed0ff429cfa0fa63945e5915 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-ae,v 1.1 2006/07/21 23:28:37 abs Exp $ | ||
|
||
--- node/node.d/hddtemp_smartctl.in.orig 2005-01-29 22:14:02.000000000 +0000 | ||
+++ node/node.d/hddtemp_smartctl.in | ||
@@ -93,6 +93,10 @@ if ($^O eq 'linux') { | ||
} | ||
} elsif ($^O eq 'solaris') { | ||
@drives = map { s@.*/@@ } glob '/dev/rdsk/c*t*d*s2'; | ||
+} elsif ($^O eq 'netbsd') { | ||
+ my $rawpart = chr(`sysctl -n kern.rawpartition` + 97); # 'c' or 'd' | ||
+ @drives = map { $_ . $rawpart } grep { /^wd/ } split ' ', | ||
+ `sysctl -n hw.disknames`; | ||
} | ||
|
||
@drives = split ' ', $ENV{drives} if exists $ENV{drives}; |