-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Make this pacakge build with gcc-4. Patches provided by martijnb in
PR pkg/33694.
- Loading branch information
Showing
2 changed files
with
60 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.3 2005/08/26 18:56:03 tv Exp $ | ||
$NetBSD: distinfo,v 1.4 2006/06/21 18:47:02 minskim Exp $ | ||
|
||
SHA1 (par2cmdline-0.4.tar.gz) = 2fcdc932b5d7b4b1c68c4a4ca855ca913d464d2f | ||
RMD160 (par2cmdline-0.4.tar.gz) = e98dc84fa7a4304b8d71c1d373fdce0bca1e6290 | ||
Size (par2cmdline-0.4.tar.gz) = 239312 bytes | ||
SHA1 (patch-aa) = cb2cc7bb718cd003fea2afc1f278d5d8a46381e0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
$NetBSD: patch-aa,v 1.1 2006/06/21 18:47:02 minskim Exp $ | ||
|
||
--- reedsolomon.cpp.orig 2003-05-26 18:01:31.000000000 +0000 | ||
+++ reedsolomon.cpp | ||
@@ -51,7 +51,7 @@ u32 gcd(u32 a, u32 b) | ||
} | ||
} | ||
|
||
-bool ReedSolomon<Galois8>::SetInput(const vector<bool> &present) | ||
+template<> bool ReedSolomon<Galois8>::SetInput(const vector<bool> &present) | ||
{ | ||
inputcount = (u32)present.size(); | ||
|
||
@@ -80,7 +80,7 @@ bool ReedSolomon<Galois8>::SetInput(cons | ||
return true; | ||
} | ||
|
||
-bool ReedSolomon<Galois8>::SetInput(u32 count) | ||
+template<> bool ReedSolomon<Galois8>::SetInput(u32 count) | ||
{ | ||
inputcount = count; | ||
|
||
@@ -101,7 +101,7 @@ bool ReedSolomon<Galois8>::SetInput(u32 | ||
return true; | ||
} | ||
|
||
-bool ReedSolomon<Galois8>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer) | ||
+template<> bool ReedSolomon<Galois8>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer) | ||
{ | ||
// Look up the appropriate element in the RS matrix | ||
Galois8 factor = leftmatrix[outputindex * (datapresent + datamissing) + inputindex]; | ||
@@ -189,7 +189,7 @@ bool ReedSolomon<Galois8>::Process(size_ | ||
|
||
// Set which of the source files are present and which are missing | ||
// and compute the base values to use for the vandermonde matrix. | ||
-bool ReedSolomon<Galois16>::SetInput(const vector<bool> &present) | ||
+template<> bool ReedSolomon<Galois16>::SetInput(const vector<bool> &present) | ||
{ | ||
inputcount = (u32)present.size(); | ||
|
||
@@ -233,7 +233,7 @@ bool ReedSolomon<Galois16>::SetInput(con | ||
|
||
// Record that the specified number of source files are all present | ||
// and compute the base values to use for the vandermonde matrix. | ||
-bool ReedSolomon<Galois16>::SetInput(u32 count) | ||
+template<> bool ReedSolomon<Galois16>::SetInput(u32 count) | ||
{ | ||
inputcount = count; | ||
|
||
@@ -267,7 +267,7 @@ bool ReedSolomon<Galois16>::SetInput(u32 | ||
return true; | ||
} | ||
|
||
-bool ReedSolomon<Galois16>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer) | ||
+template<> bool ReedSolomon<Galois16>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer) | ||
{ | ||
// Look up the appropriate element in the RS matrix | ||
|