-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix int types and network libs on SunOS
- Loading branch information
Showing
3 changed files
with
31 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,11 @@ | ||
# $NetBSD: Makefile,v 1.2 2015/11/07 20:20:54 dholland Exp $ | ||
# $NetBSD: Makefile,v 1.3 2015/12/12 16:56:04 wiedi Exp $ | ||
# | ||
|
||
DISTNAME= bwa-0.7.9a | ||
CATEGORIES= biology | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=bio-bwa/} | ||
EXTRACT_SUFX= .tar.bz2 | ||
PKGREVISION= 1 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://bio-bwa.sourceforge.net/ | ||
|
@@ -19,6 +20,9 @@ INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 | |
# unconditionally uses <emmintrin.h> | ||
ONLY_FOR_PLATFORM= *-*-x86_64 *-*-i386 *-*-ia64 | ||
|
||
CFLAGS.SunOS+= -Du_int32_t=uint32_t | ||
LDFLAGS.SunOS+= -lsocket -lnsl | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/bwa ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${DESTDIR}${PREFIX}/bin | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,7 @@ | ||
$NetBSD: distinfo,v 1.2 2015/11/02 18:42:20 agc Exp $ | ||
$NetBSD: distinfo,v 1.3 2015/12/12 16:56:04 wiedi Exp $ | ||
|
||
SHA1 (bwa-0.7.9a.tar.bz2) = a77ce327e8acba554b1d27bfdd1c148f79726484 | ||
RMD160 (bwa-0.7.9a.tar.bz2) = a51b7c686a206144eab2aee0a372d5ae46fcfce1 | ||
SHA512 (bwa-0.7.9a.tar.bz2) = 93804b2c0ac0f675e76f762441e1eec039d7f1cf77b033fd88f2e6c39d9cd4b5c21bba9fb44e34a3dab28c630c3855792a707e5b33109d4be0097cec97eaa686 | ||
Size (bwa-0.7.9a.tar.bz2) = 166193 bytes | ||
SHA1 (patch-Makefile) = 2bb665cb579d20a07ae7c2be8ba0ed874d60d5b0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
$NetBSD: patch-Makefile,v 1.1 2015/12/12 16:56:04 wiedi Exp $ | ||
|
||
Don't overwrite pkgsrc CC and CFLAGS | ||
|
||
--- Makefile.orig 2014-05-19 13:11:41.000000000 +0000 | ||
+++ Makefile | ||
@@ -1,6 +1,6 @@ | ||
-CC= gcc | ||
+#CC= gcc | ||
#CC= clang --analyze | ||
-CFLAGS= -g -Wall -Wno-unused-function -O2 | ||
+#CFLAGS= -g -Wall -Wno-unused-function -O2 | ||
WRAP_MALLOC=-DUSE_MALLOC_WRAPPERS | ||
AR= ar | ||
DFLAGS= -DHAVE_PTHREAD $(WRAP_MALLOC) | ||
@@ -11,7 +11,7 @@ AOBJS= QSufSort.o bwt_gen.o bwase.o bwa | ||
bwtsw2_chain.o fastmap.o bwtsw2_pair.o | ||
PROG= bwa | ||
INCLUDES= | ||
-LIBS= -lm -lz -lpthread | ||
+LIBS= -lm -lz -lpthread $(LDFLAGS) | ||
SUBDIRS= . | ||
|
||
.SUFFIXES:.c .o .cc |