Skip to content

Commit

Permalink
gnuradio-*: update to 3.9.2.0
Browse files Browse the repository at this point in the history
Changed
 SoapySDR support (gr-soapy)
GRC
  Parameter expressions and/or values can be displayed in blocks on the flowgraph. Previously, only values were displayed. Look for the "Show Parameter ..." toggles under the View menu.
  Deprecated blocks are shown in a distinct color (orange), and the optional deprecated property has been added to block yaml
  Dark theme works better, especially for parameter fields
  Vector length is now correctly applied to all input ports
  Validation has been improved. Raw types are validated. Port connections are checked by type rather than by item size.
  Variable names that cause name conflicts in Python code (e.g., with package names) are rejected
  Bus logic fixes
  Blocks can no longer be dragged off the screen and lost forever
gnuradio-runtime
  Remove pmt::pmt_* functions, which were not actually implemented. This is technically an API change, but any use of the API would have resulted in a link error.
  Remove Python bindings for internal buffer functions
gr-analog
  Added an example for PLL Frequency Detector
  Better names for parameters in PLL GRC blocks
gr-blocks
  Consistent naming for Vector Length parameter in GRC blocks
  count_bits uses VOLK popcnt for better performance (used for example in the Correlate Access Code block)
  Rotator block phase increment parameter is controllable via a message, and a tag can be added at the point where the increment is adjusted
gr-digital
  MPSK example updated to use a Linear Equalizer (replacing deprecated block)
gr-filter
  Filter Delay documentation improvement
  Interpolating FIR filter can generate C++ code
gr-dtv
  VL-SNR bugs fixed (incorrect constants).
gr-qtgui
  Improve autoscaling for vector sinks
  Fix floating-point resolution problems in several widgets, due to interpretation of PMT doubles as floats
gr-uhd
  Add policy enum to Python bindings for tune_request
  Additional time spec options on UHD blocks (PC Clock on Next PPS, GPS Time on Next PPS)
  Fix up code that was generating warnings
  Fix command handler logic to apply commands from messages to the correct channel
gr_filter_design
  "File/Save" is disabled until the taps have been computed, and the GUI is reset after a save, to make it clearer which data is being saved.
  Entries are hidden for parameters that do not apply to the selected filter type.
  Save window type as an integer instead of a Python enum name
gr_modtool
  Improve validation of module and block names
Build System and Infrastructure
  Improved messages related to dependencies MPIR and GMP. Only one of these packages is required, and the previous error messages were confusing.
  Cleaner builds for Windows and Conda. A number of general cmake improvements have resulted from this work.
  In-tree packaging files for DEB and RPM, used with Launchpad and COPR
  Added man pages for GNU Radio tools
  Test code generation for all in-tree GRC examples
  In GrPybind.cmake, PYBIND11_INCLUDE_DIR (incorrect) was changed to
  pybind11_INCLUDE_DIR
  • Loading branch information
tnn2 committed Jun 27, 2021
1 parent dfbb193 commit bf35fe2
Show file tree
Hide file tree
Showing 36 changed files with 268 additions and 131 deletions.
3 changes: 1 addition & 2 deletions ham/gnuradio-channels/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.27 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.28 2021/06/27 08:08:59 tnn Exp $

PKGNAME= gnuradio-channels-${VERSION}
PKGREVISION= 4
COMMENT= Signal processing blocks to simulate channel models of GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
Expand Down
4 changes: 2 additions & 2 deletions ham/gnuradio-channels/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2021/04/07 16:14:07 tnn Exp $
@comment $NetBSD: PLIST,v 1.6 2021/06/27 08:08:59 tnn Exp $
include/gnuradio/channels/api.h
include/gnuradio/channels/channel_model.h
include/gnuradio/channels/channel_model2.h
Expand All @@ -9,7 +9,7 @@ lib/cmake/gnuradio/gnuradio-channelsConfig.cmake
lib/cmake/gnuradio/gnuradio-channelsTargets-release.cmake
lib/cmake/gnuradio/gnuradio-channelsTargets.cmake
lib/libgnuradio-channels.so
lib/libgnuradio-channels.so.3.9.1
lib/libgnuradio-channels.so.3.9.2
lib/libgnuradio-channels.so.${PKGVERSION}
lib/pkgconfig/gnuradio-channels.pc
${PYSITELIB}/gnuradio/channels/__init__.py
Expand Down
3 changes: 1 addition & 2 deletions ham/gnuradio-companion/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.46 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.47 2021/06/27 08:08:59 tnn Exp $

PKGNAME= gnuradio-companion-${VERSION}
PKGREVISION= 4
COMMENT= User interface entry of GNU Radio

#CONF_FILES+= ${EGDIR}/grc.conf ${PKG_SYSCONFDIR}/grc.conf
Expand Down
3 changes: 1 addition & 2 deletions ham/gnuradio-core/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.83 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.84 2021/06/27 08:08:59 tnn Exp $

PKGNAME= gnuradio-core-${VERSION}
PKGREVISION= 5
COMMENT= Core part of GNU Radio, all others need this

PLIST_MINUS= # empty
Expand Down
3 changes: 2 additions & 1 deletion ham/gnuradio-core/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.34 2021/05/15 10:09:06 nia Exp $
# $NetBSD: Makefile.common,v 1.35 2021/06/27 08:08:59 tnn Exp $
# This Makefile fragment is included in the package Makefiles for
# GNU Radio distributed packages (they all share common configure and build
# settings).
Expand All @@ -13,6 +13,7 @@
# used by ham/gnuradio-dtv/Makefile
# used by ham/gnuradio-fec/Makefile
# used by ham/gnuradio-qtgui/Makefile
# used by ham/gnuradio-soapy-sdr/Makefile
# used by ham/gnuradio-trellis/Makefile
# used by ham/gnuradio-uhd/Makefile
# used by ham/gnuradio-utils/Makefile
Expand Down
17 changes: 8 additions & 9 deletions ham/gnuradio-core/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.31 2021/04/07 16:14:07 tnn Exp $
@comment $NetBSD: PLIST,v 1.32 2021/06/27 08:08:59 tnn Exp $
bin/gnuradio-config-info
bin/gr_filter_design
include/gnuradio/analog/agc.h
Expand Down Expand Up @@ -313,7 +313,6 @@ include/gnuradio/thread/thread_group.h
include/gnuradio/top_block.h
include/gnuradio/tpb_detail.h
include/gnuradio/types.h
include/gnuradio/unittests.h
include/pmt/api.h
include/pmt/pmt.h
include/pmt/pmt_pool.h
Expand Down Expand Up @@ -375,25 +374,25 @@ lib/cmake/gnuradio/gnuradio-runtimeConfig.cmake
lib/cmake/gnuradio/gnuradio-runtimeTargets-release.cmake
lib/cmake/gnuradio/gnuradio-runtimeTargets.cmake
lib/libgnuradio-analog.so
lib/libgnuradio-analog.so.3.9.1
lib/libgnuradio-analog.so.3.9.2
lib/libgnuradio-analog.so.${PKGVERSION}
lib/libgnuradio-audio.so
lib/libgnuradio-audio.so.3.9.1
lib/libgnuradio-audio.so.3.9.2
lib/libgnuradio-audio.so.${PKGVERSION}
lib/libgnuradio-blocks.so
lib/libgnuradio-blocks.so.3.9.1
lib/libgnuradio-blocks.so.3.9.2
lib/libgnuradio-blocks.so.${PKGVERSION}
lib/libgnuradio-fft.so
lib/libgnuradio-fft.so.3.9.1
lib/libgnuradio-fft.so.3.9.2
lib/libgnuradio-fft.so.${PKGVERSION}
lib/libgnuradio-filter.so
lib/libgnuradio-filter.so.3.9.1
lib/libgnuradio-filter.so.3.9.2
lib/libgnuradio-filter.so.${PKGVERSION}
lib/libgnuradio-pmt.so
lib/libgnuradio-pmt.so.3.9.1
lib/libgnuradio-pmt.so.3.9.2
lib/libgnuradio-pmt.so.${PKGVERSION}
lib/libgnuradio-runtime.so
lib/libgnuradio-runtime.so.3.9.1
lib/libgnuradio-runtime.so.3.9.2
lib/libgnuradio-runtime.so.${PKGVERSION}
lib/pkgconfig/gnuradio-analog.pc
lib/pkgconfig/gnuradio-audio.pc
Expand Down
6 changes: 3 additions & 3 deletions ham/gnuradio-core/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.31 2021/04/07 16:14:07 tnn Exp $
# $NetBSD: buildlink3.mk,v 1.32 2021/06/27 08:08:59 tnn Exp $

BUILDLINK_TREE+= gnuradio-core

.if !defined(GNURADIO_CORE_BUILDLINK3_MK)
GNURADIO_CORE_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.gnuradio-core+= gnuradio-core>=3.9.1.0
BUILDLINK_ABI_DEPENDS.gnuradio-core+= gnuradio-core>=3.9.1.0
BUILDLINK_API_DEPENDS.gnuradio-core+= gnuradio-core>=3.9.2.0
BUILDLINK_ABI_DEPENDS.gnuradio-core+= gnuradio-core>=3.9.2.0
BUILDLINK_PKGSRCDIR.gnuradio-core?= ../../ham/gnuradio-core

.include "../../devel/gmp/buildlink3.mk"
Expand Down
10 changes: 5 additions & 5 deletions ham/gnuradio-core/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.41 2021/04/07 16:14:07 tnn Exp $
$NetBSD: distinfo,v 1.42 2021/06/27 08:08:59 tnn Exp $

SHA1 (gnuradio-3.9.1.0.tar.gz) = 058f77b2ca3412003d56f8f6a6676bfd6e4d6332
RMD160 (gnuradio-3.9.1.0.tar.gz) = f9f8cb138f0a62592f31b6af4ed378ac9a797163
SHA512 (gnuradio-3.9.1.0.tar.gz) = 01baf79cb77e093f845d223c12f6ec1a70ada297022b6ed7d17485e1e3143ee8655ef93e62561d2b5daa38518e8f6a5bda98c53b613ceced0e3bbe5051279514
Size (gnuradio-3.9.1.0.tar.gz) = 4127980 bytes
SHA1 (gnuradio-3.9.2.0.tar.gz) = 6cb92288d6d5f7e758010b259ebc230849cd4436
RMD160 (gnuradio-3.9.2.0.tar.gz) = b42446a4459a2532acf60455d42610e37d9499b1
SHA512 (gnuradio-3.9.2.0.tar.gz) = 4a2807d6713fff10906354553ef5810b81ef4116573fdf15b122e8fc18373c56e1685b8592a8f0f08c0524c4983f3d7d4774bdada98dff0990d028f71cbd7898
Size (gnuradio-3.9.2.0.tar.gz) = 4219714 bytes
SHA1 (patch-gnuradio-runtime_lib_constants.cc.in) = e3ca88db06eef0a38387ddbfbd9a4d3b6262b9a6
SHA1 (patch-gr-audio_lib_CMakeLists.txt) = 9adacb93a20b2be596a23985306cbfd5f93c80a8
SHA1 (patch-gr-audio_lib_alsa_alsa__impl_h) = cfa9b629e5cf21198cfd53cf27a908b5874866f4
4 changes: 2 additions & 2 deletions ham/gnuradio-core/version.mk
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
# $NetBSD: version.mk,v 1.2 2021/04/07 16:14:07 tnn Exp $
# $NetBSD: version.mk,v 1.3 2021/06/27 08:08:59 tnn Exp $

VERSION= 3.9.1.0
VERSION= 3.9.2.0
3 changes: 1 addition & 2 deletions ham/gnuradio-ctrlport/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.28 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.29 2021/06/27 08:08:59 tnn Exp $

PKGNAME= gnuradio-ctrlport-${VERSION}
PKGREVISION= 4
COMMENT= New set of hooks into GNU Radio to allow a remote client to attach
.include "../../ham/gnuradio-core/Makefile.common"
.include "../../ham/gnuradio-core/Nocore.mk"
Expand Down
3 changes: 1 addition & 2 deletions ham/gnuradio-digital/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.28 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.29 2021/06/27 08:08:59 tnn Exp $

PKGNAME= gnuradio-digital-${VERSION}
PKGREVISION= 4
COMMENT= Digital related algorithms for GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
Expand Down
4 changes: 2 additions & 2 deletions ham/gnuradio-digital/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2021/04/07 16:14:08 tnn Exp $
@comment $NetBSD: PLIST,v 1.11 2021/06/27 08:08:59 tnn Exp $
include/gnuradio/digital/adaptive_algorithm.h
include/gnuradio/digital/adaptive_algorithm_cma.h
include/gnuradio/digital/adaptive_algorithm_lms.h
Expand Down Expand Up @@ -90,7 +90,7 @@ lib/cmake/gnuradio/gnuradio-digitalConfig.cmake
lib/cmake/gnuradio/gnuradio-digitalTargets-release.cmake
lib/cmake/gnuradio/gnuradio-digitalTargets.cmake
lib/libgnuradio-digital.so
lib/libgnuradio-digital.so.3.9.1
lib/libgnuradio-digital.so.3.9.2
lib/libgnuradio-digital.so.${PKGVERSION}
lib/pkgconfig/gnuradio-digital.pc
${PYSITELIB}/gnuradio/digital/__init__.py
Expand Down
3 changes: 1 addition & 2 deletions ham/gnuradio-doxygen/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.43 2021/06/01 09:12:24 wiz Exp $
# $NetBSD: Makefile,v 1.44 2021/06/27 08:09:00 tnn Exp $

PKGNAME= gnuradio-doxygen-${VERSION}
PKGREVISION= 4
COMMENT= Doxygen documentation of GNU Radio

.include "../../ham/gnuradio-core/Makefile.common"
Expand Down
Loading

0 comments on commit bf35fe2

Please sign in to comment.