-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
cad/py-gdscad: import py27-gdsCAD-0.4.5
gdsCAD is a simple, but powerful, Python package for creating, reading, and manipulating GDSII layout files. It's suitable for scripting and interactive use. It excels particularly in generating designs with multiple incrementally adjusted objects. gdsCAD uses matplotlib to visualize everything from individual geometry primitives to the entire layout.
- Loading branch information
mef
committed
Mar 17, 2018
1 parent
f5d60ba
commit bf66659
Showing
4 changed files
with
84 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
gdsCAD is a simple, but powerful, Python package for creating, reading, and | ||
manipulating GDSII layout files. It's suitable for scripting and interactive | ||
use. It excels particularly in generating designs with multiple incrementally | ||
adjusted objects. gdsCAD uses matplotlib to visualize everything from individual | ||
geometry primitives to the entire layout. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# $NetBSD: Makefile,v 1.1 2018/03/17 22:15:30 mef Exp $ | ||
|
||
DISTNAME= gdsCAD-0.4.5 | ||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME} | ||
CATEGORIES= cad python | ||
CATEGORIES= cad | ||
MASTER_SITES= ${MASTER_SITE_GITHUB:=hohlraum/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://pythonhosted.org/gdsCAD/ | ||
COMMENT= Package for creating, reading, and manipulating GDSII layout files | ||
LICENSE= gnu-gpl-v3 | ||
|
||
USE_LANGUAGES= # none | ||
#PYTHON_VERSIONS_INCOMPATIBLE= 35 36 34 | ||
# PYSETUPBUILDTARGET= install | ||
|
||
.include "../../lang/python/egg.mk" | ||
|
||
pre-configure: | ||
(cd ${WRKSRC} ;\ | ||
${ECHO} '__version__ =' "'"${PKGVERSION_NOREV}"'" > gdsCAD/_version.py \ | ||
) | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2018/03/17 22:15:30 mef Exp $ | ||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO | ||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt | ||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt | ||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt | ||
${PYSITELIB}/gdsCAD/__init__.py | ||
${PYSITELIB}/gdsCAD/__init__.pyc | ||
${PYSITELIB}/gdsCAD/__init__.pyo | ||
${PYSITELIB}/gdsCAD/_version.py | ||
${PYSITELIB}/gdsCAD/_version.pyc | ||
${PYSITELIB}/gdsCAD/_version.pyo | ||
${PYSITELIB}/gdsCAD/core.py | ||
${PYSITELIB}/gdsCAD/core.pyc | ||
${PYSITELIB}/gdsCAD/core.pyo | ||
${PYSITELIB}/gdsCAD/font.py | ||
${PYSITELIB}/gdsCAD/font.pyc | ||
${PYSITELIB}/gdsCAD/font.pyo | ||
${PYSITELIB}/gdsCAD/resources/ALIGNMENT.GDS | ||
${PYSITELIB}/gdsCAD/resources/hershey/LICENSE | ||
${PYSITELIB}/gdsCAD/resources/hershey/cyrilc.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/gothgbt.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/gothgrt.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/gothitt.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/greekc.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/greekcs.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/greekp.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/greeks.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/hershey | ||
${PYSITELIB}/gdsCAD/resources/hershey/italicc.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/italiccs.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/italict.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romanc.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romancs.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romand.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romanp.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romans.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/romant.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/scriptc.hmp | ||
${PYSITELIB}/gdsCAD/resources/hershey/scripts.hmp | ||
${PYSITELIB}/gdsCAD/shapes.py | ||
${PYSITELIB}/gdsCAD/shapes.pyc | ||
${PYSITELIB}/gdsCAD/shapes.pyo | ||
${PYSITELIB}/gdsCAD/templates.py | ||
${PYSITELIB}/gdsCAD/templates.pyc | ||
${PYSITELIB}/gdsCAD/templates.pyo | ||
${PYSITELIB}/gdsCAD/utils.py | ||
${PYSITELIB}/gdsCAD/utils.pyc | ||
${PYSITELIB}/gdsCAD/utils.pyo |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1 2018/03/17 22:15:30 mef Exp $ | ||
|
||
SHA1 (gdsCAD-0.4.5.tar.gz) = 5e6e53a6caf8193bd9b9a1b6a6e2a41d725cf87f | ||
RMD160 (gdsCAD-0.4.5.tar.gz) = 7acc35a14282a2add321806017137581d61e10f8 | ||
SHA512 (gdsCAD-0.4.5.tar.gz) = f6d50e2dd0eb8edc632afd14ff8641a9ba334f57fd98dd981b3a64e3980d26e4d5de63bc8a68d303cfc9bf145547ef45a1168353c445ea1ce2b7e1468a92a3d7 | ||
Size (gdsCAD-0.4.5.tar.gz) = 451368 bytes |