Skip to content

Commit

Permalink
*: Remove many GCC_REQD for particularly old GCCs
Browse files Browse the repository at this point in the history
In many cases the reasoning is poorly documented, or the reasoning
for setting GCC_REQD is to work around a compiler bug. Practically
a c99 compiler is now required for bootstrap (in at least several
dependencies) so we can entirely rule out GCC versions before 3.0.
  • Loading branch information
alarixnia committed Jul 17, 2023
1 parent 38c6285 commit c193afd
Show file tree
Hide file tree
Showing 28 changed files with 32 additions and 112 deletions.
4 changes: 1 addition & 3 deletions archivers/p7zip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.69 2020/01/26 05:26:08 rillig Exp $
# $NetBSD: Makefile,v 1.70 2023/07/17 22:00:22 nia Exp $

DISTNAME= p7zip_16.02_src_all
PKGNAME= ${DISTNAME:S/_src_all//S/_/-/}
Expand All @@ -23,8 +23,6 @@ PTHREAD_OPTS+= require

WRKSRC= ${WRKDIR}/${PKGNAME_NOREV:S/-/_/}

GCC_REQD+= 3.0

INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
INSTALLATION_DIRS+= share/doc/p7zip
INSTALLATION_DIRS+= share/doc/p7zip/commands
Expand Down
7 changes: 5 additions & 2 deletions audio/goom/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2020/05/20 06:09:04 rillig Exp $
# $NetBSD: Makefile,v 1.14 2023/07/17 22:00:22 nia Exp $

DISTNAME= goom-2k4-0-src
PKGNAME= goom-2004.0
Expand All @@ -15,9 +15,12 @@ USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
PKGCONFIG_OVERRIDE+= ${WRKSRC}/libgoom2.pc.in
GNU_CONFIGURE= yes
GCC_REQD+= 3.3
USE_TOOLS+= pkg-config

# "This package needs gcc-3.0 because it uses some inline assembler syntax
# that gcc-2.95.3 does not understand."
GCC_REQD+= 3.3

# convolve_fx.c: In function 'create_output_with_brightness':
# convolve_fx.c:222:20: error: array subscript has type 'char' [-Werror=char-subscripts]
# iff2 = ifftab[data->conv_motif[(ytex >>16) & CONV_MOTIF_WMASK][(xtex >> 16) & CONV_MOTIF_WMASK]];
Expand Down
6 changes: 1 addition & 5 deletions biology/rasmol/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.33 2012/10/23 10:24:02 wiz Exp $
# $NetBSD: Makefile,v 1.34 2023/07/17 22:00:22 nia Exp $

DISTNAME= RasMol_2.7.3
PKGNAME= rasmol-2.7.3
Expand All @@ -18,10 +18,6 @@ MAKE_ENV+= DEPTHDEF=${DEPTHDEF:Q}

.include "../../mk/bsd.prefs.mk"

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 2.95.3
.endif

.if defined(RASMOL_DEPTH)
. if ${RASMOL_DEPTH} == 32
DEPTHDEF= -DTHIRTYTWOBIT
Expand Down
6 changes: 1 addition & 5 deletions cad/fastcap/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.43 2023/06/06 12:40:18 riastradh Exp $
# $NetBSD: Makefile,v 1.44 2023/07/17 22:00:23 nia Exp $

DISTNAME= fastcap-2.0-18Sep92
PKGNAME= fastcap-2.0.19920918
Expand Down Expand Up @@ -30,10 +30,6 @@ CONFIGURE_ARGS+= 4
MAKE_ENV+= BIBTEX=${PREFIX}/bin/bibtex \
LATEX=${PREFIX}/bin/latex

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 2.95.3
.endif

INSTALLATION_DIRS= bin

post-patch:
Expand Down
6 changes: 1 addition & 5 deletions cad/fasthenry/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.32 2020/05/20 06:09:03 rillig Exp $
# $NetBSD: Makefile,v 1.33 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= fasthenry-3.0-12Nov96
Expand Down Expand Up @@ -32,10 +32,6 @@ LIBS+= -lffm
LIBS+= -lm
MAKE_ENV+= LIBS=${LIBS:M*:Q}

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 2.95.3
.endif

# contact.c: In function 'walk_along_edge':
# contact.c:1334:40: error: array subscript has type 'char' [-Werror=char-subscripts]
# equiv_nodes_on_edge(cell->bndry.nodes[start_node], travel_dir,
Expand Down
6 changes: 1 addition & 5 deletions chat/centerim/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.67 2023/04/19 08:09:14 adam Exp $
# $NetBSD: Makefile,v 1.68 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= centerim-4.22.10
Expand Down Expand Up @@ -40,10 +40,6 @@ CPPFLAGS+= -DAUDIO_PLAYER="\"${LOCALBASE}/bin/play\""
# 1 safe instance in xmltok.c:1494
BUILDLINK_TRANSFORM+= rm:-Werror=char-subscripts

.if !empty(MACHINE_ARCH:Msparc64)
GCC_REQD+= 3.0 # see PR 29185
.endif

.include "../../lang/python/application.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
Expand Down
4 changes: 1 addition & 3 deletions emulators/gpsim-devel/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.55 2023/01/29 21:14:34 ryoon Exp $
# $NetBSD: Makefile,v 1.56 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= gpsim-20050905
Expand All @@ -16,8 +16,6 @@ USE_LANGUAGES= c c++03
USE_TOOLS+= bison gmake lex pkg-config
USE_LIBTOOL= YES

GCC_REQD+= 3.0

CONFLICTS= eXdbm-[0-9]* gpsim-[0-9]*

.include "../../devel/popt/buildlink3.mk"
Expand Down
4 changes: 1 addition & 3 deletions emulators/gpsim-oscilloscope/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.46 2023/01/29 21:16:00 ryoon Exp $
# $NetBSD: Makefile,v 1.47 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= oscilloscope-0.1.2
Expand All @@ -15,8 +15,6 @@ USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
USE_LIBTOOL= YES

GCC_REQD+= 3.0

EGDIR= ${PREFIX}/share/examples/gpsim-oscilloscope

INSTALLATION_DIRS= ${EGDIR}
Expand Down
4 changes: 1 addition & 3 deletions emulators/gpsim-ptyusart/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.48 2023/01/29 21:16:00 ryoon Exp $
# $NetBSD: Makefile,v 1.49 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= ptyusart-0.3.2
Expand All @@ -19,8 +19,6 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= YES
USE_TOOLS+= pkg-config

GCC_REQD+= 3.0

EGDIR= ${PREFIX}/share/examples/gpsim-ptyusart
INSTALLATION_DIRS= ${EGDIR}

Expand Down
6 changes: 1 addition & 5 deletions games/sjeng/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.22 2018/01/28 20:10:51 wiz Exp $
# $NetBSD: Makefile,v 1.23 2023/07/17 22:00:23 nia Exp $

DISTNAME= Sjeng-Free-11.0
PKGNAME= sjeng-11.0
Expand All @@ -23,10 +23,6 @@ TBDIR= ${PREFIX}/share/egtb
DOCDIR= ${PREFIX}/share/doc/sjeng
EGDIR= ${PREFIX}/share/examples/sjeng

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 3.0
.endif

post-build:
cd ${WRKSRC}; \
file="sjeng.rc"; \
Expand Down
8 changes: 1 addition & 7 deletions games/xmahjongg/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.31 2020/01/26 17:31:18 rillig Exp $
# $NetBSD: Makefile,v 1.32 2023/07/17 22:00:23 nia Exp $
#

DISTNAME= xmahjongg-3.7
Expand All @@ -13,11 +13,5 @@ COMMENT= The Chinese game of Mah Jongg for X11
GNU_CONFIGURE= YES
USE_LANGUAGES= c c++03

.include "../../mk/bsd.prefs.mk"
# XXX: hack - work round an ICE with GCC 3.3 on sparc
.if ${OPSYS} == "NetBSD" && ${MACHINE_ARCH} == "sparc"
GCC_REQD+= 3.4
.endif

.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
5 changes: 1 addition & 4 deletions games/zoom/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.48 2023/01/29 21:16:24 ryoon Exp $
# $NetBSD: Makefile,v 1.49 2023/07/17 22:00:23 nia Exp $

DISTNAME= zoom-1.1.5
PKGREVISION= 11
Expand All @@ -16,9 +16,6 @@ USE_TOOLS+= gmake perl
GNU_CONFIGURE= yes
AUTO_MKDIRS= yes

.if ${MACHINE_ARCH} == "alpha"
GCC_REQD+= 3.0
.endif
UNLIMIT_RESOURCES+= datasize

post-install:
Expand Down
6 changes: 1 addition & 5 deletions graphics/povray/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.59 2023/01/03 17:37:29 wiz Exp $
# $NetBSD: Makefile,v 1.60 2023/07/17 22:00:24 nia Exp $

DISTNAME= povray-3.6.1
PKGREVISION= 16
Expand All @@ -23,10 +23,6 @@ CONFIGURE_ENV+= COMPILED_BY="The NetBSD Packages Collection"

.include "../../mk/bsd.prefs.mk"

.if ${MACHINE_ARCH} == x86_64
GCC_REQD+= 3.4
.endif

PLIST_SUBST+= POVRAY=povray-3.6

PKG_SYSCONFSUBDIR= povray/3.6
Expand Down
4 changes: 1 addition & 3 deletions lang/gpc/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.40 2021/12/25 21:34:12 dholland Exp $
# $NetBSD: Makefile,v 1.41 2023/07/17 22:00:24 nia Exp $

DISTNAME= gpc-2.1
PKGREVISION= 5
Expand All @@ -24,8 +24,6 @@ PLIST_SRC= PLIST

.include "../../mk/bsd.prefs.mk"

GCC_REQD+= 2.95.3

.if ${OPSYS} == "NetBSD"
CFLAGS+= -DNETBSD_NATIVE
GPC_PREFIX= ${PREFIX}
Expand Down
3 changes: 1 addition & 2 deletions mail/cone/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.50 2023/04/19 08:10:40 adam Exp $
# $NetBSD: Makefile,v 1.51 2023/07/17 22:00:24 nia Exp $

DISTNAME= cone-0.90
PKGREVISION= 36
Expand All @@ -13,7 +13,6 @@ LICENSE= gnu-gpl-v3

USE_LANGUAGES= c c++
USE_TOOLS+= gmake perl true
GCC_REQD+= 3.0 # need Standard C++ Library

.include "options.mk"

Expand Down
3 changes: 1 addition & 2 deletions mail/courier-mta/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.63 2023/07/06 09:40:41 wiz Exp $
# $NetBSD: Makefile,v 1.64 2023/07/17 22:00:24 nia Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/-mta-/}
Expand All @@ -19,7 +19,6 @@ DEPENDS+= maildrop>=2.5.0:../../mail/maildrop

USE_TOOLS+= gmake perl:run
USE_LANGUAGES= c c++
GCC_REQD+= 3.0 # need Standard C++ Library

.include "Makefile.common"

Expand Down
6 changes: 1 addition & 5 deletions math/scilab/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.113 2023/01/29 21:17:05 ryoon Exp $
# $NetBSD: Makefile,v 1.114 2023/07/17 22:00:24 nia Exp $
#

DISTNAME= ${SCIBASE}-src
Expand Down Expand Up @@ -122,10 +122,6 @@ post-install:
${RM} -f ${DESTDIR}${PREFIX}/lib/${SCIBASE}/scripts/${__tmp__}
.endfor

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 2.95.3
.endif

# the "SCI=0 && unset SCI" is done because some of the tests really will
# fail if SCI is set to anything.
MAKE_ENV+= SCI=${WRKSRC:Q}
Expand Down
3 changes: 1 addition & 2 deletions misc/celestia/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.92 2023/04/19 08:10:47 adam Exp $
# $NetBSD: Makefile,v 1.93 2023/07/17 22:00:24 nia Exp $

DISTNAME= celestia-1.6.1
PKGREVISION= 35
Expand All @@ -19,7 +19,6 @@ USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake pkg-config
GNU_CONFIGURE= yes

GCC_REQD+= 3.0
CXXFLAGS+= -DPKG_SYSCONFDIR="\"${PKG_SYSCONFDIR}\""

EGDIR= ${PREFIX}/share/examples/celestia
Expand Down
3 changes: 1 addition & 2 deletions multimedia/avidemux/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.136 2023/06/06 12:41:58 riastradh Exp $
# $NetBSD: Makefile,v 1.137 2023/07/17 22:00:24 nia Exp $

DISTNAME= avidemux_2.5.4
PKGNAME= ${DISTNAME:S/_/-/}
Expand All @@ -13,7 +13,6 @@ LICENSE= gnu-gpl-v2

TOOL_DEPENDS+= yasm-[0-9]*:../../devel/yasm

GCC_REQD+= 3.0
USE_LANGUAGES= c c++03
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
Expand Down
4 changes: 1 addition & 3 deletions multimedia/libogg/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.30 2022/07/25 11:12:26 wiz Exp $
# $NetBSD: Makefile,v 1.31 2023/07/17 22:00:24 nia Exp $

DISTNAME= libogg-1.3.5
PKGREVISION= 1
Expand All @@ -16,6 +16,4 @@ GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE+= ogg.pc.in
TEST_TARGET= check

GCC_REQD+= 2.95.3

.include "../../mk/bsd.pkg.mk"
5 changes: 1 addition & 4 deletions multimedia/ogle_gui/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.62 2023/04/19 08:10:59 adam Exp $
# $NetBSD: Makefile,v 1.63 2023/07/17 22:00:25 nia Exp $

DISTNAME= ogle_gui-0.9.2
PKGREVISION= 50
Expand All @@ -17,11 +17,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --bindir=${PREFIX}/lib/ogle
CONFIGURE_ARGS+= --enable-gtk2

GCC_REQD+= 2.95.3

.include "../../devel/libglade/buildlink3.mk"
.include "../../multimedia/ogle/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"
6 changes: 1 addition & 5 deletions news/inn/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.140 2023/07/06 09:41:16 wiz Exp $
# $NetBSD: Makefile,v 1.141 2023/07/17 22:00:25 nia Exp $

DISTNAME= inn-2.7.1
PKGREVISION= 1
Expand Down Expand Up @@ -203,10 +203,6 @@ post-extract:

.endif

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 2.95.3
.endif

.include "options.mk"

TEST_TARGET= tests
Expand Down
3 changes: 1 addition & 2 deletions textproc/html2text/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.21 2020/04/06 09:30:48 wiz Exp $
# $NetBSD: Makefile,v 1.22 2023/07/17 22:00:25 nia Exp $

DISTNAME= html2text-1.3.2a
CATEGORIES= textproc
Expand All @@ -12,7 +12,6 @@ LICENSE= gnu-gpl-v2

USE_LANGUAGES= c c++
USE_TOOLS+= gunzip
GCC_REQD+= 3.0
HAS_CONFIGURE= yes
CONFIGURE_ENV+= ECHO=${ECHO:Q}
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 ${PKGMANDIR}/man5
Expand Down
4 changes: 1 addition & 3 deletions textproc/xmlindent/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2023/07/11 05:46:30 nia Exp $
# $NetBSD: Makefile,v 1.17 2023/07/17 22:00:25 nia Exp $
#

DISTNAME= xmlindent-0.2.16
Expand All @@ -13,8 +13,6 @@ LICENSE= gnu-gpl-v2

USE_TOOLS+= flex:run

GCC_REQD+= 3.0

INSTALLATION_DIRS= bin ${PKGMANDIR}/man1

do-install:
Expand Down
6 changes: 1 addition & 5 deletions wm/windowmaker/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.139 2023/01/29 21:15:02 ryoon Exp $
# $NetBSD: Makefile,v 1.140 2023/07/17 22:00:25 nia Exp $

DISTNAME= WindowMaker-0.95.9
PKGNAME= ${DISTNAME:tl}
Expand Down Expand Up @@ -44,10 +44,6 @@ PKGCONFIG_OVERRIDE_STAGE= post-build
CONFIGURE_ENV+= ac_cv_lib_Xext_XineramaGetInfo=no
.endif

.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
GCC_REQD+= 3.0
.endif

CFLAGS.SunOS+= -D__EXTENSIONS__

PKG_SYSCONFSUBDIR= WindowMaker
Expand Down
Loading

0 comments on commit c193afd

Please sign in to comment.