-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- A lot of internal code cleanup and bug fixes. - Added a dialog for creating new blank floppy disk images. - The source code has been optimized for better emulation speed. - Added RS232 emulation (still very experimental and not very well tested! It seems not to work reliable yet. Help for debugging is very appreciated!). - Some bugs in the 68000 emulation have been fixed. - The emulator now checks for double bus errors and stops the emulation if necessary (instead of crashing the emulator). - Timer-D is now patched correctly again. - The old font has been replaced by two new fonts so that the GUI now looks better in high resolutions. - The fonts are now linked into the executable. - Added support for DIM floppy disk images.
- Loading branch information
adam
committed
Nov 19, 2004
1 parent
4c06d1f
commit c8ae031
Showing
5 changed files
with
31 additions
and
26 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,30 +1,22 @@ | ||
# $NetBSD: Makefile,v 1.11 2004/10/03 00:14:40 tv Exp $ | ||
# | ||
# $NetBSD: Makefile,v 1.12 2004/11/19 10:09:48 adam Exp $ | ||
|
||
DISTNAME= hatari-0.45 | ||
PKGREVISION= 1 | ||
DISTNAME= hatari-0.50 | ||
CATEGORIES= emulators | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hatari/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://hatari.sourceforge.net/ | ||
COMMENT= Atari ST emulator | ||
|
||
WRKSRC= ${WRKDIR}/${DISTNAME}/src | ||
USE_BUILDLINK3= YES | ||
USE_X11= YES | ||
USE_GNU_TOOLS+= make | ||
USE_BUILDLINK3= YES | ||
USE_GNU_TOOLS+= make | ||
USE_X11= YES | ||
GNU_CONFIGURE= YES | ||
|
||
ALL_TARGET= hatari | ||
MAKE_FLAGS+= DATADIR="${PREFIX}/share/hatari" | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/hatari ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/hatari | ||
${INSTALL_DATA} ${WRKSRC}/font8.bmp ${PREFIX}/share/hatari | ||
post-install: | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/hatari | ||
cd ${WRKSRC}/.. && ${INSTALL_DATA} *.txt ${PREFIX}/share/doc/hatari | ||
cd ${WRKSRC}/../doc && ${INSTALL_DATA} *.txt manual.html \ | ||
cd ${WRKSRC} && ${INSTALL_DATA} *.txt ${PREFIX}/share/doc/hatari | ||
cd ${WRKSRC}/doc && ${INSTALL_DATA} *.txt *.html \ | ||
${PREFIX}/share/doc/hatari | ||
|
||
.include "../../devel/SDL/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,12 +1,12 @@ | ||
@comment $NetBSD: PLIST,v 1.3 2004/01/01 03:18:15 cjep Exp $ | ||
@comment $NetBSD: PLIST,v 1.4 2004/11/19 10:09:48 adam Exp $ | ||
bin/hatari | ||
share/hatari/tos.img | ||
share/doc/hatari/authors.txt | ||
share/doc/hatari/changelog.txt | ||
share/doc/hatari/gpl.txt | ||
share/doc/hatari/keymap-sample.txt | ||
share/doc/hatari/manual.html | ||
share/doc/hatari/readme.txt | ||
share/doc/hatari/release-notes.txt | ||
share/hatari/font8.bmp | ||
@dirrm share/hatari | ||
@dirrm share/doc/hatari |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.3 2004/01/01 03:18:15 cjep Exp $ | ||
$NetBSD: distinfo,v 1.4 2004/11/19 10:09:48 adam Exp $ | ||
|
||
SHA1 (hatari-0.45.tar.gz) = 1cdaa5ac99330129391f70fdeac13de84b6b2c60 | ||
Size (hatari-0.45.tar.gz) = 474055 bytes | ||
SHA1 (patch-aa) = 5e0711007a690d17903972ab15528177166ff747 | ||
SHA1 (hatari-0.50.tar.gz) = 23e7086c3cb37dee30d04a3099def18efd2ec10d | ||
Size (hatari-0.50.tar.gz) = 497202 bytes | ||
SHA1 (patch-aa) = 1ebe2f92ee176cf5d5b1e4a7c5e2143b1d766ea8 | ||
SHA1 (patch-ab) = 8879321fb8acb5f9724f26bc040900dec1ba0f79 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
$NetBSD: patch-ab,v 1.1 2004/11/19 10:10:08 adam Exp $ | ||
|
||
--- configure.orig 2004-11-19 10:59:03.000000000 +0000 | ||
+++ configure | ||
@@ -2158,7 +2158,6 @@ test -z "$INSTALL_DATA" && INSTALL_DATA= | ||
|
||
# Use the following lines for a release versions: | ||
if test x"${GCC}" = xyes; then | ||
- CFLAGS="-O3 -fomit-frame-pointer" | ||
fi | ||
|
||
# extra command line options |