Skip to content

Commit

Permalink
Fix installation with python-2.5, using the appropriate infrastructure
Browse files Browse the repository at this point in the history
(following some hints by joerg@).
Add missing files to PLIST.
Mark as user-destdir ready.
Bump PKGREVISION.
  • Loading branch information
0-wiz-0 committed Jun 30, 2008
1 parent 168fc5e commit d12d61d
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 11 deletions.
22 changes: 12 additions & 10 deletions filesystems/py-fuse-bindings/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/05/04 19:51:52 agc Exp $
# $NetBSD: Makefile,v 1.2 2008/06/30 15:44:40 wiz Exp $
#

DISTNAME= fuse-python-0.2pre1-20060720
PKGNAME= ${PYPKGPREFIX}-fuse-bindings-0.2pre1
PKGREVISION= 1
CATEGORIES= filesystems python
MASTER_SITES= http://bsd.cenkes.org/myports/
EXTRACT_SUFX= .tar.bz2
Expand All @@ -11,20 +12,21 @@ MAINTAINER= [email protected]
HOMEPAGE= http://bsd.cenkes.org/myports/
COMMENT= Python bindings for FUSE and refuse

PYSETUP= setup.py
PLIST_SUBST+= PYSITELIB=${PYSITELIB:Q}
PYDISTUTILSPKG= yes
PY_PATCHLIST= yes
USE_TOOLS+= pkg-config
PKG_DESTDIR_SUPPORT= user-destdir

do-build:
cd ${WRKSRC} && ${PYTHONBIN} ${PYSETUP} build
INSTALLATION_DIRS= share/examples/fuse-python

do-install:
cd ${WRKSRC} && ${PYTHONBIN} ${PYSETUP} install
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/fuse-python
${INSTALL_SCRIPT} ${WRKSRC}/example/hello.py ${PREFIX}/share/examples/fuse-python/
${INSTALL_SCRIPT} ${WRKSRC}/example/xmp.py ${PREFIX}/share/examples/fuse-python/
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/example/hello.py \
${DESTDIR}${PREFIX}/share/examples/fuse-python/
${INSTALL_SCRIPT} ${WRKSRC}/example/xmp.py \
${DESTDIR}${PREFIX}/share/examples/fuse-python/

.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"

.include "../../mk/fuse.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
6 changes: 5 additions & 1 deletion filesystems/py-fuse-bindings/PLIST
Original file line number Diff line number Diff line change
@@ -1,13 +1,17 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/05/04 19:51:52 agc Exp $
@comment $NetBSD: PLIST,v 1.2 2008/06/30 15:44:41 wiz Exp $
${PYSITELIB}/fuse.py
${PYSITELIB}/fuse.pyc
${PYSITELIB}/fuse.pyo
${PYSITELIB}/fuseparts/__init__.py
${PYSITELIB}/fuseparts/__init__.pyc
${PYSITELIB}/fuseparts/__init__.pyo
${PYSITELIB}/fuseparts/_fusemodule.so
${PYSITELIB}/fuseparts/setcompatwrap.py
${PYSITELIB}/fuseparts/setcompatwrap.pyc
${PYSITELIB}/fuseparts/setcompatwrap.pyo
${PYSITELIB}/fuseparts/subbedopts.py
${PYSITELIB}/fuseparts/subbedopts.pyc
${PYSITELIB}/fuseparts/subbedopts.pyo
share/examples/fuse-python/hello.py
share/examples/fuse-python/xmp.py
@dirrm share/examples/fuse-python
Expand Down

0 comments on commit d12d61d

Please sign in to comment.