-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix installation with python-2.5, using the appropriate infrastructure
(following some hints by joerg@). Add missing files to PLIST. Mark as user-destdir ready. Bump PKGREVISION.
- Loading branch information
Showing
2 changed files
with
17 additions
and
11 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,9 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 2007/05/04 19:51:52 agc Exp $ | ||
# $NetBSD: Makefile,v 1.2 2008/06/30 15:44:40 wiz Exp $ | ||
# | ||
|
||
DISTNAME= fuse-python-0.2pre1-20060720 | ||
PKGNAME= ${PYPKGPREFIX}-fuse-bindings-0.2pre1 | ||
PKGREVISION= 1 | ||
CATEGORIES= filesystems python | ||
MASTER_SITES= http://bsd.cenkes.org/myports/ | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
@@ -11,20 +12,21 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://bsd.cenkes.org/myports/ | ||
COMMENT= Python bindings for FUSE and refuse | ||
|
||
PYSETUP= setup.py | ||
PLIST_SUBST+= PYSITELIB=${PYSITELIB:Q} | ||
PYDISTUTILSPKG= yes | ||
PY_PATCHLIST= yes | ||
USE_TOOLS+= pkg-config | ||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
do-build: | ||
cd ${WRKSRC} && ${PYTHONBIN} ${PYSETUP} build | ||
INSTALLATION_DIRS= share/examples/fuse-python | ||
|
||
do-install: | ||
cd ${WRKSRC} && ${PYTHONBIN} ${PYSETUP} install | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/fuse-python | ||
${INSTALL_SCRIPT} ${WRKSRC}/example/hello.py ${PREFIX}/share/examples/fuse-python/ | ||
${INSTALL_SCRIPT} ${WRKSRC}/example/xmp.py ${PREFIX}/share/examples/fuse-python/ | ||
post-install: | ||
${INSTALL_SCRIPT} ${WRKSRC}/example/hello.py \ | ||
${DESTDIR}${PREFIX}/share/examples/fuse-python/ | ||
${INSTALL_SCRIPT} ${WRKSRC}/example/xmp.py \ | ||
${DESTDIR}${PREFIX}/share/examples/fuse-python/ | ||
|
||
.include "../../lang/python/application.mk" | ||
.include "../../lang/python/extension.mk" | ||
|
||
.include "../../mk/fuse.buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters