-
Notifications
You must be signed in to change notification settings - Fork 163
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Update geography/mapcode to 2.5.1. Fix cmake build.
2.5.1 - Updated unit test to compile with plain C and added some test cases. 2.5.0 - Added support for getting territory names in English and local alphabets. - Added much improved unit test scripts to run gprof, valgrind, the CLang address sanitize and compare the output of the new library with and older version.
- Loading branch information
Showing
3 changed files
with
44 additions
and
14 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,7 @@ | ||
$NetBSD: distinfo,v 1.2 2016/10/26 10:50:33 fhajny Exp $ | ||
$NetBSD: distinfo,v 1.3 2016/11/03 15:06:41 fhajny Exp $ | ||
|
||
SHA1 (mapcode-cpp-2.4.0.tar.gz) = 393cdb4cb935847d122bc09f351c9f639b6fa96e | ||
RMD160 (mapcode-cpp-2.4.0.tar.gz) = 2ffff7a096bbab58571f7ac8223ad86f602a67e4 | ||
SHA512 (mapcode-cpp-2.4.0.tar.gz) = 657543dcc31433d48a33cf3e499f33581d7f2b01c6fe5f203a811d31d82df13e869a914098ed9d1ade349b929012d2b91175f55074b34a9fcb7af49fa556fc7a | ||
Size (mapcode-cpp-2.4.0.tar.gz) = 990523 bytes | ||
SHA1 (mapcode-cpp-2.5.1.tar.gz) = d988b54e7303067959c32d9f09fe58bbfbc6b4ad | ||
RMD160 (mapcode-cpp-2.5.1.tar.gz) = 249060a872ad83599c77556f9002cef9d48cb182 | ||
SHA512 (mapcode-cpp-2.5.1.tar.gz) = 01a14a12c233be40f3014d535fba418685f327a1e7b59b41d8931fd7376f85049c81f35eec7b307b809f484fe2e6b513604f30dc7702c07ed606705c1f07f275 | ||
Size (mapcode-cpp-2.5.1.tar.gz) = 1043969 bytes | ||
SHA1 (patch-CMakeLists.txt) = 4d029bd3666278d52aa41e9ea831b5f5544555c1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
$NetBSD: patch-CMakeLists.txt,v 1.1 2016/11/03 15:06:41 fhajny Exp $ | ||
|
||
Fix cmake build, ensure sane lib name. | ||
|
||
--- CMakeLists.txt.orig 2016-11-02 12:47:12.000000000 +0000 | ||
+++ CMakeLists.txt | ||
@@ -43,6 +43,9 @@ set(CMAKE_EXE_LINKER_FLAGS_DEBUG "${MAPC | ||
set(CMAKE_EXE_LINKER_FLAGS_RELWITHDEBINFO "${MAPCODE_SANITIZER_LINKER_OPTIONS}") | ||
set(CMAKE_EXE_LINKER_FLAGS_RELEASE "") | ||
|
||
+set(EXECUTABLE_OUTPUT_PATH "${CMAKE_BINARY_DIR}/build" ) | ||
+set(LIBRARY_OUTPUT_PATH "${CMAKE_BINARY_DIR}/build" ) | ||
+ | ||
set(SOURCE_FILES_MAPCODELIB | ||
mapcodelib/internal_data.h | ||
mapcodelib/internal_alphabet_recognizer.h | ||
@@ -65,7 +68,8 @@ set(SOURCE_FILES_UNITTEST | ||
set(SOURCE_FILES_UTILITY | ||
utility/mapcode.cpp) | ||
|
||
-add_library(mapcodelib ${SOURCE_FILES_MAPCODELIB}) | ||
+add_library(mapcodelib SHARED ${SOURCE_FILES_MAPCODELIB}) | ||
+set_target_properties(mapcodelib PROPERTIES OUTPUT_NAME mapcode) | ||
target_include_directories(mapcodelib PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}) | ||
|
||
add_executable(unittest ${SOURCE_FILES_UNITTEST}) |