Skip to content

Commit

Permalink
update to 0.10.15
Browse files Browse the repository at this point in the history
changes:
-amrnbenc: give element a rank (SECONDARY) so it's autoplugged
-rmdemux: descramble sipro audio before pushing out
-x264enc: fix up codec_data / avcC header construction some more
-x264enc: Put pixel-aspect-ratio from input into the src pad caps

pkgsrc note: patch-ab was added to work around an API incompatibility
to pkgsrc's old libx264, can be removed if libx264 gets updated (which
is currently not possible due to pkgsrc's even older ffmpeg)
I've tested gst-x264enc only with a simple testcase (videotestsrc!x264enc)
and it seems to work so far.
  • Loading branch information
drochner committed Jul 13, 2010
1 parent 0bc973f commit df72a2e
Show file tree
Hide file tree
Showing 4 changed files with 21 additions and 20 deletions.
4 changes: 2 additions & 2 deletions multimedia/gst-plugins0.10-ugly/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.14 2010/06/03 07:50:57 obache Exp $
# $NetBSD: Makefile.common,v 1.15 2010/07/13 18:16:39 drochner Exp $
#
# used by audio/gst-plugins0.10-a52/Makefile
# used by audio/gst-plugins0.10-mad/Makefile
Expand All @@ -8,7 +8,7 @@
# used by multimedia/gst-plugins0.10-x264/Makefile

GST_PLUGINS0.10_TYPE= ugly
GST_PLUGINS0.10_VER= 0.10.14
GST_PLUGINS0.10_VER= 0.10.15

# Disable all drivers and features by default.
.for driver in a52dec \
Expand Down
10 changes: 5 additions & 5 deletions multimedia/gst-plugins0.10-ugly/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.14 2010/03/12 20:56:14 drochner Exp $
$NetBSD: distinfo,v 1.15 2010/07/13 18:16:39 drochner Exp $

SHA1 (gst-plugins-ugly-0.10.14.tar.bz2) = b1622b732335835c73b334c3769e00834ad0e387
RMD160 (gst-plugins-ugly-0.10.14.tar.bz2) = 37708268cda49a77faf28a26f04191a50c2830fe
Size (gst-plugins-ugly-0.10.14.tar.bz2) = 1028518 bytes
SHA1 (patch-aa) = 456f22518e96cf554eab1f62cb4b2f33fae535e6
SHA1 (gst-plugins-ugly-0.10.15.tar.bz2) = d94b696cb2abba8e8780e6aa9c04e86b2d06aad8
RMD160 (gst-plugins-ugly-0.10.15.tar.bz2) = f60c2f1a92c12851bbd6880145659aafdc6f12a3
Size (gst-plugins-ugly-0.10.15.tar.bz2) = 1034223 bytes
SHA1 (patch-ab) = 09f80db045a4b5fa49615f9ac99e9bb01d6ecc0a
13 changes: 0 additions & 13 deletions multimedia/gst-plugins0.10-ugly/patches/patch-aa

This file was deleted.

14 changes: 14 additions & 0 deletions multimedia/gst-plugins0.10-ugly/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
$NetBSD: patch-ab,v 1.3 2010/07/13 18:16:39 drochner Exp $

--- ext/x264/gstx264enc.c.orig 2010-05-28 11:13:32.000000000 +0000
+++ ext/x264/gstx264enc.c
@@ -594,7 +594,9 @@ gst_x264_enc_init_encoder (GstX264Enc *
encoder->x264param.analyse.inter = encoder->analyse;
encoder->x264param.analyse.b_transform_8x8 = encoder->dct8x8;
encoder->x264param.analyse.b_weighted_bipred = encoder->weightb;
+#if 0
encoder->x264param.analyse.i_weighted_pred = 0;
+#endif
encoder->x264param.analyse.i_noise_reduction = encoder->noise_reduction;
encoder->x264param.i_frame_reference = encoder->ref;
encoder->x264param.i_bframe = encoder->bframes;

0 comments on commit df72a2e

Please sign in to comment.