Skip to content

Commit

Permalink
Change BUILD_DEPENDS semantics:
Browse files Browse the repository at this point in the history
first component is now a package name+version/pattern, no more
executable/patchname/whatnot.

While there, introduce BUILD_USES_MSGFMT as shorthand to pull in
devel/gettext unless /usr/bin/msgfmt exists (i.e. on post-1.5 -current).

Patch by Alistair Crooks <[email protected]>
  • Loading branch information
hubertf committed Mar 27, 2001
1 parent d5f813f commit e32afb6
Show file tree
Hide file tree
Showing 204 changed files with 593 additions and 592 deletions.
91 changes: 51 additions & 40 deletions Packages.txt
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Packages.txt,v 1.146 2001/03/23 17:11:17 skrll Exp $
# $NetBSD: Packages.txt,v 1.147 2001/03/27 03:19:43 hubertf Exp $
###########################################################################

==========================
Expand Down Expand Up @@ -1591,64 +1591,75 @@ not the same as FreeBSD's deprecated one, and NetBSD does not use the
FreeBSD LIB_DEPENDS definition any more - it proved problematic on ELF
NetBSD platforms).

[In the following examples, the BUILD_DEPENDS dependencies have the format:
<file>:<directory containing package to build>[:<stage>] If the <stage>
isn't specified, it defaults to ``install''. If the file contains a '/', it
is interpreted as a regular file - otherwise, the name is taken to be an
executable file, and the PATH is searched for <file>. If the regular file
is not found, or the executable file is not in the path, then the
pre-requisite package will be built from the sources in <directory
containing the package to build>. The DEPENDS definition specifies a
package name (which contains its version number), and the directory
containing the package to build if this version of the package is not
installed.]

(a) If your package needs files from another package to build, see the
print/ghostscript5 package (it relies on the jpeg sources being
present in source form during the build):

BUILD_DEPENDS+= ../../graphics/jpeg/${WRKDIR:T}/jpeg-6a:../../graphics/jpeg:extract

(b) If your package needs to use another package to build itself, this
is specified using the BUILD_DEPENDS definition, but without
specifying the stage ``:extract'' in (a) above. An example is the
print/lyx package, which uses the latex binary during its build
process:

BUILD_DEPENDS+= latex:../../print/teTeX

(c) If your package needs a library with which to link, this is
The basic difference between the two definitions is as follows: the
DEPENDS definition registers that pre-requisite in the binary package,
whilst the BUILD_DEPENDS definition does not.

This means that if you only need a package present whilst you are building,
it should be noted as a BUILD_DEPENDS.

The format for a BUILD_DEPENDS and a DEPENDS definition is:

<pre-req-package-name>:../../<category>/<pre-req-package>

Please note that the "pre-req-package-name" may include any of the wildcard
version numbers recognised by pkg_info(1).

(a) If your package needs to use another package to build itself, this
is specified using the BUILD_DEPENDS definition.

BUILD_DEPENDS+= autoconf-2.13:../../devel/autoconf

(b) If your package needs a library with which to link, this is
specified using the DEPENDS definition. An example of this is the
print/lyx package, which uses the xpm library, version 3.4j to build.

DEPENDS+= xpm-3.4j:../../graphics/xpm
DEPENDS+= xpm-3.4j:../../graphics/xpm

You can also use wildcards in package dependences:

DEPENDS+= xpm-*:../../graphics/xpm
DEPENDS+= xpm-*:../../graphics/xpm

Note that such wildcard dependencies are retained when creating binary
packages. The dependency is checked when installing the binary
package and any package which matches the pattern will be used.
Wildard dependencies should be used with care.

Note that such wildcard dependencies are retained when creating
binary package. The dependency is checked when installing the binary
package and any package which matches the pattern would be used.
Beware that wildard dependencies should be used with a bit of care.
Simple example for package which needs some version of Tk installed,
but doesn't care which exactly - dependency
For example, if a package needs any version of Tk installed, but does
not require an explicit version of Tk:

DEPENDS+= tk-*:../../x11/tk80
DEPENDS+= tk-*:../../x11/tk80

would also match e.g. tk-postgresql-6.5.3, which is not what was
needed. ALWAYS ensure that the wildcard doesn't match more than it should.
needed. ALWAYS ensure that the wildcard doesn't match more than it should,
and perhaps use version numbers to make certain:

BUILD_DEPENDS+= perl-5.*:../../lang/perl

(d) If your package needs some executable to be able to run correctly, this
(c) If your package needs some executable to be able to run correctly, this
is specified using the DEPENDS definition. The print/lyx package needs to
be able to execute the latex binary from the teTex package when it runs,
and that is specified:

DEPENDS+= teTex-*:../../print/teTeX
DEPENDS+= teTex-*:../../print/teTeX

The comment about wildcard dependencies from previous paragraph
applies here, too.

If your package needs files from another package to build, see the
first part of the "do-configure" target print/ghostscript5 package (it
relies on the jpeg sources being present in source form during the
build):

if [ ! -e ${BUILD_ROOT}/graphics/jpeg/${WRKDIR:T}/jpeg-6b ]; then \
cd ../../graphics/jpeg && ${MAKE} extract; \
fi

Please also note the BUILD_USES_MSGFMT definition, which is provided
as a convenience definition. This definition works out whether
msgfmt(1) is part of the base system, and, if it isn't, installs the
devel/gettext package.


9.13 Conflicts with other packages
==================================
Expand Down
4 changes: 2 additions & 2 deletions archivers/gsharutils/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2001/02/16 13:15:27 wiz Exp $
# $NetBSD: Makefile,v 1.7 2001/03/27 03:19:44 hubertf Exp $

DISTNAME= sharutils-4.2.1
PKGNAME= g${DISTNAME}
Expand All @@ -9,7 +9,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.gnu.org/software/sharutils/sharutils.html
COMMENT= Allow packing and unpacking of shell archives

BUILD_DEPENDS+= msgfmt:../../devel/gettext
BUILD_USES_MSGFMT= yes

USE_LIBINTL= yes
GNU_CONFIGURE= yes
Expand Down
4 changes: 2 additions & 2 deletions archivers/zip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.22 2001/02/16 13:15:43 wiz Exp $
# $NetBSD: Makefile,v 1.23 2001/03/27 03:19:44 hubertf Exp $
# FreeBSD Id: Makefile,v 1.10 1997/04/27 16:06:15 ache Exp
#

Expand All @@ -13,7 +13,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.info-zip.org/pub/infozip/Zip.html
COMMENT= Create/update ZIP files compatible with pkzip

BUILD_DEPENDS= unzip:../../archivers/unzip
BUILD_DEPENDS= unzip-*:../../archivers/unzip

EXTRACT_ONLY= zip23.tar.gz
MAKEFILE= unix/Makefile
Expand Down
4 changes: 2 additions & 2 deletions archivers/zip1/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2001/02/16 13:15:44 wiz Exp $
# $NetBSD: Makefile,v 1.12 2001/03/27 03:19:45 hubertf Exp $
#

DISTNAME= zip1-1.1
Expand All @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.info-zip.org/pub/infozip/
COMMENT= Create/update ZIP files compatible with pkzip version 1

BUILD_DEPENDS= unzip:../../archivers/unzip
BUILD_DEPENDS= unzip-*:../../archivers/unzip

EXTRACT_CMD= unzip -qo ${DOWNLOADED_DISTFILE}

Expand Down
5 changes: 3 additions & 2 deletions audio/aumix/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2001/02/16 13:30:33 wiz Exp $
# $NetBSD: Makefile,v 1.8 2001/03/27 03:19:45 hubertf Exp $

DISTNAME= aumix-2.7
CATEGORIES= audio
Expand All @@ -12,7 +12,8 @@ MAINTAINER= [email protected]
HOMEPAGE= http://jpj.net/~trevor/aumix.html
COMMENT= Set mix levels

BUILD_DEPENDS+= msgfmt:../../devel/gettext
BUILD_USES_MSGFMT= yes

DEPENDS+= gtk+-1.2.*:../../x11/gtk

USE_CURSES= yes
Expand Down
4 changes: 2 additions & 2 deletions audio/cdd/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2001/02/16 13:30:33 wiz Exp $
# $NetBSD: Makefile,v 1.9 2001/03/27 03:19:45 hubertf Exp $

DISTNAME= cdd-1.0nb3
CATEGORIES= audio
Expand All @@ -7,7 +7,7 @@ MASTER_SITES= ${MASTER_SITE_LOCAL}
MAINTAINER= [email protected]
COMMENT= Another program for reading CD digital audio from SCSI or ATAPI CD-ROM drives

BUILD_DEPENDS+= ${PREFIX}/lib/libscsi.a:../../devel/libscsi
BUILD_DEPENDS+= libscsi-1.6:../../devel/libscsi

.include "../../mk/bsd.prefs.mk"

Expand Down
4 changes: 2 additions & 2 deletions audio/csound/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/03/13 13:18:24 wiz Exp $
# $NetBSD: Makefile,v 1.2 2001/03/27 03:19:45 hubertf Exp $
#

DISTNAME= unofficial-csound-4.09.0.0b-linux.src
Expand All @@ -10,7 +10,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.csound.org
COMMENT= software synthesizer and sequencer

BUILD_DEPENDS+= ${LOCALBASE}/bin/autoreconf:../../devel/autoconf
BUILD_DEPENDS+= autoconf-2.13:../../devel/autoconf

LICENSE= csound-license
NO_SRC_ON_CDROM= "no for-fee-redistribution"
Expand Down
4 changes: 2 additions & 2 deletions audio/eawpatches/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/03/16 12:52:31 wiz Exp $
# $NetBSD: Makefile,v 1.5 2001/03/27 03:19:45 hubertf Exp $
#

DISTNAME= eawpats-full-10
Expand All @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.stardate.bc.ca/eawpatches/
COMMENT= Eric A. Welsh' patches (audio samples) for TiMidity

BUILD_DEPENDS= unrar:../../archivers/unrar
BUILD_DEPENDS= unrar-*:../../archivers/unrar

CONFLICTS= guspatches-*

Expand Down
4 changes: 2 additions & 2 deletions audio/gogo/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/02/16 13:30:41 wiz Exp $
# $NetBSD: Makefile,v 1.5 2001/03/27 03:19:45 hubertf Exp $
#

DISTNAME= gogo235
Expand All @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://homepage1.nifty.com/herumi/gogo_e.html
COMMENT= very fast lame-based mp3 encoder, i386 only

BUILD_DEPENDS+= nasm:../../devel/nasm
BUILD_DEPENDS+= nasm-0.98:../../devel/nasm

ONLY_FOR_PLATFORM= *-*-i386

Expand Down
5 changes: 3 additions & 2 deletions audio/gqmpeg/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.32 2001/03/25 16:21:51 hubertf Exp $
# $NetBSD: Makefile,v 1.33 2001/03/27 03:19:46 hubertf Exp $
# FreeBSD Id: Makefile,v 1.6 1998/12/28 01:02:05 vanilla Exp

DISTNAME= gqmpeg-0.8.3
Expand All @@ -10,8 +10,9 @@ MAINTAINER= [email protected]
HOMEPAGE= http://gqmpeg.sourceforge.net/
COMMENT= GTK+ front end to mpg123

BUILD_USES_MSGFMT= yes

DEPENDS+= gdk-pixbuf>=0.8.0nb1:../../graphics/gdk-pixbuf
BUILD_DEPENDS+= msgfmt:../../devel/gettext
DEPENDS+= gtk+-1.2.*:../../x11/gtk
DEPENDS+= mpg123-0.59r:../../audio/mpg123

Expand Down
12 changes: 9 additions & 3 deletions audio/krio/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/03/04 09:06:09 tron Exp $
# $NetBSD: Makefile,v 1.5 2001/03/27 03:19:46 hubertf Exp $

DISTNAME= Krio-19990721
PKGNAME= krio-19990721
Expand All @@ -15,8 +15,6 @@ USE_X11BASE= yes

RIODIR= ${PKGSRCDIR}/audio/rio/${WRKDIR:T}/rio107

BUILD_DEPENDS+= ${RIODIR}/rio.cpp:../../audio/rio:configure

DEPENDS+= jpeg-6b:../../graphics/jpeg
DEPENDS+= kdelibs-1.1.2:../../x11/kdelibs
DEPENDS+= png>1.0.9:../../graphics/png
Expand All @@ -29,4 +27,12 @@ EVAL_PREFIX= QT1DIR=qt1 KDEDIR=kdelibs
MAKE_ENV+= QT1DIR=${QT1DIR} KDEDIR=${KDEDIR}
MAKE_ENV+= RIODIR=${RIODIR} X11PREFIX=${X11PREFIX}

pre-configure:
if [ ! -e ${RIODIR} ]; then \
cd ../../audio/rio && ${MAKE} configure; \
fi

pre-clean:
cd ../../audio/rio && ${MAKE} clean

.include "../../mk/bsd.pkg.mk"
6 changes: 3 additions & 3 deletions audio/libao/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2001/03/20 09:57:36 wiz Exp $
# $NetBSD: Makefile,v 1.3 2001/03/27 03:19:46 hubertf Exp $

DISTNAME= libao-0.6.0
PKGNAME= ${DISTNAME}nb1
Expand All @@ -8,8 +8,8 @@ MASTER_SITES= http://www.vorbis.com/files/beta4/unix/
MAINTAINER= [email protected]
COMMENT= cross-platform audio library

BUILD_DEPENDS+= ${LOCALBASE}/bin/automake:../../devel/automake
BUILD_DEPENDS+= ${LOCALBASE}/bin/autoconf:../../devel/autoconf
BUILD_DEPENDS+= automake-1.4:../../devel/automake
BUILD_DEPENDS+= autoconf-2.13:../../devel/autoconf

GNU_CONFIGURE= yes
USE_GMAKE= yes
Expand Down
4 changes: 2 additions & 2 deletions audio/madplay/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2001/03/25 11:34:57 simonb Exp $
# $NetBSD: Makefile,v 1.14 2001/03/27 03:19:46 hubertf Exp $
#

DISTNAME= mad-0.12.5b
Expand All @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://sourceforge.net/projects/mad/
COMMENT= High-quality MPEG audio decoder

BUILD_DEPENDS+= msgfmt:../../devel/gettext
BUILD_USES_MSGFMT= yes

GNU_CONFIGURE= YES
USE_LIBINTL= YES
Expand Down
5 changes: 3 additions & 2 deletions audio/rplay/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2001/02/16 13:30:49 wiz Exp $
# $NetBSD: Makefile,v 1.24 2001/03/27 03:19:46 hubertf Exp $
# FreeBSD Id: Makefile,v 1.8 1997/06/13 16:17:01 ache Exp
#

Expand All @@ -11,7 +11,8 @@ MAINTAINER= [email protected]
HOMEPAGE= http://rplay.doit.org/
COMMENT= Network audio player

BUILD_DEPENDS+= ${LOCALBASE}/bin/autoreconf:../../devel/autoconf
BUILD_DEPENDS+= autoconf-2.13:../../devel/autoconf

DEPENDS+= gsm-1.0.10:../../audio/gsm
DEPENDS+= rx-1.5:../../devel/rx

Expand Down
4 changes: 2 additions & 2 deletions benchmarks/xengine/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.4 2001/02/25 04:17:38 hubertf Exp $
# $NetBSD: Makefile,v 1.5 2001/03/27 03:19:47 hubertf Exp $
# FreeBSD Id: ports/benchmarks/xengine/Makefile,v 1.9 2000/02/02 22:31:24 mharo Exp

DISTNAME= xengine-1.0.1
Expand All @@ -11,7 +11,7 @@ PATCH_DIST_STRIP= -p1 # no ${PATCHFILES} but used below
MAINTAINER= [email protected]
COMMENT= Reciprocating engine for X

BUILD_DEPENDS= gunshar:../../archivers/gsharutils
BUILD_DEPENDS= gsharutils-4.2.1:../../archivers/gsharutils

DIST_SUBDIR= xengine
NO_WRKSUBDIR= yes
Expand Down
4 changes: 2 additions & 2 deletions cad/ipal-current/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2001/02/16 13:46:24 wiz Exp $
# $NetBSD: Makefile,v 1.8 2001/03/27 03:19:47 hubertf Exp $
#

DISTNAME= ipal-20001210
Expand All @@ -10,7 +10,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.icarus.com/eda/ipal/index.html
COMMENT= Libs and utils for manipulating PAL designs (development version)

BUILD_DEPENDS+= bison:../../devel/bison
BUILD_DEPENDS+= bison-*:../../devel/bison
DEPENDS+= gtk+>=1.2.7:../../x11/gtk

GNU_CONFIGURE= YES
Expand Down
6 changes: 3 additions & 3 deletions cad/verilog-current/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2001/02/16 13:46:30 wiz Exp $
# $NetBSD: Makefile,v 1.13 2001/03/27 03:19:47 hubertf Exp $
#

DISTNAME= verilog-20010113
Expand All @@ -10,8 +10,8 @@ MAINTAINER= [email protected]
HOMEPAGE= http://icarus.com/eda/verilog/index.html
COMMENT= Verilog simulation and synthesis tool (development snapshot version)

BUILD_DEPENDS+= bison:../../devel/bison
BUILD_DEPENDS+= gperf:../../devel/gperf
BUILD_DEPENDS+= bison-*:../../devel/bison
BUILD_DEPENDS+= gperf-2.7.2:../../devel/gperf
DEPENDS+= ipal-current>=20001210:../../cad/ipal-current

CONFLICTS+= verilog
Expand Down
6 changes: 3 additions & 3 deletions cad/verilog/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2001/02/16 13:46:29 wiz Exp $
# $NetBSD: Makefile,v 1.7 2001/03/27 03:19:47 hubertf Exp $
#

DISTNAME= verilog-0.4
Expand All @@ -9,8 +9,8 @@ MAINTAINER= [email protected]
HOMEPAGE= http://icarus.com/eda/verilog/index.html
COMMENT= Verilog simulation and synthesis tool (stable release version)

BUILD_DEPENDS+= bison:../../devel/bison
BUILD_DEPENDS+= gperf:../../devel/gperf
BUILD_DEPENDS+= bison-*:../../devel/bison
BUILD_DEPENDS+= gperf-2.7.2:../../devel/gperf
DEPENDS+= ipal-current>=20001210:../../cad/ipal-current

CONFLICTS+= verilog-current
Expand Down
Loading

0 comments on commit e32afb6

Please sign in to comment.