Skip to content

Commit

Permalink
FIX: sendmail is /usr/sbin/sendmail on NetBSD (now notify works).
Browse files Browse the repository at this point in the history
While fixing that, I broke out the huge multi-file patch-aa into
separate patch files for each patched file in the distribution,
and moved new files into ${FILESDIR} for easier maintenance.
  • Loading branch information
suominen committed Aug 29, 1999
1 parent 05b2a7c commit e61af24
Show file tree
Hide file tree
Showing 12 changed files with 330 additions and 375 deletions.
8 changes: 7 additions & 1 deletion net/rdist6/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 1998/08/20 15:17:18 tsarna Exp $
# $NetBSD: Makefile,v 1.4 1999/08/29 12:26:19 kim Exp $
#

DISTNAME= rdist-6.1.4
Expand All @@ -13,6 +13,12 @@ RDIST6_NAME= rdist6
INSTALL_TARGET= install install.man
MAKE_ENV+= RDIST6_NAME=${RDIST6_NAME}

pre-patch:
@${CP} \
${FILESDIR}/mf.netbsd \
${FILESDIR}/os-netbsd.h \
${WRKSRC}/config

post-install:
@strip ${PREFIX}/bin/${RDIST6_NAME}
@strip ${PREFIX}/bin/rdistd
Expand Down
22 changes: 22 additions & 0 deletions net/rdist6/files/mf.netbsd
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
# $NetBSD: mf.netbsd,v 1.1 1999/08/29 12:26:20 kim Exp $
#
# NetBSD Makefile
#

#
# Functions that are missing in this OS are contained in the
# files specified in ${MISSINGOBJS}.
#
#MISSINGOBJS = $(O)strerror.o $(O)strcasecmp.o

#
# System libraries that we need to load.
#
LIB_SYS = -lcompat

#
# System dependent options for compiling
#
#CFLAGS_OS =

BIN_DIR = /usr/local/bin
124 changes: 124 additions & 0 deletions net/rdist6/files/os-netbsd.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,124 @@
/* $NetBSD: os-netbsd.h,v 1.1 1999/08/29 12:26:21 kim Exp $
*/

/*
* Define the following name for use in #ifdef's.
* The value should be all upper-case with no periods (.).
*/
#if !defined(NETBSD)
#define NETBSD
#endif

/*
* NOTE: NetBSD uses 64-bit file size semantics, and so you
* must be careful when using varargs-type functions
* like the *printf family when printing elements which
* might be 64-bits (such as stat->st_size from stat.h).
*/

/*
* Set process args to messages that show up when running ps(1)
*
* Under some OS's, the SETARGS code will cause ": is not an identifier"
* errors for "special" commands.
*/
#define SETARGS

/*
* Define the type of directory routines your system has.
*/
#define DIR_TYPE DIR_DIRENT

/*
* Determine what routines we have to get filesystem info.
*/
#define FSI_TYPE FSI_GETFSSTAT

/*
* Type of non-blocking I/O.
*/
#define NBIO_TYPE NBIO_FCNTL

/*
* Type of wait() function to use.
*/
#define WAIT_TYPE WAIT_WAIT3

/*
* Type of argument passed to wait() (above).
*/
#define WAIT_ARG_TYPE int

/*
* Select the type of executable file format.
*/
#define EXE_TYPE EXE_AOUT

/*
* Select the type of statfs() system call (if any).
*/
#define STATFS_TYPE STATFS_BSD

/*
* Type of arg functions we have.
*/
#define ARG_TYPE ARG_STDARG

/*
* UID argument type for chown()
*/
typedef uid_t CHOWN_UID_T;

/*
* GID argument type for chown()
*/
typedef gid_t CHOWN_GID_T;

/*
* Our types, usually these are uid_t and gid_t.
*/
typedef uid_t UID_T; /* Must be signed */
typedef gid_t GID_T; /* Must be signed */

/*
* Generic pointer, used by memcpy, malloc, etc. Usually char or void.
*/
typedef void POINTER;

/*
* Type of set file time function available
*/
#define SETFTIME_TYPE SETFTIME_UTIMES

/*
* Type of set line buffering function available
*/
#define SETBUF_TYPE SETLINEBUF

/*
* Things we have
*/
#define HAVE_FCHOWN /* Have fchown() */
#define HAVE_FCHMOD /* Have fchmod() */
#define HAVE_SELECT /* Have select() */
#define HAVE_SAVED_IDS /* Have POSIX style saved [ug]id's */
#define POSIX_SIGNALS /* Have POSIX signals */

/*
* Things we need
*/
#define NEED_UNISTD_H /* Need <unistd.h> */

/*
* Path to the remote shell command.
* Define this only if the pathname is different than
* that which appears in "include/paths.h".
*/
#define _PATH_REMSH "/usr/bin/rsh"

/*
* Path to the sendmail command.
*/
#ifndef _PATH_SENDMAIL
#define _PATH_SENDMAIL "/usr/sbin/sendmail"
#endif
11 changes: 9 additions & 2 deletions net/rdist6/files/patch-sum
Original file line number Diff line number Diff line change
@@ -1,3 +1,10 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 14:12:27 agc Exp $
$NetBSD: patch-sum,v 1.2 1999/08/29 12:26:21 kim Exp $

MD5 (patch-aa) = 2830bf9712392b4cb018107b99daa3f2
MD5 (patch-aa) = c5e9a5acd315f3715323700e27d7b208
MD5 (patch-ab) = e21fb981d9e9bb3f1eeebf59b279eb9a
MD5 (patch-ac) = dee3dab4fa644050c6bdeb863ce60cd5
MD5 (patch-ad) = d70b67f7871d6a276a96be80b8cc9242
MD5 (patch-ae) = 6adfdfc96017cbd039f7c6e74959529e
MD5 (patch-af) = 6ad7be9db90f998dad85832d60a28acf
MD5 (patch-ag) = 69628c934eec9549ada7c6c0665cc13b
MD5 (patch-ah) = 4995c7a3306861dee58c55dcc2713251
Loading

0 comments on commit e61af24

Please sign in to comment.