Skip to content

Commit

Permalink
The interpreter check for packages which are their own interpreter,
Browse files Browse the repository at this point in the history
e.g. lang/perl5, was failing.  Adding a check for ${DESTDIR}"$$interp"
fixes this.
  • Loading branch information
bjs committed Nov 30, 2007
1 parent 2e61a00 commit ee769f9
Showing 1 changed file with 6 additions and 2 deletions.
8 changes: 6 additions & 2 deletions mk/check/check-interpreter.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: check-interpreter.mk,v 1.20 2007/11/07 10:52:00 rillig Exp $
# $NetBSD: check-interpreter.mk,v 1.21 2007/11/30 08:34:31 bjs Exp $
#
# This file checks that after installation, all files of the package
# that start with a "#!" line will find their interpreter. Files that
Expand Down Expand Up @@ -63,10 +63,14 @@ _check-interpreter: error-check .PHONY
case "$$interp" in \
"") continue; \
esac; \
if [ ! -f "$$interp" ]; then \
\
if { [ ! -f ${DESTDIR:Q}"$$interp" ] && \
[ ! -f "$$interp" ]; }; then \
\
if [ -x "$$file" ]; then \
${DELAYED_ERROR_MSG} "[check-interpreter.mk] The interpreter \"$$interp\" of \"${DESTDIR}${PREFIX}/$$file\" does not exist."; \
else \
\
${DELAYED_WARNING_MSG} "[check-interpreter.mk] The interpreter \"$$interp\" of \"${DESTDIR}${PREFIX}/$$file\" does not exist."; \
fi; \
fi; \
Expand Down

0 comments on commit ee769f9

Please sign in to comment.