Skip to content

Commit

Permalink
".for variable names should not contain uppercase letters"
Browse files Browse the repository at this point in the history
  • Loading branch information
rodent committed Apr 6, 2013
1 parent 9fcd703 commit f5f81cb
Show file tree
Hide file tree
Showing 21 changed files with 110 additions and 110 deletions.
6 changes: 3 additions & 3 deletions biology/genesplicer/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2012/09/11 20:32:12 asau Exp $
# $NetBSD: Makefile,v 1.13 2013/04/06 13:24:18 rodent Exp $
#

DISTNAME= GeneSplicer
Expand All @@ -24,8 +24,8 @@ INSTALLATION_DIRS= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sources/genesplicer ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA_DIR} ${DESTDIR}${EXDIR}
.for DOC in readme fasta.example fasta.results
${INSTALL_DATA} ${WRKSRC}/sources/${DOC} ${DESTDIR}${EXDIR}
.for doc in readme fasta.example fasta.results
${INSTALL_DATA} ${WRKSRC}/sources/${doc} ${DESTDIR}${EXDIR}
.endfor
cd ${WRKSRC} && pax -rw ${EXAMPLES} ${DESTDIR}${EXDIR}

Expand Down
10 changes: 5 additions & 5 deletions biology/glimmer/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2012/09/16 17:20:17 cheusov Exp $
# $NetBSD: Makefile,v 1.13 2013/04/06 13:24:18 rodent Exp $
#

DISTNAME= glimmer213
Expand All @@ -19,16 +19,16 @@ WRKSRC= ${WRKDIR}/glimmer2.13
INSTALLATION_DIRS= bin

do-install:
.for PROGRAM in adjust anomaly build-icm check codon-usage compare-lists \
.for program in adjust anomaly build-icm check codon-usage compare-lists \
generate get-len get-putative glimmer2 long-orfs
${INSTALL_PROGRAM} ${WRKSRC}/${PROGRAM} ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${program} ${DESTDIR}${PREFIX}/bin
.endfor
# ``extract'' is also in the csound package, so rename to avoid conflict
${INSTALL_PROGRAM} ${WRKSRC}/extract ${DESTDIR}${PREFIX}/bin/glextract
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/glimmer
${CP} ${WRKSRC}/README ${WRKSRC}/run-glimmer2.readme
.for DOC in run-glimmer2.readme build-icm.readme extract.readme glimmer2.readme long-orfs.readme
${INSTALL_DATA} ${WRKSRC}/${DOC} ${DESTDIR}${PREFIX}/share/doc/glimmer
.for doc in run-glimmer2.readme build-icm.readme extract.readme glimmer2.readme long-orfs.readme
${INSTALL_DATA} ${WRKSRC}/${doc} ${DESTDIR}${PREFIX}/share/doc/glimmer
.endfor
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/glimmer
${INSTALL_SCRIPT} ${WRKSRC}/run-glimmer2 ${DESTDIR}${PREFIX}/share/glimmer
Expand Down
6 changes: 3 additions & 3 deletions biology/xylem/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2012/09/11 20:32:14 asau Exp $
# $NetBSD: Makefile,v 1.11 2013/04/06 13:24:18 rodent Exp $
#

DISTNAME= xylem.1.8.7
Expand Down Expand Up @@ -27,9 +27,9 @@ post-build:
${MV} ${WRKSRC}/src.c/shuffle ${WRKSRC}/src.c/xyl-shuffle

do-install:
.for PROGRAM in dbstat getloc getob xyl-identify prot2nuc reform ribosome \
.for program in dbstat getloc getob xyl-identify prot2nuc reform ribosome \
splitdb xyl-shuffle flat2phyl phyl2flat
${INSTALL_PROGRAM} ${WRKSRC}/src.c/${PROGRAM} ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src.c/${program} ${DESTDIR}${PREFIX}/bin
.endfor
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/xylem
${INSTALL_DATA} ${WRKSRC}/doc/* ${DESTDIR}${PREFIX}/share/doc/xylem/
Expand Down
8 changes: 4 additions & 4 deletions converters/doc2html/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.20 2012/10/03 21:54:07 wiz Exp $
# $NetBSD: Makefile,v 1.21 2013/04/06 13:24:18 rodent Exp $
#

DISTNAME= doc2html
Expand All @@ -21,12 +21,12 @@ USE_TOOLS+= gs:run perl:run
INSTALLATION_DIRS= bin

do-build:
.for CVTR in doc2html pdf2html
.for cvtr in doc2html pdf2html
${SED} -e "s%@@LOCALBASE@@%${LOCALBASE}%g" \
-e "s%/usr/bin/perl%${PERL5}%g" \
-e "s%/bin/sed%${SED}%g" \
-e "s%@@X11BASE@@%${X11BASE}%g" < ${WRKSRC}/${CVTR}.pl \
> ${WRKSRC}/${CVTR}
-e "s%@@X11BASE@@%${X11BASE}%g" < ${WRKSRC}/${cvtr}.pl \
> ${WRKSRC}/${cvtr}
.endfor

do-install:
Expand Down
6 changes: 3 additions & 3 deletions editors/xcoral/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.18 2012/10/03 11:43:47 asau Exp $
# $NetBSD: Makefile,v 1.19 2013/04/06 13:24:18 rodent Exp $

DISTNAME= xcoral-3.2
PKGREVISION= 1
Expand All @@ -25,8 +25,8 @@ INSTALLATION_DIRS= bin lib/xcoral share/doc/xcoral/HTML/icons

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xcoral ${DESTDIR}${PREFIX}/bin
.for FILE in ${LIBFILES}
${INSTALL_DATA} ${WRKSRC}/SmacLib/${FILE} ${DESTDIR}${PREFIX}/lib/xcoral
.for file in ${LIBFILES}
${INSTALL_DATA} ${WRKSRC}/SmacLib/${file} ${DESTDIR}${PREFIX}/lib/xcoral
.endfor
${CP} -r ${WRKSRC}/Doc/* ${DESTDIR}${PREFIX}/share/doc/xcoral

Expand Down
16 changes: 8 additions & 8 deletions editors/xemacs-packages/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.58 2012/10/03 21:56:00 wiz Exp $
# $NetBSD: Makefile,v 1.59 2013/04/06 13:24:19 rodent Exp $

DISTNAME= xemacs-packages
PKGNAME= xemacs-packages-1.16
Expand Down Expand Up @@ -212,10 +212,10 @@ xemacs-update-package: xemacs-fetch-package-list xemacs-merge-package-list

do-install:
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/lib/xemacs/xemacs-packages
.for DISTFILE in ${DISTFILES}
@${ECHO_MSG} -n "Extracting ${DISTFILE} ... "
.for distfile in ${DISTFILES}
@${ECHO_MSG} -n "Extracting ${distfile} ... "
${GTAR} xCzf ${DESTDIR}${PREFIX}/lib/xemacs/xemacs-packages \
${DISTDIR}/${DIST_SUBDIR}/${DISTFILE}
${DISTDIR}/${DIST_SUBDIR}/${distfile}
@${ECHO_MSG} "done"
.endfor
@${ECHO_MSG} -n "Fixing file ownerships ... "
Expand All @@ -225,11 +225,11 @@ do-install:
@${ECHO_MSG} -n "Fixing file permissions ... "
${CHMOD} -R g-w,o-w ${DESTDIR}${PREFIX}/lib/xemacs/xemacs-packages
@${ECHO_MSG} "done"
.for PROG in ${REPLACEMENT_PROGS}
@${ECHO_MSG} "Fixing ${PROG} paths"
for f in ${REPLACEMENTS.${PROG}}; do \
.for prog in ${REPLACEMENT_PROGS}
@${ECHO_MSG} "Fixing ${prog} paths"
for f in ${REPLACEMENTS.${prog}}; do \
cp ${DESTDIR}$$f ${DESTDIR}$$f.pre; \
${SED} -e 's|#!.*${PROG}|${PREFIX}/bin/${PROG}|' \
${SED} -e 's|#!.*${prog}|${PREFIX}/bin/${prog}|' \
${DESTDIR}$$f.pre > ${DESTDIR}$$f; \
rm ${DESTDIR}$$f.pre; \
done
Expand Down
6 changes: 3 additions & 3 deletions fonts/intlfonts/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.31 2013/04/06 13:01:26 rodent Exp $
# $NetBSD: Makefile,v 1.32 2013/04/06 13:24:19 rodent Exp $

DISTNAME= intlfonts-1.2.1
PKGREVISION= 5
Expand Down Expand Up @@ -65,8 +65,8 @@ PLIST_SRC= PLIST PLIST.extrafonts
.endif

post-extract:
.for FILE in ${MISC_FILES}
${CP} ${_DISTDIR}/${FILE} ${WRKSRC}
.for file in ${MISC_FILES}
${CP} ${_DISTDIR}/${file} ${WRKSRC}
.endfor

.include "../../mk/bsd.pkg.mk"
12 changes: 6 additions & 6 deletions lang/openjdk7/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.44 2013/04/06 11:39:26 rodent Exp $
# $NetBSD: Makefile,v 1.45 2013/04/06 13:24:19 rodent Exp $

DISTNAME= openjdk-7-fcs-src-b147-27_jun_2011
PKGNAME= openjdk7-1.7.0.147.20110811
Expand Down Expand Up @@ -128,11 +128,11 @@ post-extract:
printf '#!/bin/sh\nexec %s/bootstrap/bin/java-real -mx256m "$$@"\n' \
${WRKDIR} > ${WRKDIR}/bootstrap/bin/java
chmod a+x ${WRKDIR}/bootstrap/bin/java
.for T in idlj jar javac javah javap native2ascii rmic
mv ${WRKDIR}/bootstrap/bin/${T} ${WRKDIR}/bootstrap/bin/${T}-real
printf '#!/bin/sh\n\nexec %s/bootstrap/bin/${T}-real -J-mx256m "$$@"\n' \
${WRKDIR} > ${WRKDIR}/bootstrap/bin/${T}
chmod a+x ${WRKDIR}/bootstrap/bin/${T}
.for t in idlj jar javac javah javap native2ascii rmic
mv ${WRKDIR}/bootstrap/bin/${t} ${WRKDIR}/bootstrap/bin/${t}-real
printf '#!/bin/sh\n\nexec %s/bootstrap/bin/${t}-real -J-mx256m "$$@"\n' \
${WRKDIR} > ${WRKDIR}/bootstrap/bin/${t}
chmod a+x ${WRKDIR}/bootstrap/bin/${t}
.endfor

do-build: ${WRKDIR}/stage3-done
Expand Down
6 changes: 3 additions & 3 deletions net/gofish/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.14 2012/10/23 17:18:24 asau Exp $
# $NetBSD: Makefile,v 1.15 2013/04/06 13:24:19 rodent Exp $

DISTNAME= gofish-1.2
CATEGORIES= net
Expand Down Expand Up @@ -31,8 +31,8 @@ RCD_SCRIPTS= gopherd

OWN_DIRS_PERMS= ${RUNTIMEDIR} ${GOPHER_USER} ${GOPHER_GROUP} 0750

.for FILE in gofish.conf gofish-www.conf
CONF_FILES+= ${EGDIR}/${FILE} ${PKG_SYSCONFDIR}/${FILE}
.for file in gofish.conf gofish-www.conf
CONF_FILES+= ${EGDIR}/${file} ${PKG_SYSCONFDIR}/${file}
.endfor

FILES_SUBST+= RUNTIMEDIR=${RUNTIMEDIR:Q}
Expand Down
6 changes: 3 additions & 3 deletions net/openslp/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.41 2013/02/14 16:51:32 drochner Exp $
# $NetBSD: Makefile,v 1.42 2013/04/06 13:24:19 rodent Exp $

DISTNAME= openslp-1.2.1
PKGREVISION= 6
Expand All @@ -25,8 +25,8 @@ EGDIR= ${PREFIX}/share/examples/${PKGBASE}

CONFS= slp.conf slp.reg slp.spi
CONF_FILES= # empty
.for FILE in ${CONFS}
CONF_FILES+= ${EGDIR}/${FILE} ${PKG_SYSCONFDIR}/${FILE}
.for file in ${CONFS}
CONF_FILES+= ${EGDIR}/${file} ${PKG_SYSCONFDIR}/${file}
.endfor
RCD_SCRIPTS= slpd

Expand Down
14 changes: 7 additions & 7 deletions pkgtools/pkgdepgraph/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.29 2012/10/03 21:57:15 wiz Exp $
# $NetBSD: Makefile,v 1.30 2013/04/06 13:24:19 rodent Exp $
#

DISTNAME= pkgdepgraph-2.8
Expand Down Expand Up @@ -31,19 +31,19 @@ do-extract:
${CP} ${FILESDIR}/pkgdepgraph.0 ${WRKSRC}/pkgdepgraph.0.in

do-build:
.for FILE in pkgdepgraph
.for file in pkgdepgraph
${SED} -e 's|@PREFIX@|${PREFIX}|g' \
-e 's|@PKG_DBDIR@|${PKG_DBDIR}|g' \
-e 's|@PKGSRCDIR@|${PKGSRCDIR}|g' \
-e 's|@DISTVER@|${DISTVER}|g' \
< ${WRKSRC}/${FILE}.pl \
> ${WRKSRC}/${FILE}
< ${WRKSRC}/${file}.pl \
> ${WRKSRC}/${file}
.endfor
.for FILE in pkgdepgraph.1 pkgdepgraph.0
.for file in pkgdepgraph.1 pkgdepgraph.0
${SED} -e 's|@PKG_DBDIR@|${PKG_DBDIR}|g' \
-e 's|@PKGSRCDIR@|${PKGSRCDIR}|g' \
< ${WRKSRC}/${FILE}.in \
> ${WRKSRC}/${FILE}
< ${WRKSRC}/${file}.in \
> ${WRKSRC}/${file}
.endfor
.if ${OPSYS} == "SunOS" || ${OPSYS} == "AIX"
# the pre-generated man-pages are 'mandoc'; these OS need 'man'
Expand Down
10 changes: 5 additions & 5 deletions print/ja-vflib-lib/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2011/05/28 09:07:38 obache Exp $
# $NetBSD: Makefile,v 1.12 2013/04/06 13:24:19 rodent Exp $

.include "Makefile.common"

Expand All @@ -13,12 +13,12 @@ INSTALL_TARGET= install-src
USE_TOOLS+= pax

post-build:
.for FILE in vfontcap vfontcap.bdf
.for file in vfontcap vfontcap.bdf
cd ${WRKSRC}; \
${MV} ${FILE} ${FILE}.orig; \
${MV} ${file} ${file}.orig; \
${SED} -e "s|/usr/local/share/fonts|${PREFIX}/share/fonts|g" \
${FILE}.orig > ${FILE}; \
${RM} ${FILE}.orig
${file}.orig > ${file}; \
${RM} ${file}.orig
.endfor

post-install:
Expand Down
6 changes: 3 additions & 3 deletions security/PAM/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.48 2012/10/23 18:16:20 asau Exp $
# $NetBSD: Makefile,v 1.49 2013/04/06 13:24:19 rodent Exp $

DISTNAME= Linux-PAM-0.77
PKGNAME= ${DISTNAME:S/Linux-//}
Expand Down Expand Up @@ -80,8 +80,8 @@ PLIST.limits= yes
.endif

CONF_FILES= ${EGDIR}/pam.conf ${PKG_SYSCONFBASEDIR}/pam.conf
.for FILE in ${CFILES}
CONF_FILES+= ${EGDIR}/${FILE} ${PKG_SYSCONFDIR}/${FILE}
.for file in ${CFILES}
CONF_FILES+= ${EGDIR}/${file} ${PKG_SYSCONFDIR}/${file}
.endfor
SPECIAL_PERMS= ${PREFIX}/sbin/unix_chkpwd ${SETUID_ROOT_PERMS}

Expand Down
6 changes: 3 additions & 3 deletions security/fragroute/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2013/02/06 23:23:36 jperkin Exp $
# $NetBSD: Makefile,v 1.24 2013/04/06 13:24:20 rodent Exp $

DISTNAME= fragroute-1.2
PKGREVISION= 14
Expand All @@ -21,8 +21,8 @@ SCRIPTS= README.snort base-1 frag-1 frag-2 frag-3 frag-4 frag-5 \
INSTALLATION_DIRS+= share/fragroute

pre-install:
.for FILE in ${SCRIPTS}
${INSTALL_DATA} ${WRKSRC}/scripts/${FILE} ${DESTDIR}${PREFIX}/share/fragroute
.for file in ${SCRIPTS}
${INSTALL_DATA} ${WRKSRC}/scripts/${file} ${DESTDIR}${PREFIX}/share/fragroute
.endfor

.include "../../net/libpcap/buildlink3.mk"
Expand Down
14 changes: 7 additions & 7 deletions security/gpg2dot/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.15 2012/10/23 18:16:29 asau Exp $
# $NetBSD: Makefile,v 1.16 2013/04/06 13:24:20 rodent Exp $
#

DISTNAME= gpg2dot-1.5
Expand Down Expand Up @@ -26,16 +26,16 @@ do-extract:
# ${CP} ${FILESDIR}/gpg2dot.1 ${WRKSRC}/gpg2dot.1.in

do-build:
.for FILE in gpg2dot
.for file in gpg2dot
${SED} -e 's|@PREFIX@|${PREFIX}|g' \
-e 's|@DISTVER@|${DISTVER}|g' \
< ${WRKSRC}/${FILE}.pl \
> ${WRKSRC}/${FILE}
< ${WRKSRC}/${file}.pl \
> ${WRKSRC}/${file}
.endfor
#.for FILE in gpg2dot
#.for file in gpg2dot
# ${SED} -e '' \
# < ${WRKSRC}/${FILE}.1.in \
# > ${WRKSRC}/${FILE}.1
# < ${WRKSRC}/${file}.1.in \
# > ${WRKSRC}/${file}.1
#.endfor

do-install:
Expand Down
14 changes: 7 additions & 7 deletions time/asclock/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.32 2012/10/23 10:24:11 wiz Exp $
# $NetBSD: Makefile,v 1.33 2013/04/06 13:24:20 rodent Exp $

DISTNAME= asclock-classic-1.0
PKGNAME= asclock-1.0
Expand Down Expand Up @@ -57,12 +57,12 @@ do-install:
${CAT} ${PKGDIR}/PLIST > ${PLIST_SRC}
${INSTALL_MAN_DIR} ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
${INSTALL_MAN} ${WRKSRC}/asclock.man ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/asclock.1
.for LANGUAGE in ${LANGUAGES}
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/asclock-classic/${LANGUAGE}
cd ${WRKSRC}/${LANGUAGE}; ${INSTALL_DATA} month.xpm weekday.xpm \
${DESTDIR}${PREFIX}/share/asclock-classic/${LANGUAGE}
@${ECHO} share/asclock-classic/${LANGUAGE}/month.xpm >> ${PLIST_SRC}
@${ECHO} share/asclock-classic/${LANGUAGE}/weekday.xpm >> ${PLIST_SRC}
.for language in ${LANGUAGES}
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/asclock-classic/${language}
cd ${WRKSRC}/${language}; ${INSTALL_DATA} month.xpm weekday.xpm \
${DESTDIR}${PREFIX}/share/asclock-classic/${language}
@${ECHO} share/asclock-classic/${language}/month.xpm >> ${PLIST_SRC}
@${ECHO} share/asclock-classic/${language}/weekday.xpm >> ${PLIST_SRC}
.endfor

.include "../../x11/libXext/buildlink3.mk"
Expand Down
6 changes: 3 additions & 3 deletions time/devtodo/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.30 2012/10/08 13:04:17 asau Exp $
# $NetBSD: Makefile,v 1.31 2013/04/06 13:24:20 rodent Exp $

DISTNAME= devtodo-0.1.20
PKGREVISION= 3
Expand All @@ -18,7 +18,7 @@ EGDIR= ${PREFIX}/share/examples/devtodo
INSTALL_MAKE_FLAGS+= sysconfdir=${EGDIR}

post-install:
.for CFILE in changelog2html \
.for cfile in changelog2html \
changelog2todo \
tdrec \
todo-nodone-html.xslt \
Expand All @@ -27,7 +27,7 @@ post-install:
todo2pdf.README \
todo2pdf.sh \
todo2pdf.xslt
${INSTALL_DATA} ${WRKSRC}/contrib/${CFILE} ${DESTDIR}${EGDIR}
${INSTALL_DATA} ${WRKSRC}/contrib/${cfile} ${DESTDIR}${EGDIR}
.endfor

.include "../../devel/readline/buildlink3.mk"
Expand Down
Loading

0 comments on commit f5f81cb

Please sign in to comment.