Skip to content

Commit

Permalink
Update libFoundation to 1.1.7.168. This makes libFoundation play nice…
Browse files Browse the repository at this point in the history
… with

the new gnustep-make directory structure.  Other notable changes include:
 * bugfixes and stability improvements
 * Support for some new Cocoa classes, like NSURL
 * Improved compatibility with gstep-base
 * more and fixed timezone files
 * support for read-only strings in UTF-8 and UTF-16
 * some fixes for warnings thrown in new gcc (gcc3+) compilers
  • Loading branch information
rh committed Apr 18, 2009
1 parent f6b4f42 commit f6c1471
Show file tree
Hide file tree
Showing 8 changed files with 429 additions and 351 deletions.
38 changes: 16 additions & 22 deletions devel/libFoundation/Makefile
Original file line number Diff line number Diff line change
@@ -1,47 +1,41 @@
# $NetBSD: Makefile,v 1.12 2008/08/23 07:47:00 obache Exp $
# $NetBSD: Makefile,v 1.13 2009/04/18 02:19:23 rh Exp $
#

DISTNAME= libFoundation-1.0.72-r107
DISTNAME= libFoundation-1.1.7-r168
PKGNAME= ${DISTNAME:S/-r/./}
PKGREVISION= 2
CATEGORIES= devel gnustep
MASTER_SITES= http://download.opengroupware.org/nightly/sources/releases/

MAINTAINER= [email protected]
HOMEPAGE= http://www.opengroupware.org/en/devs/thirdparty/libFoundation/
COMMENT= Library implementing the OpenStep Foundation API

USE_LANGUAGES= objc
LICENSE= libFoundation-license

WRKSRC= ${WRKDIR}/libfoundation
.include "common.mk"

GNU_CONFIGURE= yes
MAKE_ENV+= ADDITIONAL_OBJCFLAGS="-I${WRKSRC} -I."
MAKE_ENV+= FOUNDATION_LIB="fd"
MAKE_ENV+= INSTALL_DATA=${INSTALL_DATA:Q}
MAKE_FLAGS= GNUSTEP_TARGET_DIR="${WRKSRC}/Foundation"

PLIST_SUBST+= GNUSTEP_HOST_CPU=${GNUSTEP_HOST_CPU:Q}
PLIST_SUBST+= LIBF_HOST_OS=${LIBF_HOST_OS}
SUBST_FILES.gnustep_installation_dir+= Foundation/GNUmakefile.postamble
SUBST_FILES.gnustep_installation_dir+= Foundation/GNUmakefile
SUBST_FILES.gnustep_installation_dir+= Resources/GNUmakefile

LIBF_HOST_OS= ${GNUSTEP_HOST:C/.*-//}

PLIST_SUBST+= GNUSTEP_HOST_CPU=${GNUSTEP_HOST_CPU:Q}
PLIST_SUBST+= LIBF_HOST_OS=${LIBF_HOST_OS}

.include "../../devel/gnustep-make/buildlink3.mk"
.include "../../devel/gnustep-objc-lf2/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

pre-configure:
${MKDIR} ${WRKSRC}/config/${MACHINE_GNU_ARCH}
[ -e ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${GNUSTEP_HOST_OS}.h ] || \
${LN} -s linux.h ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${GNUSTEP_HOST_OS}.h
.if ${GNUSTEP_HOST_OS} != ${LIBF_HOST_OS}
[ -e ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${LIBF_HOST_OS}.h ] || \
${LN} -s linux.h ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${LIBF_HOST_OS}.h
.endif

post-configure:
-${MKDIR} ${WRKSRC}/Foundation/${GNUSTEP_HOST_CPU}
${MKDIR} ${WRKSRC}/Foundation/${GNUSTEP_HOST_CPU}
[ -e ${WRKSRC}/Foundation/${GNUSTEP_HOST_CPU}/${LIBF_HOST_OS} ] || \
${LN} -s \
${WRKSRC}/Foundation/${LIBF_HOST_OS} \
${WRKSRC}/Foundation/${GNUSTEP_HOST_CPU}/${LIBF_HOST_OS}

pre-install:
${MKDIR} ${DESTDIR}${GNUSTEP_MAKEFILES}/Additional

.include "../../mk/bsd.pkg.mk"
561 changes: 282 additions & 279 deletions devel/libFoundation/PLIST

Large diffs are not rendered by default.

92 changes: 46 additions & 46 deletions devel/libFoundation/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,56 +1,55 @@
# $NetBSD: buildlink3.mk,v 1.9 2009/03/20 19:24:16 joerg Exp $
# $NetBSD: buildlink3.mk,v 1.10 2009/04/18 02:19:23 rh Exp $

BUILDLINK_TREE+= libFoundation

.if !defined(LIBFOUNDATION_BUILDLINK3_MK)
LIBFOUNDATION_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.libFoundation+= libFoundation>=1.0.72.107nb1
BUILDLINK_ABI_DEPENDS.libFoundation?= libFoundation>=1.0.72.107nb2
BUILDLINK_API_DEPENDS.libFoundation+= libFoundation>=1.1.7.168
BUILDLINK_PKGSRCDIR.libFoundation?= ../../devel/libFoundation

PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/CharacterSets$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/Defaults$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Africa$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Asia$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Australia$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Canada$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Europe$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/SystemV$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/US$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}\/${LOWER_OPSYS}$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}\/${LOWER_OPSYS}\/GNU$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/Foundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/Foundation\/exceptions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/extensions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm share\/GNUstep\/System\/Library\/Headers\/libFoundation\/extensions\/exceptions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/CharacterSets$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/Defaults$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Africa$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Asia$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Australia$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Canada$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/Europe$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/SystemV$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Libraries\/Resources\/libFoundation\/TimeZoneInfo\/US$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}\/${LOWER_OPSYS}$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/${GNUSTEP_HOST_CPU}\/${LOWER_OPSYS}\/GNU$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/Foundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/Foundation\/exceptions$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/extensions$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/share\/GNUstep\/System\/Library\/Headers\/libFoundation\/extensions\/exceptions$$/ { next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/${MACHINE_ARCH}$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/${MACHINE_ARCH}\/${LOWER_OPSYS}$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/${MACHINE_ARCH}\/${LOWER_OPSYS}\/GNU$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/Foundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/Foundation\/exceptions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/extensions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm include\/libFoundation\/extensions\/exceptions$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/CharacterSets$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/Defaults$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Africa$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Asia$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Australia$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Canada$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Europe$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/SystemV$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@dirrm lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/US$$/ { print "@comment in devel/libFoundation: " $$0; next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/${MACHINE_ARCH}$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/${MACHINE_ARCH}\/${LOWER_OPSYS}$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/${MACHINE_ARCH}\/${LOWER_OPSYS}\/GNU$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/Foundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/Foundation\/exceptions$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/extensions$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/include\/libFoundation\/extensions\/exceptions$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/CharacterSets$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/Defaults$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Africa$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Asia$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Australia$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Canada$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/Europe$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/SystemV$$/ { next; }
PRINT_PLIST_AWK+= /^@exec \$${MKDIR} %D\/lib\/GNUstep\/Libraries\/${PKGNAME}\/Resources\/libFoundation\/TimeZoneInfo\/US$$/ { next; }

FOUNDATION_LIB?= fd
ADDITIONAL_INCLUDE_DIRS+=-I${GNUSTEP_SYSTEM_ROOT}/Library/Headers/libFoundation/${GNUSTEP_HOST_CPU}/${LOWER_OPSYS}/GNU
Expand All @@ -61,7 +60,8 @@ MAKE_ENV+= FOUNDATION_LIB=${FOUNDATION_LIB:Q}
MAKE_ENV+= ADDITIONAL_INCLUDE_DIRS=${ADDITIONAL_INCLUDE_DIRS:Q}
.endif

.include "../../devel/gnustep-make/buildlink3.mk"
.include "../../devel/gnustep-objc-lf2/buildlink3.mk"
.endif # LIBFOUNDATION_BUILDLINK3_MK
.endif # LIBFOUNDATION_BUILDLINK3_MK

BUILDLINK_TREE+= -libFoundation
31 changes: 31 additions & 0 deletions devel/libFoundation/common.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# $NetBSD: common.mk,v 1.1 2009/04/18 02:19:23 rh Exp $
#
PKG_DESTDIR_SUPPORT= destdir

USE_LANGUAGES= objc

WRKSRC= ${WRKDIR}/libfoundation

GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= no
MAKE_ENV+= ADDITIONAL_OBJCFLAGS="-I${WRKSRC} -I."
MAKE_ENV+= FOUNDATION_LIB="fd"
MAKE_ENV+= INSTALL_DATA=${INSTALL_DATA:Q}

LIBF_HOST_OS= ${GNUSTEP_HOST:C/.*-//}

FIX_GNUSTEP_INSTALLATION_DIR= yes

.include "../../devel/gnustep-make/gnustep.mk"

PLIST_SUBST+= GNUSTEP_HOST_CPU=${GNUSTEP_HOST_CPU:Q}
PLIST_SUBST+= LIBF_HOST_OS=${LIBF_HOST_OS}

pre-configure:
${MKDIR} ${WRKSRC}/config/${MACHINE_GNU_ARCH}
[ -e ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${GNUSTEP_HOST_OS}.h ] || \
${LN} -s linux.h ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${GNUSTEP_HOST_OS}.h
.if ${GNUSTEP_HOST_OS} != ${LIBF_HOST_OS}
[ -e ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${LIBF_HOST_OS}.h ] || \
${LN} -s linux.h ${WRKSRC}/config/${MACHINE_GNU_ARCH}/${LIBF_HOST_OS}.h
.endif
10 changes: 6 additions & 4 deletions devel/libFoundation/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2005/04/24 02:48:06 rh Exp $
$NetBSD: distinfo,v 1.2 2009/04/18 02:19:23 rh Exp $

SHA1 (libFoundation-1.0.72-r107.tar.gz) = e6934e03d749a7a47d6e1ba5ab006d48458fd685
RMD160 (libFoundation-1.0.72-r107.tar.gz) = 8de369d04b80d91bc939dbe0dcf9c93e44f60ee4
Size (libFoundation-1.0.72-r107.tar.gz) = 534583 bytes
SHA1 (libFoundation-1.1.7-r168.tar.gz) = ddd1a732b19fb802e4b7cfac3e1248b26c1c1576
RMD160 (libFoundation-1.1.7-r168.tar.gz) = 73beb75f1bdc983ce9b17348cc7437800b442070
Size (libFoundation-1.1.7-r168.tar.gz) = 563456 bytes
SHA1 (patch-aa) = d65aaa11cd6c0d37d84a4d409e662099f931c857
SHA1 (patch-ab) = b4f1ff791052403ac3c3a9b005dd3d67d3dc9aea
13 changes: 13 additions & 0 deletions devel/libFoundation/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2009/04/18 02:19:23 rh Exp $

--- GNUmakefile.orig 2009-04-18 10:49:03.000000000 +1000
+++ GNUmakefile
@@ -38,7 +38,7 @@ GNUSTEP_INSTALLATION_DOMAIN = SYSTEM
include $(GNUSTEP_MAKEFILES)/common.make
include ./Version

-SUBPROJECTS = Foundation Resources examples
+SUBPROJECTS = Foundation Resources

include $(GNUSTEP_MAKEFILES)/aggregate.make

17 changes: 17 additions & 0 deletions devel/libFoundation/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.1 2009/04/18 02:19:23 rh Exp $

--- Foundation/NSDecimalNumber.m.orig 2008-11-03 02:00:07.000000000 +1000
+++ Foundation/NSDecimalNumber.m
@@ -22,10 +22,12 @@
or in connection with the use or performance of this software.
*/

+#define nan system_nan
#include <Foundation/NSDecimalNumber.h>
#include <Foundation/NSUtilities.h>
#include <common.h>
#include <math.h>
+#undef nan

@interface NSDecimalZeroNumber : NSDecimalNumber
@end
18 changes: 18 additions & 0 deletions licenses/libFoundation-license
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@

Copyright (C) 1995, 1996, 1997, 1998 Ovidiu Predescu and Mircea Oancea.
All rights reserved.

Permission to use, copy, modify, and distribute this software and its
documentation for ANY purpose and without fee is hereby granted, provided
that the above copyright notice appear in all copies and that both that
copyright notice and this permission notice appear in supporting
documentation. This software may be included in any commercial product
provided that its distribution contain the libFoundation copyright notice
and this permission notice.

We disclaim all warranties with regard to this software, including all
implied warranties of merchantability and fitness, in no event shall
we be liable for any special, indirect or consequential damages or any
damages whatsoever resulting from loss of use, data or profits, whether in
an action of contract, negligence or other tortious action, arising out of
or in connection with the use or performance of this software.

0 comments on commit f6c1471

Please sign in to comment.