Skip to content

Commit

Permalink
uhd: updated to 4.1.0.5
Browse files Browse the repository at this point in the history
4.1.0.5

* ad9361
  -  Add comment re overclocking
  -  Modify set-tx-gain procedure to update gain in one go
* b200
  -  Re-sync times
  -  Move the B200 radio control core into usrp/b200/
* cal
  -  Use safe version of set_thread_priority()
* ci
  -  Device wait to redlock scope for Vivado close
  -  Add Fedora 34 and remove Fedora 32
  -  Refactor installers and add Windows support
  -  Add custom boost version support
  -  Remove documentation-only changes from pipeline runs
  -  enable batch CI
  -  Split CI and PR pipelines for mono pipeline
  -  Enable custom CXX flags, enable -Werror
  -  Let make keep building upon failure
  -  Add clang as a compiler to all Fedora and Ubuntu containers
* cmake
  -  use LooseVersion to ensure correct version comparisons
  -  Fix rfnoc-example (CMake paths)
  -  Fix issues with static builds and CMRC
  -  Replace CMAKE_{SOURCE,BINARY}_DIR with UHD_*_DIR
  -  tests: Add build-python path to PYTHONPATH
  -  Add check for libatomic linking requirement
  -  remove duplicate entry in LIBUHD_PYTHON_GEN_SOURCE
  -  Fix VS names and use relative for images
* dbsrx
  -  Fix issue with loop variable
* debs
  -  Update upload_debs script
* devtest
  -  Clarify data type in multi_usrp_test::send_waveform()
  -  Add receive stability test to B2xx devtest
  -  Add receive stability test
* dissectors
  -  Fix whitespace formatting in CMake files
  -  Fix inclusion of glib.h and Python version
* docs
  -  Several minor manual improvements
  -  Collect all RFNoC block controllers in a module in the manual
  -  Align dependencies and bump deb package versions
  -  Clarify set/get_gpio_attr() and GPIO banks
  -  Fix GPIO documentation example
  -  x410: Fix info on loading SD card images with bmaptool
  -  Improve docs for rx_streamer::recv() on overruns
  -  sync: Update page on synchronization
  -  Fix typo in ZBX Block Diagram
  -  x4xx: Document configuring eth0 static IP
  -  Remove bmaptool instructions for writing filesystems
* examples
  -  Use cmul for gain block in-tree IP example
  -  Test all variants in gain testbench
  -  Make IQ order clear in gain RFNoC block
  -  Improve txrx_loopback_to_file (late recv, Boost, timing)
  -  Show how to use in-tree Verilog header
  -  Add x400/x410 target to RFNoC example
  -  gpio: Separate bank and port arguments
  -  usrp_power_meter: fix channel indexing when reading USRP power
* fpga
  -  Revert "Add ability to get time from Radio block"
  -  Add ability to get time from Radio block
  -  rfnoc: Add RFNoC CHDR resize module
  -  rfnoc: Add CHDR management util functions
  -  lib: Clean up axi_mux
  -  rfnoc: Add labels to axi_switch generate blocks
  -  rfnoc: Add labels to chdr_mgmt_pkt_handler
  -  rfnoc: Add documentation to chdr_xb_routing_table
  -  Shorten line length for Launchpad linter
  -  x300: Update synchronizer constraint
  -  n3xx: Update synchronizer constraint
  -  lib: Update example constraint in synchronizer
  -  Update help message for setupenv.sh
  -  Remove stale references to UHD_FPGA_DIR
  -  tools: Add UHD_FPGA_DIR definition to synthesis
  -  Set default part for sim in setupenv.sh
  -  Fix Xilinx bitfile parser for Python 3
  -  rfnoc: Fix EOB loss in DUC
  -  sim: Add PkgComplex, PkgMath, and PkgRandom
  -  lib: Clean up and document lib files
  -  x400: Remove stale information in register map
  -  ci: Add testbench pipeline
* host
  -  Revert "Add ability to get time from Radio block"
  -  Add ability to get time from Radio block
  -  python: Return mb_controller with reference_internal
  -  x4xx: Implement GPIO API
  -  Add GPIO functions to MPM RPC shim
  -  gpio: Create gpio_atr_offsets to store GPIO registers
* images
  -  Update image packager script for Python 3
* lib
  -  Remove all remaining usage of boost::numeric::bounds<>
  -  transport: Mark typecast as intended
  -  transport: Initialize _hshake_args_server
  -  rfnoc: Make implicit typecasts explicit
  -  rfnoc: Change enum node_type to enum class
  -  Add various missing includes
* libusb
  -  Remove unused context variable
* mpm
  -  x4xx: update mboard_max_rev
  -  x4xx: Allow GPIO0 and GPIO1 as port names
  -  x4xx: add DIO GPIO API configuration methods
  -  mpm: x4xx: Add checks before accessing self.dio_control
  -  Fix handling of rfic_digital_loopback argument
  -  rfdc: Tear down RFDC on teardown
  -  add X410 support for 250e6 master clock rate
  -  Expose motherboard regs for debugging
* mpmd
  -  Increase UHD-side MTU cap for 10 GbE and 1 GbE
* multi_usrp_rfnoc
  -  Revert "Reduce latency of get_time_now()"
  -  Reduce latency of get_time_now()
* n320
  -  Reduce PLL lock time
* n3x0/e3x0
  -  Remove reference to "master FP-GPIO radio"
* n3xx
  -  Add support for rev 10
  -  Fix White Rabbit
* python
  -  multi_usrp: Add set_rx_spp()
  -  multi_usrp: Fix issues in send_waveform()
  -  multi_usrp: Fix issues with recv_num_samps()
  -  Fix dropped-sample calculation in benchmark_rate.py
  -  multi_usrp: Fix overloaded function definition
  -  Add new method bindings to noc_block_base
  -  rfnoc: Change reference type for noc_block_base export
* responder
  -  Fix printw function arguments
* rfnoc
  -  radio: Fix async message handling channel checks
  -  mgmt_portal: Fix order of validity checks
  -  blocks: Minor cleanup (whitespace, typos)
  -  mgmt_portal: Remove two unused variables
  -  Add vivado-path to rfnoc_image_builder
  -  ddc: Improve unit tests and documentation
  -  duc: Fix frequency range for DUC block
  -  duc: Remove stale references to CORDIC
  -  siggen: Fix direction of rotation
* rh
  -  Fix auto DC-offset correction and auto-IQ balance APIs
* tests
  -  Remove skip_dram from streaming performance test script
  -  Fix rfnoc_graph mock nodes stop-stream command
  -  Use reference type to prevent copy
  -  Fix check in link_test
  -  Fix potential resource leak
* tools
  -  Fix rfnoc dissector build
* uhd
  -  add support for max10 variants
  -  update manifest for x410 cpld
  -  Update manifest
  -  update num_recv_frames calculation for ctrl links
  -  Remove spurious template from property dtor
  -  Fix spelling errors
  -  mpm: Expose filesystem version information on MPM tree
  -  Remove Boost version checks for Boost 1.61
  -  Fix usage of std::abs with template parameters
* utils
  -  Get signal above noise floor when finding optimal gain
* x300
  -  Fix error message for wrong reference frequency
  -  Remove unused variables in x300_eth_mgr.cpp
  -  Fix MAX_RATE_1GIGE value
  -  Fix sfpp_io_core tuser width
  -  Initialize struct variable before using it
* x410
  -  correct 100GbE link speed
  • Loading branch information
adam committed Jan 4, 2022
1 parent d3d358b commit f83cc5e
Show file tree
Hide file tree
Showing 5 changed files with 38 additions and 14 deletions.
7 changes: 4 additions & 3 deletions ham/uhd/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.63 2021/12/11 17:39:56 tnn Exp $
# $NetBSD: Makefile,v 1.64 2022/01/04 17:29:06 adam Exp $

DISTNAME= uhd-4.1.0.4
DISTNAME= uhd-4.1.0.5
CATEGORIES= ham
MASTER_SITES= ${MASTER_SITE_GITHUB:=EttusResearch/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down Expand Up @@ -55,7 +55,9 @@ REPLACE_PYTHON+= utils/usrp2_recovery.py
REPLACE_PYTHON+= tests/devtest/benchmark_rate_test.py
REPLACE_PYTHON+= tests/devtest/multi_usrp_test.py
REPLACE_PYTHON+= tests/devtest/python_api_test.py
REPLACE_PYTHON+= tests/devtest/python_rx_stability_test.py
REPLACE_PYTHON+= tests/devtest/run_testsuite.py
REPLACE_PYTHON+= tests/devtest/recv_stability_test.py
REPLACE_PYTHON+= tests/devtest/rx_samples_to_file_test.py
REPLACE_PYTHON+= tests/devtest/test_messages_test.py
REPLACE_PYTHON+= tests/devtest/test_pps_test.py
Expand All @@ -69,7 +71,6 @@ REPLACE_PYTHON+= tests/streaming_performance/run_E3xx_max_rate_tests.py
REPLACE_PYTHON+= tests/streaming_performance/run_N3xx_max_rate_tests.py
REPLACE_PYTHON+= tests/streaming_performance/run_X3xx_max_rate_tests.py


INSTALLATION_DIRS+= share/uhd
INSTALLATION_DIRS+= share/uhd/firmware
INSTALLATION_DIRS+= share/uhd/fpga
Expand Down
10 changes: 6 additions & 4 deletions ham/uhd/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.20 2021/12/11 17:39:56 tnn Exp $
@comment $NetBSD: PLIST,v 1.21 2022/01/04 17:29:06 adam Exp $
bin/rfnoc_image_builder
bin/uhd_adc_self_cal
bin/uhd_cal_rx_iq_balance
Expand Down Expand Up @@ -238,6 +238,8 @@ lib/uhd/tests/devtest/gpio_test.py
lib/uhd/tests/devtest/list_sensors_test.py
lib/uhd/tests/devtest/multi_usrp_test.py
lib/uhd/tests/devtest/python_api_test.py
lib/uhd/tests/devtest/python_rx_stability_test.py
lib/uhd/tests/devtest/recv_stability_test.py
lib/uhd/tests/devtest/run_testsuite.py
lib/uhd/tests/devtest/rx_samples_to_file_test.py
lib/uhd/tests/devtest/test_messages_test.py
Expand Down Expand Up @@ -354,6 +356,9 @@ share/uhd/cal/cal_metadata.fbs
share/uhd/cal/dsa_cal.fbs
share/uhd/cal/iq_cal.fbs
share/uhd/cal/pwr_cal.fbs
@pkgdir share/uhd/firmware
@pkgdir share/uhd/fpga
@pkgdir share/uhd/images
share/uhd/rfnoc/blocks/addsub.yml
share/uhd/rfnoc/blocks/axi_ram_fifo.yml
share/uhd/rfnoc/blocks/axi_ram_fifo_2x64.yml
Expand Down Expand Up @@ -386,6 +391,3 @@ share/uhd/rfnoc/core/rfnoc_imagebuilder_args.json
share/uhd/rfnoc/core/x300_bsp.yml
share/uhd/rfnoc/core/x310_bsp.yml
share/uhd/rfnoc/core/x410_bsp.yml
@pkgdir share/uhd/images
@pkgdir share/uhd/fpga
@pkgdir share/uhd/firmware
23 changes: 22 additions & 1 deletion ham/uhd/PLIST.doxygen
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
@comment $NetBSD: PLIST.doxygen,v 1.16 2022/01/04 17:29:06 adam Exp $
share/doc/uhd/doxygen/html/Ettus_Logo.png
share/doc/uhd/doxygen/html/N2xx-JTAG.jpg
share/doc/uhd/doxygen/html/N310fp.png
Expand Down Expand Up @@ -806,6 +807,11 @@ share/doc/uhd/doxygen/html/graph__edge_8hpp_source.html
share/doc/uhd/doxygen/html/graph__utils_8hpp.html
share/doc/uhd/doxygen/html/graph__utils_8hpp.js
share/doc/uhd/doxygen/html/graph__utils_8hpp_source.html
share/doc/uhd/doxygen/html/group__defs_8dox.html
share/doc/uhd/doxygen/html/group__rfnoc.html
share/doc/uhd/doxygen/html/group__rfnoc.js
share/doc/uhd/doxygen/html/group__rfnoc__blocks.html
share/doc/uhd/doxygen/html/group__rfnoc__blocks.js
share/doc/uhd/doxygen/html/hierarchy.html
share/doc/uhd/doxygen/html/hierarchy.js
share/doc/uhd/doxygen/html/identification_8dox.html
Expand Down Expand Up @@ -884,6 +890,8 @@ share/doc/uhd/doxygen/html/metadata_8hpp_source.html
share/doc/uhd/doxygen/html/mock__block_8hpp.html
share/doc/uhd/doxygen/html/mock__block_8hpp.js
share/doc/uhd/doxygen/html/mock__block_8hpp_source.html
share/doc/uhd/doxygen/html/modules.html
share/doc/uhd/doxygen/html/modules.js
share/doc/uhd/doxygen/html/moving__average__block__control_8hpp.html
share/doc/uhd/doxygen/html/moving__average__block__control_8hpp_source.html
share/doc/uhd/doxygen/html/mpm_8dox.html
Expand Down Expand Up @@ -930,6 +938,8 @@ share/doc/uhd/doxygen/html/namespacepybind11_1_1detail.html
share/doc/uhd/doxygen/html/namespacepybind11_1_1detail.js
share/doc/uhd/doxygen/html/namespaces.html
share/doc/uhd/doxygen/html/namespaces_dup.js
share/doc/uhd/doxygen/html/namespacestd.html
share/doc/uhd/doxygen/html/namespacestd.js
share/doc/uhd/doxygen/html/namespaceuhd.html
share/doc/uhd/doxygen/html/namespaceuhd.js
share/doc/uhd/doxygen/html/namespaceuhd_1_1build__info.html
Expand Down Expand Up @@ -985,7 +995,15 @@ share/doc/uhd/doxygen/html/navtreeindex13.js
share/doc/uhd/doxygen/html/navtreeindex14.js
share/doc/uhd/doxygen/html/navtreeindex15.js
share/doc/uhd/doxygen/html/navtreeindex16.js
share/doc/uhd/doxygen/html/navtreeindex17.js
share/doc/uhd/doxygen/html/navtreeindex18.js
share/doc/uhd/doxygen/html/navtreeindex19.js
share/doc/uhd/doxygen/html/navtreeindex2.js
share/doc/uhd/doxygen/html/navtreeindex20.js
share/doc/uhd/doxygen/html/navtreeindex21.js
share/doc/uhd/doxygen/html/navtreeindex22.js
share/doc/uhd/doxygen/html/navtreeindex23.js
share/doc/uhd/doxygen/html/navtreeindex24.js
share/doc/uhd/doxygen/html/navtreeindex3.js
share/doc/uhd/doxygen/html/navtreeindex4.js
share/doc/uhd/doxygen/html/navtreeindex5.js
Expand Down Expand Up @@ -1085,7 +1103,6 @@ share/doc/uhd/doxygen/html/property__tree_8hpp.html
share/doc/uhd/doxygen/html/property__tree_8hpp.js
share/doc/uhd/doxygen/html/property__tree_8hpp_source.html
share/doc/uhd/doxygen/html/property__tree_8ipp.html
share/doc/uhd/doxygen/html/property__tree_8ipp.js
share/doc/uhd/doxygen/html/pwr__cal_8hpp.html
share/doc/uhd/doxygen/html/pwr__cal_8hpp_source.html
share/doc/uhd/doxygen/html/pybind__adaptors_8hpp.html
Expand Down Expand Up @@ -1406,11 +1423,15 @@ share/doc/uhd/doxygen/html/search/functions_e.html
share/doc/uhd/doxygen/html/search/functions_e.js
share/doc/uhd/doxygen/html/search/functions_f.html
share/doc/uhd/doxygen/html/search/functions_f.js
share/doc/uhd/doxygen/html/search/groups_0.html
share/doc/uhd/doxygen/html/search/groups_0.js
share/doc/uhd/doxygen/html/search/mag_sel.svg
share/doc/uhd/doxygen/html/search/namespaces_0.html
share/doc/uhd/doxygen/html/search/namespaces_0.js
share/doc/uhd/doxygen/html/search/namespaces_1.html
share/doc/uhd/doxygen/html/search/namespaces_1.js
share/doc/uhd/doxygen/html/search/namespaces_2.html
share/doc/uhd/doxygen/html/search/namespaces_2.js
share/doc/uhd/doxygen/html/search/nomatches.html
share/doc/uhd/doxygen/html/search/pages_0.html
share/doc/uhd/doxygen/html/search/pages_0.js
Expand Down
4 changes: 2 additions & 2 deletions ham/uhd/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.5 2021/12/11 17:39:56 tnn Exp $
# $NetBSD: buildlink3.mk,v 1.6 2022/01/04 17:29:06 adam Exp $

BUILDLINK_TREE+= uhd

.if !defined(UHD_BUILDLINK3_MK)
UHD_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.uhd+= uhd>=2.22
BUILDLINK_ABI_DEPENDS.uhd?= uhd>=4.1.0.4
BUILDLINK_ABI_DEPENDS.uhd+= uhd>=4.1.0.4
BUILDLINK_PKGSRCDIR.uhd?= ../../ham/uhd

# gnuradio-uhd FindUHD.cmake uses this env var as a hint for finding uhd
Expand Down
8 changes: 4 additions & 4 deletions ham/uhd/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.29 2021/12/11 17:39:56 tnn Exp $
$NetBSD: distinfo,v 1.30 2022/01/04 17:29:06 adam Exp $

BLAKE2s (uhd-4.1.0.4.tar.gz) = e67997ef49c983de8e328e36e7ec8b041b6becc52f39d80d9d01283ec2c069a9
SHA512 (uhd-4.1.0.4.tar.gz) = f3ada2f2b114b1e8d0eca71da7ed5494191364c864adb1498314255ba280c7c747f2f5d118c98ae1f7ae96f3ef0e4aafd86955fb7e6271c800b359f95703fcd6
Size (uhd-4.1.0.4.tar.gz) = 37913211 bytes
BLAKE2s (uhd-4.1.0.5.tar.gz) = f172a3e30a7e6b81cf79ead0b7a7bb2f34ea55777b94152c2fec267b2f68586a
SHA512 (uhd-4.1.0.5.tar.gz) = 4929ebc8a12bcc0acfe4a64ceafe17387420e2f056e7bb7284a8d7b60d14aba05484b3c033ce63b00c6d9115f570b056df4e2b36e11a2b25079a8c34b1d084af
Size (uhd-4.1.0.5.tar.gz) = 37975618 bytes
SHA1 (patch-CMakeLists.txt) = 16cc883a0bffdb6c3a4733dda7060bd206928d68
SHA1 (patch-lib_transport_nirio_lvbitx_process-lvbitx.py) = 5117c7593c4e92ed6bfb86388cc366c41a1dead7

0 comments on commit f83cc5e

Please sign in to comment.