-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
rh
committed
May 12, 2002
1 parent
be73b51
commit f9bc1bd
Showing
1 changed file
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# $NetBSD: buildlink.mk,v 1.1 2002/05/12 10:43:10 rh Exp $ | ||
# | ||
# This Makefile fragment is included by packages that use fam. | ||
# | ||
# This file was created automatically using createbuildlink 1.6. | ||
# | ||
# To use this Makefile fragment, simply: | ||
# | ||
# (1) Optionally define BUILDLINK_DEPENDS.fam to the dependency pattern | ||
# for the version of fam desired. | ||
# (2) Include this Makefile fragment in the package Makefile, | ||
# (3) Add ${BUILDLINK_DIR}/include to the front of the C preprocessor's header | ||
# search path, and | ||
# (4) Add ${BUILDLINK_DIR}/lib to the front of the linker's library search | ||
# path. | ||
|
||
.if !defined(FAM_BUILDLINK_MK) | ||
FAM_BUILDLINK_MK= # defined | ||
|
||
.include "../../mk/bsd.buildlink.mk" | ||
|
||
BUILDLINK_DEPENDS.fam?= fam>=2.6.7 | ||
DEPENDS+= ${BUILDLINK_DEPENDS.fam}:../../sysutils/fam | ||
|
||
EVAL_PREFIX+= BUILDLINK_PREFIX.fam=fam | ||
BUILDLINK_PREFIX.fam_DEFAULT= ${LOCALBASE} | ||
BUILDLINK_FILES.fam+= include/fam.h | ||
BUILDLINK_FILES.fam+= lib/fam/editconf.perl | ||
BUILDLINK_FILES.fam+= lib/libfam.* | ||
|
||
|
||
BUILDLINK_TARGETS.fam= fam-buildlink | ||
BUILDLINK_TARGETS+= ${BUILDLINK_TARGETS.fam} | ||
|
||
pre-configure: ${BUILDLINK_TARGETS} | ||
fam-buildlink: _BUILDLINK_USE | ||
|
||
.endif # FAM_BUILDLINK_MK |