-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix format strings. Fix ordering of pointers relative to 0. Bump
revision.
- Loading branch information
Showing
5 changed files
with
73 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,10 @@ | ||
$NetBSD: distinfo,v 1.5 2015/11/03 20:56:53 agc Exp $ | ||
$NetBSD: distinfo,v 1.6 2017/02/08 00:04:53 joerg Exp $ | ||
|
||
SHA1 (kajaani-kombat-0.7.tar.gz) = a6aa674591fef6445c1dbdba446773e9e3d91c8c | ||
RMD160 (kajaani-kombat-0.7.tar.gz) = 0f932876dfe5f9f32d9889f0b1720dd9b570b8e2 | ||
SHA512 (kajaani-kombat-0.7.tar.gz) = 84f6923b73c9529fa600c533b5a3de9ea9411f81060c5ad9fb85346fa17c9cb70bf6ba8222319e123372b01286a11b40bb355e8ef8c9bec95cd98f4d0e0460cb | ||
Size (kajaani-kombat-0.7.tar.gz) = 1805504 bytes | ||
SHA1 (patch-aa) = bc1ec637e480db4ec499b51d9bd9fabd951b1048 | ||
SHA1 (patch-client__net.cpp) = 547692aff95f540c91ca5ab9602c03f05ceb7557 | ||
SHA1 (patch-client__net.cpp) = d0dfcaf5a7cf6063cb5fb2c23830be9372ae6414 | ||
SHA1 (patch-config.cpp) = d330cbb6a63e814c09fcef5ee88b19a78e9ce7f2 | ||
SHA1 (patch-game__server.cpp) = 8da51acf0732363212f27a12037d53438371e05f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-config.cpp,v 1.1 2017/02/08 00:04:53 joerg Exp $ | ||
|
||
Fix format string to match argument. | ||
|
||
--- config.cpp.orig 2017-01-08 19:37:40.160134851 +0000 | ||
+++ config.cpp | ||
@@ -228,7 +228,7 @@ void file_config::read_config( string& f | ||
port = ( strlen( v ) ? v : DEFAULT_PORT ); | ||
} | ||
else { | ||
- fprintf( stderr," Unknown key/value pair (%s/%s) on line %u\n", key.c_str(), v, linenum ); | ||
+ fprintf( stderr," Unknown key/value pair (%s/%s) on line %zu\n", key.c_str(), v, linenum ); | ||
} | ||
} | ||
/* |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-game__server.cpp,v 1.1 2017/02/08 00:04:53 joerg Exp $ | ||
|
||
Pointers are not relative to 0. | ||
|
||
--- game_server.cpp.orig 2017-01-08 19:35:01.809714788 +0000 | ||
+++ game_server.cpp | ||
@@ -64,7 +64,7 @@ void game_server::init_net() | ||
|
||
// OK, init server thread to listen to clients | ||
con_th = SDL_CreateThread (&game_server::connection_accepter, (void *) this); | ||
- if (con_th < 0) | ||
+ if (!con_th) | ||
{ | ||
fprintf (stderr, "[SRV] Error starting thread: %s\n", SDL_GetError()); | ||
exit(2); |