Skip to content

Commit

Permalink
bash: update to 5.1.12.
Browse files Browse the repository at this point in the history
Updated provided by kre@

Changes:
9.  The bash malloc implementation of malloc_usable_size() does not follow
    the specification. This can cause library functions that use it to
    overwrite memory bounds checking.

10. If `wait -n' is interrupted by a trapped signal other than SIGINT, it
    does not completely clean up state, and that can prevent subsequent
    calls to `wait -n' from working correctly.

11. When reading a compound assignment, and running it through the parser
    to split it into words, we need to save and restore any alias we're
    currently expanding.

12. There is a possible race condition that arises when a child process
    receives a signal trapped by the parent before it can reset the signal
    dispositions.   The child process is not supposed to trap the signal
  • Loading branch information
0-wiz-0 committed Nov 18, 2021
1 parent 3e47816 commit ffecdcb
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 27 deletions.
7 changes: 3 additions & 4 deletions shells/bash/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,7 @@
# $NetBSD: Makefile,v 1.101 2021/07/21 10:24:16 jperkin Exp $
# $NetBSD: Makefile,v 1.102 2021/11/18 20:38:19 wiz Exp $

BASH_VERSION= 5.1
BASH_PATCHLEVEL= 8

PKGREVISION= 3
BASH_PATCHLEVEL= 12

DISTNAME= bash-${BASH_VERSION}
PKGNAME= bash-${BASH_VERSION}.${BASH_PATCHLEVEL}
Expand All @@ -13,6 +11,7 @@ MASTER_SITES= ${MASTER_SITE_GNU:=bash/}
PATCH_SITES= ${MASTER_SITES:=bash-5.1-patches/}
PATCHFILES+= bash51-001 bash51-002 bash51-003 bash51-004
PATCHFILES+= bash51-005 bash51-006 bash51-007 bash51-008
PATCHFILES+= bash51-009 bash51-010 bash51-011 bash51-012

MAINTAINER= [email protected]
HOMEPAGE= https://www.gnu.org/software/bash/bash.html
Expand Down
15 changes: 13 additions & 2 deletions shells/bash/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.67 2021/10/26 11:18:36 nia Exp $
$NetBSD: distinfo,v 1.68 2021/11/18 20:38:19 wiz Exp $

BLAKE2s (bash-5.1.tar.gz) = 9053924a9a02eb9e6d9aed99e945c23ddd98481234a50c5897f124dc3f02dd33
SHA512 (bash-5.1.tar.gz) = c44a0ce381469219548a3a27589af3fea4f22eda1ca4e9434b59fc16da81b471c29ce18e31590e0860a6a251a664b68c2b45e3a17d22cfc02799ffd9a208390c
Expand Down Expand Up @@ -27,11 +27,22 @@ Size (bash51-007) = 2621 bytes
BLAKE2s (bash51-008) = 54137de0baaaa419a53b91538821ff45c87f439bde9359be0ebef31b094711b5
SHA512 (bash51-008) = 97f9558a08a66cc9da62c285bf9118b39328e25ed3b9277728e0539b1ac0adef176a090e39cd96dc03d6fd900d8155bd58040cb3390a09f637bab1de8af3faf6
Size (bash51-008) = 1821 bytes
BLAKE2s (bash51-009) = e549836133bf60d8f052e6ca5861821c8cb4d756f42a54acac4bbad584008580
SHA512 (bash51-009) = 2d3c65162ec4e5c3dfeb439891950ef2c43973a84122fcdf6b56c388466c7e671dbc9b236d2253f01411b668c365855263995dbacb8e6f9e9dbcb7e6c2cc518c
Size (bash51-009) = 1627 bytes
BLAKE2s (bash51-010) = bf16355b68342d8bf495259608873121ecc621925e63ca8906ef454ba35d2f4d
SHA512 (bash51-010) = aac4a0b72b559566334f1029c52754f4c98185af99e09436e401d83ab81bab7882d0d8050674b30f171733f3628157777a264566e927e93db2ea5a18d26630f1
Size (bash51-010) = 1700 bytes
BLAKE2s (bash51-011) = dcb9dd45b7652372456f28f74e8fa5cce03bf88318f127cd2d10af766937feeb
SHA512 (bash51-011) = bb9e47a570bb9758c365831f9650b9379b60862b8cef572edc3cd833df96ebb8b9612de474bdc2a03ff4efc2275f871d55962295385e38f3658874488e974b81
Size (bash51-011) = 2229 bytes
BLAKE2s (bash51-012) = d9e0cbc34d1ead557dca3a467043c10756d32d13af64aa30eb8d025876c2ccb5
SHA512 (bash51-012) = 59819914b6821d9f4af0aade7b9b7ea92368c2b8eb8407cea11dfeee7208905dd06bdef7a049d7b1c4fac41c44d9a130b95a061957a9649050b37471b3044cf1
Size (bash51-012) = 6372 bytes
SHA1 (patch-af) = e26e3209902247263884cfebc11a2f7e43245062
SHA1 (patch-ag) = cd3b151e3bb045d2bb609c0a03d7d3df2c871f47
SHA1 (patch-aj) = 2e4c15afd9b50d44967ee8e1f85bdc908c0eeeb0
SHA1 (patch-builtins_ulimit.def) = 1390069344607204eb3abbd6ddeb148ff590c55e
SHA1 (patch-builtins_wait.def) = 777ed0528fbd66ea20b039a2ab33ce89221c7312
SHA1 (patch-configure) = c4e1ab53a1ee85f3e6121047f0aca8ceb85e6e5d
SHA1 (patch-examples_loadables_fdflags.c) = dce409c76b7d6c838eb25c3ccc7a89ee57ca69b8
SHA1 (patch-lib_malloc_malloc.c) = fc22c2bb45490c57782d34d62336d168875c3609
Expand Down
21 changes: 0 additions & 21 deletions shells/bash/patches/patch-builtins_wait.def

This file was deleted.

0 comments on commit ffecdcb

Please sign in to comment.