Skip to content

Commit

Permalink
ar71xx: Add eTactica EG-200 support
Browse files Browse the repository at this point in the history
EG-200 is a DIN rail mountable device with one ethernet port, wifi,
an RS-485 port, and an internal USB attached uSD card reader.

Two leds, "modbus" and "etactica" are managed by userspace applications
in factory firmware.

Flash instruction:
    Original firmware is based on OpenWrt.
    Use sysupgrade image directly in vendor GUI.

Signed-off-by: Karl Palsson <[email protected]>
  • Loading branch information
karlp authored and blogic committed Feb 13, 2018
1 parent da8990e commit b2a5f76
Show file tree
Hide file tree
Showing 13 changed files with 140 additions and 1 deletion.
1 change: 1 addition & 0 deletions package/boot/uboot-envtools/files/ar71xx
Original file line number Diff line number Diff line change
Expand Up @@ -48,6 +48,7 @@ om5p-ac|\
om5p-acv2|\
om5p-an|\
r36a|\
rme-eg200|\
sr3200|\
tube2h|\
wndr3700|\
Expand Down
6 changes: 6 additions & 0 deletions target/linux/ar71xx/base-files/etc/board.d/01_leds
Original file line number Diff line number Diff line change
Expand Up @@ -623,6 +623,12 @@ re450)
ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "$board:blue:wlan2g" "phy1tpt"
ucidef_set_led_wlan "wlan5g" "WLAN 5 GHz" "$board:blue:wlan5g" "phy0tpt"
;;
rme-eg200)
ucidef_set_led_netdev "wan" "WAN" "eg200:red:eth0" "eth0"
ucidef_set_led_wlan "wlan" "WLAN" "eg200:red:wlan" "phy0tpt"
ucidef_set_led_oneshot "modbus" "Modbus" "eg200:red:modbus" "100" "33"
ucidef_set_led_default "etactica" "etactica" "eg200:red:etactica" "ignore"
;;
rocket-m-ti)
ucidef_set_led_rssi "rssiverylow" "RSSIVERYLOW" "ubnt:green:link1" "wlan0" "1" "100" "0" "13"
ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:green:link2" "wlan0" "26" "100" "-25" "13"
Expand Down
3 changes: 2 additions & 1 deletion target/linux/ar71xx/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -262,7 +262,8 @@ ar71xx_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "3:wan" "4:lan"
;;
cap324)
cap324|\
rme-eg200)
ucidef_set_interface_lan "eth0" "dhcp"
;;
cpe210|\
Expand Down
3 changes: 3 additions & 0 deletions target/linux/ar71xx/base-files/lib/ar71xx.sh
Original file line number Diff line number Diff line change
Expand Up @@ -670,6 +670,9 @@ ar71xx_board_detect() {
*"ESR900")
name="esr900"
;;
*"eTactica EG-200")
name="rme-eg200"
;;
*"FRITZ!WLAN Repeater 300E")
name="fritz300e"
;;
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/base-files/lib/upgrade/platform.sh
Original file line number Diff line number Diff line change
Expand Up @@ -262,6 +262,7 @@ platform_check_image() {
pqi-air-pen|\
r36a|\
r602n|\
rme-eg200|\
rocket-m|\
rocket-m-ti|\
rocket-m-xw|\
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/config-4.4
Original file line number Diff line number Diff line change
Expand Up @@ -170,6 +170,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_RBSXTLITE is not set
# CONFIG_ATH79_MACH_RE355 is not set
# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RME_EG200 is not set
# CONFIG_ATH79_MACH_RUT9XX is not set
# CONFIG_ATH79_MACH_RW2458N is not set
# CONFIG_ATH79_MACH_SC1750 is not set
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/config-4.9
Original file line number Diff line number Diff line change
Expand Up @@ -168,6 +168,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_RBSXTLITE is not set
# CONFIG_ATH79_MACH_RE355 is not set
# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RME_EG200 is not set
# CONFIG_ATH79_MACH_RUT9XX is not set
# CONFIG_ATH79_MACH_RW2458N is not set
# CONFIG_ATH79_MACH_SC1750 is not set
Expand Down
10 changes: 10 additions & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
Original file line number Diff line number Diff line change
Expand Up @@ -1325,6 +1325,16 @@ config ATH79_MACH_RE450
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC

config ATH79_MACH_RME_EG200
bool "eTactica EG200 board supprt"
select SOC_AR933X
select ATH79_DEV_ETH
select ATH79_DEV_GPIO_BUTTONS
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC

config ATH79_MACH_RUT9XX
bool "Teltonika RUT900 series support"
select SOC_AR934X
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -179,6 +179,7 @@ obj-$(CONFIG_ATH79_MACH_RBSPI) += mach-rbspi.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
obj-$(CONFIG_ATH79_MACH_RE355) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RME_EG200) += mach-rme-eg200.o
obj-$(CONFIG_ATH79_MACH_RUT9XX) += mach-rut9xx.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
obj-$(CONFIG_ATH79_MACH_SC1750) += mach-sc1750.o
Expand Down
99 changes: 99 additions & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/mach-rme-eg200.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
/*
* eTactica EG-200 board, based on 8devices Carambola2 module
*
* Copyright (C) 2015 Karl Palsson <[email protected]>
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/

#include <asm/mach-ath79/ath79.h>
#include <asm/mach-ath79/ar71xx_regs.h>
#include "common.h"
#include "dev-eth.h"
#include "dev-gpio-buttons.h"
#include "dev-leds-gpio.h"
#include "dev-m25p80.h"
#include "dev-usb.h"
#include "dev-wmac.h"
#include "machtypes.h"

#define RME_EG200_GPIO_LED_WLAN 0
#define RME_EG200_GPIO_LED_ETH0 13
#define RME_EG200_GPIO_LED_ETACTICA 15
#define RME_EG200_GPIO_LED_MODBUS 16

#define RME_EG200_GPIO_BTN_RESTORE 11

#define RME_EG200_KEYS_POLL_INTERVAL 20 /* msecs */
#define RME_EG200_KEYS_DEBOUNCE_INTERVAL (3 * RME_EG200_KEYS_POLL_INTERVAL)

#define RME_EG200_MAC0_OFFSET 0x0000
#define RME_EG200_CALDATA_OFFSET 0x1000
#define RME_EG200_WMAC_MAC_OFFSET 0x1002

static struct gpio_led rme_eg200_leds_gpio[] __initdata = {
{
.name = "eg200:red:wlan",
.gpio = RME_EG200_GPIO_LED_WLAN,
.active_low = 1,
}, {
.name = "eg200:red:eth0",
.gpio = RME_EG200_GPIO_LED_ETH0,
.active_low = 1,
}, {
.name = "eg200:red:etactica",
.gpio = RME_EG200_GPIO_LED_ETACTICA,
.active_low = 0,
}, {
.name = "eg200:red:modbus",
.gpio = RME_EG200_GPIO_LED_MODBUS,
.active_low = 0,
}
};

static struct gpio_keys_button rme_eg200_keys[] __initdata = {
{
.desc = "restore button",
.type = EV_KEY,
.code = KEY_WPS_BUTTON,
.debounce_interval = RME_EG200_KEYS_DEBOUNCE_INTERVAL,
.gpio = RME_EG200_GPIO_BTN_RESTORE,
.active_low = 1,
},
};

static void __init rme_eg200_setup(void)
{
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);

ath79_register_m25p80(NULL);
ath79_register_wmac(art + RME_EG200_CALDATA_OFFSET,
art + RME_EG200_WMAC_MAC_OFFSET);

ath79_setup_ar933x_phy4_switch(true, true);

ath79_init_mac(ath79_eth0_data.mac_addr, art + RME_EG200_MAC0_OFFSET, 0);

ath79_register_mdio(0, 0x0);

/* WAN port */
ath79_register_eth(0);

ath79_gpio_function_disable(AR724X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
AR724X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
AR724X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
AR724X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
AR724X_GPIO_FUNC_ETH_SWITCH_LED4_EN);

ath79_register_leds_gpio(-1, ARRAY_SIZE(rme_eg200_leds_gpio),
rme_eg200_leds_gpio);
ath79_register_gpio_keys_polled(-1, RME_EG200_KEYS_POLL_INTERVAL,
ARRAY_SIZE(rme_eg200_keys),
rme_eg200_keys);
ath79_register_usb();
}

MIPS_MACHINE(ATH79_MACH_RME_EG200, "RME-EG200", "eTactica EG-200",
rme_eg200_setup);
1 change: 1 addition & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
Original file line number Diff line number Diff line change
Expand Up @@ -209,6 +209,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
ATH79_MACH_RE355, /* TP-LINK RE355 */
ATH79_MACH_RE450, /* TP-LINK RE450 */
ATH79_MACH_RME_EG200, /* eTactica EG200 */
ATH79_MACH_RUT9XX, /* Teltonika RUT900 series */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
ATH79_MACH_SC1750, /* Abicom SC1750 */
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/generic/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -127,6 +127,7 @@ CONFIG_ATH79_MACH_R36A=y
CONFIG_ATH79_MACH_R602N=y
CONFIG_ATH79_MACH_RE355=y
CONFIG_ATH79_MACH_RE450=y
CONFIG_ATH79_MACH_RME_EG200=y
CONFIG_ATH79_MACH_RUT9XX=y
CONFIG_ATH79_MACH_RW2458N=y
CONFIG_ATH79_MACH_SC1750=y
Expand Down
13 changes: 13 additions & 0 deletions target/linux/ar71xx/image/generic.mk
Original file line number Diff line number Diff line change
Expand Up @@ -310,6 +310,19 @@ define Device/ew-dorin-router
endef
TARGET_DEVICES += ew-dorin-router

define Device/rme-eg200
DEVICE_TITLE := eTactica EG-200
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ledtrig-oneshot \
kmod-usb-serial kmod-usb-serial-ftdi \
kmod-usb-storage \
kmod-fs-ext4
BOARDNAME = RME-EG200
IMAGE_SIZE = 16000k
CONSOLE = ttyATH0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += rme-eg200

define Device/weio
DEVICE_TITLE := WeIO
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
Expand Down

0 comments on commit b2a5f76

Please sign in to comment.