Skip to content

Commit

Permalink
upgrade mklibs to 0.1.29 - fixes runtime errors in mklibs-readelf
Browse files Browse the repository at this point in the history
SVN-Revision: 17171
  • Loading branch information
Felix Fietkau committed Aug 8, 2009
1 parent 583f6f2 commit a6a8398
Show file tree
Hide file tree
Showing 3 changed files with 10 additions and 9 deletions.
6 changes: 4 additions & 2 deletions tools/mklibs/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=mklibs
PKG_VERSION:=0.1.26
PKG_VERSION:=0.1.29

PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
PKG_MD5SUM:=708f284975f1b567b817d27f7677a95f
PKG_MD5SUM:=7f35dfdbde249a090199829c1a1222d8

HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mklibs

include $(INCLUDE_DIR)/host-build.mk

Expand Down
7 changes: 3 additions & 4 deletions tools/mklibs/patches/001-missing_stdio.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
diff -urN mklibs-0.1.26/src/mklibs-readelf/main.cpp mklibs-0.1.26.new/src/mklibs-readelf/main.cpp
--- mklibs-0.1.26/src/mklibs-readelf/main.cpp 2007-09-20 19:41:34.000000000 +0200
+++ mklibs-0.1.26.new/src/mklibs-readelf/main.cpp 2009-08-07 12:20:21.000000000 +0200
@@ -6,6 +6,7 @@
--- a/src/mklibs-readelf/main.cpp
+++ b/src/mklibs-readelf/main.cpp
@@ -7,6 +7,7 @@

#include <elf.h>
#include <getopt.h>
Expand Down
6 changes: 3 additions & 3 deletions tools/mklibs/patches/002-disable_symbol_checks.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/src/mklibs.py
+++ b/src/mklibs.py
@@ -429,7 +429,7 @@ while 1:
@@ -500,7 +500,7 @@ while 1:
# No progress in last pass. Verify all remaining symbols are weak.
for name in unresolved:
if not needed_symbols[name].weak:
Expand All @@ -9,13 +9,13 @@
break

previous_pass_unresolved = unresolved
@@ -467,10 +467,7 @@ while 1:
@@ -533,10 +533,7 @@ while 1:

# which symbols are actually used from each lib
for name in needed_symbols:
- if not name in symbol_provider:
- if not needed_symbols[name].weak:
- raise "No library provides non-weak %s" % symbol
- raise "No library provides non-weak %s" % name
- else:
+ if name in symbol_provider:
lib = symbol_provider[name]
Expand Down

0 comments on commit a6a8398

Please sign in to comment.