Skip to content

Commit

Permalink
beecrypt: make a config option for C++ support
Browse files Browse the repository at this point in the history
beecrypt used to pull in icu automatically when C++ support was enabled,
but since icu is pretty large and slow, that automatic dependency was
removed.  However, it is not obvious to the user that he should enable
icu in order to get C++ support in beecrypt. Therefore, make the C++
support a user visible config option and mention icu in the help text.

It would also be possible to automatically enable C++ support if icu
happens to be selected for another reason, but that doesn't really seem
to offer an advantage.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <[email protected]>
Signed-off-by: Peter Korsgaard <[email protected]>
  • Loading branch information
arnout authored and jacmet committed Mar 26, 2014
1 parent 0ac91f8 commit 3fb263f
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 4 deletions.
23 changes: 21 additions & 2 deletions package/beecrypt/Config.in
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
comment "beecrypt needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS

config BR2_PACKAGE_BEECRYPT
bool "beecrypt"
depends on BR2_TOOLCHAIN_HAS_THREADS
Expand All @@ -6,5 +9,21 @@ config BR2_PACKAGE_BEECRYPT

http://beecrypt.sf.net

comment "beecrypt needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS
if BR2_PACKAGE_BEECRYPT

config BR2_PACKAGE_BEECRYPT_CPP
bool "C++ support"
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # icu
depends on !BR2_arc # icu
depends on !BR2_BINFMT_FLAT # icu
select BR2_PACKAGE_ICU
help
Enable C++ support. This pulls in the (large) icu package.

comment "C++ support needs a toolchain w/ wchar"
depends on !BR2_arc
depends on !BR2_BINFMT_FLAT
depends on BR2_INSTALL_LIBSTDCPP && !BR2_USE_WCHAR

endif # BR2_PACKAGE_BEECRYPT
3 changes: 1 addition & 2 deletions package/beecrypt/beecrypt.mk
Original file line number Diff line number Diff line change
Expand Up @@ -22,8 +22,7 @@ BEECRYPT_CONF_OPT = \
--without-python \
--disable-openmp

ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR)$(BR2_PACKAGE_ICU),yyy)
# C++ support needs icu
ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
BEECRYPT_DEPENDENCIES += icu
else
BEECRYPT_CONF_OPT += --without-cplusplus
Expand Down

0 comments on commit 3fb263f

Please sign in to comment.