forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 3
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Changelog: https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.1.79 Manually rebased: ath79/patches-6.1/900-unaligned_access_hacks.patch All other patches automatically rebased. Build system: x86/64 Build-tested: x86/64/AMD Cezanne, ramips/tplink_archer-a6-v3, flogic/xiaomi_redmi-router-ax6000-ubootmod Run-tested: x86/64/AMD Cezanne, ramips/tplink_archer-a6-v3, flogic/xiaomi_redmi-router-ax6000-ubootmod Signed-off-by: John Audia <[email protected]>
- Loading branch information
Showing
17 changed files
with
32 additions
and
31 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,2 @@ | ||
LINUX_VERSION-6.1 = .78 | ||
LINUX_KERNEL_HASH-6.1.78 = 65206b969831236849c9906eba267e715734a93808e9909fd9b4f12eea10d689 | ||
LINUX_VERSION-6.1 = .79 | ||
LINUX_KERNEL_HASH-6.1.79 = faa49ca22fb55ed4d5ca2a55e07dd10e4e171cfc3b92568a631453cd2068b39b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -1185,7 +1185,7 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
} | ||
--- a/drivers/usb/core/hub.c | ||
+++ b/drivers/usb/core/hub.c | ||
@@ -5669,7 +5669,7 @@ static void port_event(struct usb_hub *h | ||
@@ -5677,7 +5677,7 @@ static void port_event(struct usb_hub *h | ||
port_dev->over_current_count++; | ||
port_over_current_notify(port_dev); | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -52,7 +52,7 @@ Signed-off-by: Dom Cobley <[email protected]> | |
/* L2 intc private data structure */ | ||
struct brcmstb_l2_intc_data { | ||
struct irq_domain *domain; | ||
@@ -286,11 +296,18 @@ static int __init brcmstb_l2_lvl_intc_of | ||
@@ -289,11 +299,18 @@ static int __init brcmstb_l2_lvl_intc_of | ||
return brcmstb_l2_intc_of_init(np, parent, &l2_lvl_intc_init); | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -42,7 +42,7 @@ Signed-off-by: Paolo Abeni <[email protected]> | |
|
||
__netif_tx_unlock_bh(netdev_get_tx_queue(priv->dev, queue)); | ||
|
||
@@ -5485,12 +5489,13 @@ static int stmmac_napi_poll_tx(struct na | ||
@@ -5488,12 +5492,13 @@ static int stmmac_napi_poll_tx(struct na | ||
struct stmmac_channel *ch = | ||
container_of(napi, struct stmmac_channel, tx_napi); | ||
struct stmmac_priv *priv = ch->priv_data; | ||
|
@@ -57,7 +57,7 @@ Signed-off-by: Paolo Abeni <[email protected]> | |
work_done = min(work_done, budget); | ||
|
||
if (work_done < budget && napi_complete_done(napi, work_done)) { | ||
@@ -5501,6 +5506,10 @@ static int stmmac_napi_poll_tx(struct na | ||
@@ -5504,6 +5509,10 @@ static int stmmac_napi_poll_tx(struct na | ||
spin_unlock_irqrestore(&ch->lock, flags); | ||
} | ||
|
||
|
@@ -68,7 +68,7 @@ Signed-off-by: Paolo Abeni <[email protected]> | |
return work_done; | ||
} | ||
|
||
@@ -5509,12 +5518,13 @@ static int stmmac_napi_poll_rxtx(struct | ||
@@ -5512,12 +5521,13 @@ static int stmmac_napi_poll_rxtx(struct | ||
struct stmmac_channel *ch = | ||
container_of(napi, struct stmmac_channel, rxtx_napi); | ||
struct stmmac_priv *priv = ch->priv_data; | ||
|
@@ -83,7 +83,7 @@ Signed-off-by: Paolo Abeni <[email protected]> | |
tx_done = min(tx_done, budget); | ||
|
||
rx_done = stmmac_rx_zc(priv, budget, chan); | ||
@@ -5539,6 +5549,10 @@ static int stmmac_napi_poll_rxtx(struct | ||
@@ -5542,6 +5552,10 @@ static int stmmac_napi_poll_rxtx(struct | ||
spin_unlock_irqrestore(&ch->lock, flags); | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -21,7 +21,7 @@ Signed-off-by: Greg Kroah-Hartman <[email protected]> | |
|
||
--- a/drivers/of/property.c | ||
+++ b/drivers/of/property.c | ||
@@ -1144,8 +1144,8 @@ static struct device_node *parse_prop_ce | ||
@@ -1146,8 +1146,8 @@ static struct device_node *parse_prop_ce | ||
if (strcmp(prop_name, list_name)) | ||
return NULL; | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <[email protected]> | |
|
||
--- a/drivers/of/property.c | ||
+++ b/drivers/of/property.c | ||
@@ -1249,7 +1249,7 @@ DEFINE_SIMPLE_PROP(dmas, "dmas", "#dma-c | ||
@@ -1251,7 +1251,7 @@ DEFINE_SIMPLE_PROP(dmas, "dmas", "#dma-c | ||
DEFINE_SIMPLE_PROP(power_domains, "power-domains", "#power-domain-cells") | ||
DEFINE_SIMPLE_PROP(hwlocks, "hwlocks", "#hwlock-cells") | ||
DEFINE_SIMPLE_PROP(extcon, "extcon", NULL) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -141,7 +141,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
--- a/scripts/mod/modpost.c | ||
+++ b/scripts/mod/modpost.c | ||
@@ -1781,7 +1781,9 @@ static void read_symbols(const char *mod | ||
@@ -1785,7 +1785,9 @@ static void read_symbols(const char *mod | ||
symname = remove_dot(info.strtab + sym->st_name); | ||
|
||
handle_symbol(mod, &info, sym, symname); | ||
|
@@ -151,7 +151,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
} | ||
|
||
for (sym = info.symtab_start; sym < info.symtab_stop; sym++) { | ||
@@ -1944,8 +1946,10 @@ static void add_header(struct buffer *b, | ||
@@ -1948,8 +1950,10 @@ static void add_header(struct buffer *b, | ||
buf_printf(b, "BUILD_SALT;\n"); | ||
buf_printf(b, "BUILD_LTO_INFO;\n"); | ||
buf_printf(b, "\n"); | ||
|
@@ -162,7 +162,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
buf_printf(b, "\n"); | ||
buf_printf(b, "__visible struct module __this_module\n"); | ||
buf_printf(b, "__section(\".gnu.linkonce.this_module\") = {\n"); | ||
@@ -1959,8 +1963,10 @@ static void add_header(struct buffer *b, | ||
@@ -1963,8 +1967,10 @@ static void add_header(struct buffer *b, | ||
buf_printf(b, "\t.arch = MODULE_ARCH_INIT,\n"); | ||
buf_printf(b, "};\n"); | ||
|
||
|
@@ -173,7 +173,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
buf_printf(b, | ||
"\n" | ||
@@ -1968,8 +1974,10 @@ static void add_header(struct buffer *b, | ||
@@ -1972,8 +1978,10 @@ static void add_header(struct buffer *b, | ||
"MODULE_INFO(retpoline, \"Y\");\n" | ||
"#endif\n"); | ||
|
||
|
@@ -184,7 +184,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
if (strstarts(mod->name, "tools/testing")) | ||
buf_printf(b, "\nMODULE_INFO(test, \"Y\");\n"); | ||
@@ -2065,11 +2073,13 @@ static void add_depends(struct buffer *b | ||
@@ -2069,11 +2077,13 @@ static void add_depends(struct buffer *b | ||
|
||
static void add_srcversion(struct buffer *b, struct module *mod) | ||
{ | ||
|
@@ -198,7 +198,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
} | ||
|
||
static void write_buf(struct buffer *b, const char *fname) | ||
@@ -2155,7 +2165,9 @@ static void write_mod_c_file(struct modu | ||
@@ -2159,7 +2169,9 @@ static void write_mod_c_file(struct modu | ||
add_exported_symbols(&buf, mod); | ||
add_versions(&buf, mod); | ||
add_depends(&buf, mod); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
/* Align . to a 8 byte boundary equals to maximum function alignment. */ | ||
#define ALIGN_FUNCTION() . = ALIGN(8) | ||
|
||
@@ -512,14 +522,14 @@ | ||
@@ -511,14 +521,14 @@ | ||
/* Kernel symbol table: Normal symbols */ \ | ||
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \ | ||
__start___ksymtab = .; \ | ||
|
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
__stop___ksymtab_gpl = .; \ | ||
} \ | ||
\ | ||
@@ -539,7 +549,7 @@ | ||
@@ -538,7 +548,7 @@ | ||
\ | ||
/* Kernel symbol table: strings */ \ | ||
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \ | ||
|
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
} \ | ||
\ | ||
/* __*init sections */ \ | ||
@@ -1048,6 +1058,8 @@ | ||
@@ -1042,6 +1052,8 @@ | ||
#define COMMON_DISCARDS \ | ||
SANITIZER_DISCARDS \ | ||
PATCHABLE_DISCARDS \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -19,7 +19,7 @@ Signed-off-by: Rafał Miłecki <[email protected]> | |
|
||
--- a/drivers/base/core.c | ||
+++ b/drivers/base/core.c | ||
@@ -1700,7 +1700,7 @@ static void device_links_purge(struct de | ||
@@ -1702,7 +1702,7 @@ static void device_links_purge(struct de | ||
#define FW_DEVLINK_FLAGS_RPM (FW_DEVLINK_FLAGS_ON | \ | ||
DL_FLAG_PM_RUNTIME) | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -606,7 +606,7 @@ endif | ||
@@ -605,7 +605,7 @@ endif | ||
# Allows the usage of unstable features in stable compilers. | ||
export RUSTC_BOOTSTRAP := 1 | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
--- a/init/Kconfig | ||
+++ b/init/Kconfig | ||
@@ -1482,6 +1482,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW | ||
@@ -1491,6 +1491,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW | ||
the unaligned access emulation. | ||
see arch/parisc/kernel/unaligned.c for reference | ||
|
||
|
@@ -105,7 +105,7 @@ Signed-off-by: Felix Fietkau <[email protected]> | |
|
||
--- a/scripts/link-vmlinux.sh | ||
+++ b/scripts/link-vmlinux.sh | ||
@@ -160,6 +160,10 @@ kallsyms() | ||
@@ -165,6 +165,10 @@ kallsyms() | ||
kallsymopt="${kallsymopt} --lto-clang" | ||
fi | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <[email protected]> | |
|
||
--- a/init/Kconfig | ||
+++ b/init/Kconfig | ||
@@ -1827,6 +1827,15 @@ config EMBEDDED | ||
@@ -1836,6 +1836,15 @@ config EMBEDDED | ||
an embedded system so certain expert options are available | ||
for configuration. | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -63,7 +63,7 @@ Signed-off-by: Petr Štetiar <[email protected]> | |
reg_3v3_vmmc: regulator-3v3-vmmc { | ||
compatible = "regulator-fixed"; | ||
enable-active-high; | ||
@@ -260,6 +271,12 @@ | ||
@@ -262,6 +273,12 @@ | ||
>; | ||
}; | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -136,7 +136,7 @@ Signed-off-by: Maxime Chevallier <[email protected]> | |
#include <net/dst.h> | ||
#include <net/sock.h> | ||
#include <net/checksum.h> | ||
@@ -4516,6 +4520,9 @@ static const u8 skb_ext_type_len[] = { | ||
@@ -4517,6 +4521,9 @@ static const u8 skb_ext_type_len[] = { | ||
#if IS_ENABLED(CONFIG_MCTP_FLOWS) | ||
[SKB_EXT_MCTP] = SKB_EXT_CHUNKSIZEOF(struct mctp_flow), | ||
#endif | ||
|
@@ -146,7 +146,7 @@ Signed-off-by: Maxime Chevallier <[email protected]> | |
}; | ||
|
||
static __always_inline unsigned int skb_ext_total_length(void) | ||
@@ -4536,6 +4543,9 @@ static __always_inline unsigned int skb_ | ||
@@ -4537,6 +4544,9 @@ static __always_inline unsigned int skb_ | ||
#if IS_ENABLED(CONFIG_MCTP_FLOWS) | ||
skb_ext_type_len[SKB_EXT_MCTP] + | ||
#endif | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -59,7 +59,7 @@ Signed-off-by: John Crispin <[email protected]> | |
depends on ARCH_RENESAS || COMPILE_TEST | ||
--- a/drivers/i2c/busses/Makefile | ||
+++ b/drivers/i2c/busses/Makefile | ||
@@ -97,6 +97,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM) += i2c-pc | ||
@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM) += i2c-pc | ||
obj-$(CONFIG_I2C_PNX) += i2c-pnx.o | ||
obj-$(CONFIG_I2C_PXA) += i2c-pxa.o | ||
obj-$(CONFIG_I2C_PXA_PCI) += i2c-pxa-pci.o | ||
|