Skip to content

Commit

Permalink
openssl: update to 1.0.2f (fixes CVE-2016-0701, CVE-2015-3197)
Browse files Browse the repository at this point in the history
Signed-off-by: Felix Fietkau <[email protected]>

Backport of r48531

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48532 3c298f89-4303-0410-b956-a3cf2f4a3e73
  • Loading branch information
Felix Fietkau committed Jan 28, 2016
1 parent 7a4a793 commit 0c335d6
Show file tree
Hide file tree
Showing 6 changed files with 20 additions and 20 deletions.
4 changes: 2 additions & 2 deletions package/libs/openssl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openssl
PKG_VERSION:=1.0.2e
PKG_VERSION:=1.0.2f
PKG_RELEASE:=1
PKG_USE_MIPS16:=0

Expand All @@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
PKG_MD5SUM:=5262bfa25b60ed9de9f28d5d52d77fc5
PKG_MD5SUM:=b3bf73f507172be9292ea2a8c28b659d

PKG_LICENSE:=OpenSSL
PKG_LICENSE_FILES:=LICENSE
Expand Down
2 changes: 1 addition & 1 deletion package/libs/openssl/patches/110-optimize-for-size.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
@@ -461,6 +461,12 @@ my %table=(
@@ -464,6 +464,12 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",

Expand Down
2 changes: 1 addition & 1 deletion package/libs/openssl/patches/150-no_engines.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Configure
+++ b/Configure
@@ -2106,6 +2106,11 @@ EOF
@@ -2103,6 +2103,11 @@ EOF
close(OUT);
}

Expand Down
14 changes: 7 additions & 7 deletions package/libs/openssl/patches/160-disable_doc_tests.patch
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,7 @@
WDIRS= windows
LIBS= libcrypto.a libssl.a
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
@@ -274,7 +274,7 @@ reflect:
@@ -273,7 +273,7 @@ reflect:

sub_all: build_all

Expand All @@ -36,9 +36,9 @@

build_libs: build_libcrypto build_libssl openssl.pc

@@ -534,7 +534,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -530,7 +530,7 @@ dist:
@$(MAKE) SDIRS='$(SDIRS)' clean
@$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar

-install: all install_docs install_sw
+install: all install_sw
Expand All @@ -47,9 +47,9 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
--- a/Makefile.org
+++ b/Makefile.org
@@ -532,7 +532,7 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -528,7 +528,7 @@ dist:
@$(MAKE) SDIRS='$(SDIRS)' clean
@$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar

-install: all install_docs install_sw
+install: all install_sw
Expand Down
4 changes: 2 additions & 2 deletions package/libs/openssl/patches/190-remove_timestamp_check.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Makefile.org
+++ b/Makefile.org
@@ -185,7 +185,7 @@ WTARFILE= $(NAME)-win.tar
@@ -184,7 +184,7 @@ TARFILE= ../$(NAME).tar
EXHEADER= e_os2.h
HEADER= e_os.h

Expand All @@ -9,7 +9,7 @@

# as we stick to -e, CLEARENV ensures that local variables in lower
# Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
@@ -401,11 +401,6 @@ openssl.pc: Makefile
@@ -400,11 +400,6 @@ openssl.pc: Makefile
echo 'Version: '$(VERSION); \
echo 'Requires: libssl libcrypto' ) > openssl.pc

Expand Down
14 changes: 7 additions & 7 deletions package/libs/openssl/patches/200-parallel_build.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Makefile.org
+++ b/Makefile.org
@@ -280,17 +280,17 @@ build_libcrypto: build_crypto build_engi
@@ -279,17 +279,17 @@ build_libcrypto: build_crypto build_engi
build_libssl: build_ssl libssl.pc

build_crypto:
Expand All @@ -24,7 +24,7 @@

all_testapps: build_libs build_testapps
build_testapps:
@@ -462,7 +462,7 @@ update: errors stacks util/libeay.num ut
@@ -461,7 +461,7 @@ update: errors stacks util/libeay.num ut
@set -e; target=update; $(RECURSIVE_BUILD_CMD)

depend:
Expand All @@ -33,9 +33,9 @@

lint:
@set -e; target=lint; $(RECURSIVE_BUILD_CMD)
@@ -527,9 +527,9 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -523,9 +523,9 @@ dist:
@$(MAKE) SDIRS='$(SDIRS)' clean
@$(MAKE) TAR='$(TAR)' TARFLAGS='$(TARFLAGS)' $(DISTTARVARS) tar

-install: all install_sw
+install: install_sw
Expand All @@ -45,7 +45,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
@@ -538,12 +538,19 @@ install_sw:
@@ -534,12 +534,19 @@ install_sw:
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
Expand All @@ -66,7 +66,7 @@
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
@@ -627,12 +634,7 @@ install_html_docs:
@@ -623,12 +630,7 @@ install_html_docs:
done; \
done

Expand Down

0 comments on commit 0c335d6

Please sign in to comment.