forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Marvell 88W8864 open source mac80211 driver
Signed-off-by: Imre Kaloz <[email protected]> SVN-Revision: 43772
- Loading branch information
Showing
2 changed files
with
71 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# | ||
# Copyright (C) 2014 OpenWrt.org | ||
# | ||
# This is free software, licensed under the GNU General Public License v2. | ||
# See /LICENSE for more information. | ||
# | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=mwlwifi | ||
PKG_VERSION:=10.2.6.1.p4-20141224 | ||
PKG_RELEASE=1 | ||
|
||
PKG_LICENSE:=ISC | ||
PKG_LICENSE_FILES:= | ||
|
||
PKG_SOURCE_URL:=https://github.com/kaloz/mwlwifi | ||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) | ||
PKG_SOURCE_VERSION:=28120935bc38e3861a885d745ec6ebe3f603611e | ||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz | ||
|
||
PKG_MAINTAINER:=Imre Kaloz <[email protected]> | ||
PKG_BUILD_PARALLEL:=1 | ||
|
||
include $(INCLUDE_DIR)/kernel.mk | ||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define KernelPackage/mwlwifi | ||
SUBMENU:=Wireless Drivers | ||
TITLE:=Marvell 88W8864 wireless driver | ||
DEPENDS:=+kmod-mac80211 +@DRIVER_11N_SUPPORT @PCI_SUPPORT | ||
FILES:=$(PKG_BUILD_DIR)/mwlwifi.ko | ||
AUTOLOAD:=$(call AutoLoad,50,mac80211 mwlwifi) | ||
endef | ||
|
||
NOSTDINC_FLAGS = \ | ||
-I$(PKG_BUILD_DIR) \ | ||
-I$(STAGING_DIR)/usr/include/mac80211-backport/uapi \ | ||
-I$(STAGING_DIR)/usr/include/mac80211-backport \ | ||
-I$(STAGING_DIR)/usr/include/mac80211/uapi \ | ||
-I$(STAGING_DIR)/usr/include/mac80211 \ | ||
-include backport/backport.h | ||
|
||
define Build/Compile | ||
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \ | ||
ARCH="$(LINUX_KARCH)" \ | ||
CROSS_COMPILE="$(TARGET_CROSS)" \ | ||
SUBDIRS="$(PKG_BUILD_DIR)" \ | ||
NOSTDINC_FLAGS="$(NOSTDINC_FLAGS)" \ | ||
modules | ||
endef | ||
|
||
define KernelPackage/mwlwifi/install | ||
$(INSTALL_DIR) $(1)/lib/firmware | ||
$(CP) $(PKG_BUILD_DIR)/bin/firmware/7.2.6.1/88W8864.bin $(1)/lib/firmware/ | ||
$(CP) $(PKG_BUILD_DIR)/bin/powertable/Mamba/Mamba_FCC_v1.2_5G4TX.ini $(1)/lib/firmware/ | ||
endef | ||
|
||
$(eval $(call KernelPackage,mwlwifi)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/mwl_main.c | ||
+++ b/mwl_main.c | ||
@@ -72,7 +72,7 @@ static long atohex2(const char *number); | ||
*/ | ||
|
||
static char fw_image_path[FILE_PATH_LEN] = "88W8864.bin"; | ||
-static char pwr_tbl_path[FILE_PATH_LEN] = "PWR_TABLE.ini"; | ||
+static char pwr_tbl_path[FILE_PATH_LEN] = "/lib/firmware/Mamba_FCC_v1.2_5G4TX.ini"; | ||
|
||
static struct pci_device_id mwl_pci_id_tbl[SYSADPT_MAX_CARDS_SUPPORT + 1] = { | ||
|