Skip to content

Commit

Permalink
gcc: add llvm-gcc and llvm from trunk (does not successfully compile …
Browse files Browse the repository at this point in the history
…a target yet, but gets close)

SVN-Revision: 18019
  • Loading branch information
Felix Fietkau committed Oct 10, 2009
1 parent b49cdab commit 215ccb6
Show file tree
Hide file tree
Showing 33 changed files with 4,631 additions and 22 deletions.
4 changes: 4 additions & 0 deletions package/busybox/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -59,6 +59,10 @@ define Build/Configure
oldconfig
endef

ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif

define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
Expand Down
5 changes: 5 additions & 0 deletions toolchain/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -46,6 +46,11 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endif
endif

ifdef CONFIG_GCC_VERSION_LLVM
$(curdir)/builddirs += llvm
$(curdir)/gcc/prepare += $(curdir)/llvm/install
endif

ifneq ($(ARCH),)
$(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \
Expand Down
3 changes: 3 additions & 0 deletions toolchain/gcc/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -36,6 +36,9 @@ if !LINUX_2_4

config GCC_VERSION_4_4_1
bool "gcc 4.4.1"

config GCC_VERSION_LLVM
bool "llvm-gcc 4.2"
endif

endchoice
Expand Down
2 changes: 2 additions & 0 deletions toolchain/gcc/Config.version
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,7 @@ config GCC_VERSION
default "4.3.4" if GCC_VERSION_4_3_4
default "4.4.0" if GCC_VERSION_4_4_0
default "4.4.1" if GCC_VERSION_4_4_1
default "llvm" if GCC_VERSION_LLVM
default "4.1.2"

config GCC_VERSION_3
Expand All @@ -31,6 +32,7 @@ config GCC_VERSION_4_1
config GCC_VERSION_4_2
bool
default y if GCC_VERSION_4_2_4
default y if GCC_VERSION_LLVM

config GCC_VERSION_4_3
bool
Expand Down
60 changes: 38 additions & 22 deletions toolchain/gcc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,24 +22,38 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=gcc
PKG_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))

PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2

ifeq ($(PKG_VERSION),3.4.6)
PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
endif
ifeq ($(PKG_VERSION),4.1.2)
PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
endif
ifeq ($(PKG_VERSION),4.2.4)
PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
endif
ifeq ($(PKG_VERSION),4.3.3)
PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
endif
ifeq ($(PKG_VERSION),4.4.0)
PKG_MD5SUM:=cf5d787bee57f38168b74d65a7c0e6fd
GCC_VERSION:=$(PKG_VERSION)
GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)

ifdef CONFIG_GCC_VERSION_LLVM
PKG_SOURCE_VERSION:=c98c494b72ff875884c0c7286be67f16f9f6d7ab
PKG_REV:=83504
GCC_DIR:=llvm-gcc-4.2-r$(PKG_REV)
GCC_VERSION:=4.2.1
PKG_SOURCE:=$(GCC_DIR).tar.gz
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://repo.or.cz/llvm-gcc-4.2.git
PKG_SOURCE_SUBDIR:=$(GCC_DIR)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
else
PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2

ifeq ($(PKG_VERSION),3.4.6)
PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
endif
ifeq ($(PKG_VERSION),4.1.2)
PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
endif
ifeq ($(PKG_VERSION),4.2.4)
PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
endif
ifeq ($(PKG_VERSION),4.3.3)
PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
endif
ifeq ($(PKG_VERSION),4.4.0)
PKG_MD5SUM:=cf5d787bee57f38168b74d65a7c0e6fd
endif
endif

PATCH_DIR=./patches/$(PKG_VERSION)
Expand Down Expand Up @@ -71,6 +85,7 @@ GCC_CONFIGURE:= \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm)

ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
GCC_BUILD_TARGET_LIBGCC:=y
Expand Down Expand Up @@ -130,11 +145,12 @@ GCC_CONFIGURE_STAGE2:= \
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \

CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"

define Host/SetToolchainInfo
$(SED) 's,TARGET_CROSS=.*,TARGET_CROSS=$(REAL_GNU_TARGET_NAME)-,' $(TOOLCHAIN_DIR)/info.mk
$(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
$(SED) 's,GCC_VERSION=.*,GCC_VERSION=$(GCC_VERSION),' $(TOOLCHAIN_DIR)/info.mk
endef


Expand Down Expand Up @@ -175,7 +191,7 @@ define Stage1/Install
$(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)

# XXX: glibc insists on linking against libgcc_eh
( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
cp libgcc.a libgcc_initial.a; \
)
Expand Down Expand Up @@ -231,7 +247,7 @@ endef
define Host/Prepare
$(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
$(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
$(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(HOST_BUILD_DIR)/gcc/version.c
Expand Down
200 changes: 200 additions & 0 deletions toolchain/gcc/patches/llvm/100-uclibc-conf.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,200 @@
--- a/libgomp/configure
+++ b/libgomp/configure
@@ -3893,7 +3893,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/gcc/config/cris/linux.h
+++ b/gcc/config/cris/linux.h
@@ -74,7 +74,11 @@ Boston, MA 02110-1301, USA. */
#define CRIS_DEFAULT_CPU_VERSION CRIS_CPU_NG

#undef CRIS_SUBTARGET_VERSION
-#define CRIS_SUBTARGET_VERSION " - cris-axis-linux-gnu"
+#if UCLIBC_DEFAULT
+# define CRIS_SUBTARGET_VERSION " - cris-axis-linux-uclibc"
+#else
+# define CRIS_SUBTARGET_VERSION " - cris-axis-linux-gnu"
+#endif

#define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"

--- a/libstdc++-v3/configure
+++ b/libstdc++-v3/configure
@@ -4283,7 +4283,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/zlib/configure
+++ b/zlib/configure
@@ -3429,7 +3429,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libobjc/configure
+++ b/libobjc/configure
@@ -3314,7 +3314,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libgfortran/configure
+++ b/libgfortran/configure
@@ -3721,7 +3721,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libmudflap/configure
+++ b/libmudflap/configure
@@ -5394,7 +5394,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/boehm-gc/configure
+++ b/boehm-gc/configure
@@ -4323,7 +4323,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libffi/configure
+++ b/libffi/configure
@@ -3460,7 +3460,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libssp/configure
+++ b/libssp/configure
@@ -4482,7 +4482,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/contrib/regression/objs-gcc.sh
+++ b/contrib/regression/objs-gcc.sh
@@ -105,6 +105,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
then
make all-gdb all-dejagnu all-ld || exit 1
make install-gdb install-dejagnu install-ld || exit 1
+elif [ $H_REAL_TARGET = $H_REAL_HOST -a $H_REAL_TARGET = i686-pc-linux-uclibc ]
+ then
+ make all-gdb all-dejagnu all-ld || exit 1
+ make install-gdb install-dejagnu install-ld || exit 1
elif [ $H_REAL_TARGET = $H_REAL_HOST ] ; then
make bootstrap || exit 1
make install || exit 1
--- a/libjava/classpath/ltconfig
+++ b/libjava/classpath/ltconfig
@@ -603,7 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-

# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
case $host_os in
-linux-gnu*) ;;
+linux-gnu*|linux-uclibc*) ;;
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
esac

@@ -1251,7 +1251,7 @@ linux-gnuoldld* | linux-gnuaout* | linux
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
version_type=linux
need_lib_prefix=no
need_version=no
--- a/libjava/classpath/configure
+++ b/libjava/classpath/configure
@@ -5307,7 +5307,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libjava/configure
+++ b/libjava/configure
@@ -5424,7 +5424,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/libtool.m4
+++ b/libtool.m4
@@ -739,7 +739,7 @@ irix5* | irix6*)
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
lt_cv_deplibs_check_method=pass_all
;;

--- a/ltconfig
+++ b/ltconfig
@@ -603,7 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-

# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
case $host_os in
-linux-gnu*) ;;
+linux-gnu*|linux-uclibc*) ;;
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
esac

@@ -1253,7 +1253,7 @@ linux-gnuoldld* | linux-gnuaout* | linux
;;

# This must be Linux ELF.
-linux-gnu*)
+linux*)
version_type=linux
need_lib_prefix=no
need_version=no
Loading

0 comments on commit 215ccb6

Please sign in to comment.