Skip to content

Commit

Permalink
dev-libs/libpqxx: Bump to 5.1.0
Browse files Browse the repository at this point in the history
Fixes bug 626076 where newer version of sed are more strict about
character class syntax.

Last release to support pre-C++11 compilers.

Gentoo-Bug: 626076

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
titanofold committed Aug 10, 2017
1 parent 2ec9f95 commit 0e5ca9a
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libpqxx/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libpqxx-4.0.1.tar.gz 1582532 SHA256 097ceda2797761ce517faa5bee186c883df1c407cb2aada613a16773afeedc38 SHA512 00204985097ef8bb0a3376d6ba541dbb471d7c52d7135f6244a9f4acbf6c8e5254d6f813e4411421e49bb56f4a520fc6ac67e300141d724396ce0ac11bd3a95e WHIRLPOOL d377863f9200e7ed235f8a2cf132b554efa4223d5f542eea23d743ffe391a13d44da767ee2f70146558e5b393ba334656c09007241c1aadde750c00c16e25c12
DIST libpqxx-5.0.1.tar.gz 743560 SHA256 21ba7167aeeb76142c0e865127514b4834cefde45eaab2d5eb79099188e21a06 SHA512 a097a419301d45e8078af08eb4667b7ae06c91d8bb62d57d26e0f6df138eeea350d4ba672a96271f724b3de86f3dd1d57da81aee093835c4b08b2084e98720ef WHIRLPOOL ca447f769f01a876edae5fd05c9b42fb6c33c5684ba61e07b1055586f332310290d85f2dfea9ba4d537100d427b342afd3f75ba948def9b70dabc68ac926d28a
DIST libpqxx-5.1.0.tar.gz 677998 SHA256 c94c8796e3e82f3dda8e8d39b767bc45e95e1cb6e32d03d7fbf71b3e3bd9edd5 SHA512 4e881bb509b36b6b48d18dddd0895ab6864ba0430630d3e1417036ff8ff0008b446467868f2672e0b49b46cc3a86c6a61a8a3e5c6b63e0bf422be3268d7f9702 WHIRLPOOL 270430f4428b9a4d61cf6c94b36de85c8c575c4712688542b771cdaa535f2147a458d859d66f08d3ef9b0f40bc68033dc90f1b5a8c925921707bad6eaebcb8eb
94 changes: 94 additions & 0 deletions dev-libs/libpqxx/libpqxx-5.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python2_7 )
inherit python-any-r1

KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"

DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="http://pqxx.org/development/libpqxx/"
LICENSE="BSD"
SLOT="0"
IUSE="doc static-libs"

RDEPEND="dev-db/postgresql:="
DEPEND="${PYTHON_DEPS}
${RDEPEND}
doc? (
app-doc/doxygen
app-text/xmlto
)
"

DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )

src_prepare() {
default

sed -e 's/python/python2/' \
-i tools/{splitconfig,template2mak.py} \
|| die "Couldn't fix Python shebangs"
}

src_configure() {
econf \
--enable-shared \
$(use_enable doc documentation) \
$(use_enable static-libs static) local myconf
}

src_install () {
use doc && HTML_DOCS=( doc/html/. )

default

if ! use static-libs; then
find "${D}" -name '*.la' -delete || die
fi
}

src_test() {
einfo "The tests need a running PostgreSQL server and an existing database."
einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
einfo "set PGPORT and PGHOST. Define them at the command line or in:"
einfo " ${EROOT%/}/etc/libpqxx_test_env"

if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
source "${EROOT%/}/etc/libpqxx_test_env"
[[ -n $PGDATABASE ]] && export PGDATABASE
[[ -n $PGHOST ]] && export PGHOST
[[ -n $PGPORT ]] && export PGPORT
[[ -n $PGUSER ]] && export PGUSER
fi
fi

if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
local server_version
server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
if [[ $? = 0 ]] ; then
# Currently works with highest server version in tree
#server_version=$(echo ${server_version} | cut -d " " -f 2 | cut -d "." -f -2 | tr -d .)
#if [[ $server_version < 92 ]] ; then
cd "${S}/test"
emake check
#else
# eerror "Server version must be 8.4.x or below."
# die "Server version isn't 8.4.x or below"
#fi
else
eerror "Is the server running?"
eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
eerror " Role: ${PGUSER}"
eerror " Database: ${PGDATABASE}"
die "Couldn't connect to server."
fi
else
eerror "PGDATABASE and PGUSER must be set to perform tests."
eerror "Skipping tests."
fi
}

0 comments on commit 0e5ca9a

Please sign in to comment.