Skip to content

Commit

Permalink
dev-libs/opencl-clang: bump to 11.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Khue Nguyen <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
khuei authored and juippis committed Feb 2, 2021
1 parent c0dcd50 commit 157fe3d
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/opencl-clang/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opencl-clang-10.0.0.1.tar.gz 23549 BLAKE2B 8663da4525507862835ebc14fb4666d9f2f3cca0a2c08aadfc2875bc285e604e81b21ccc7476976eea2e3eb1ce88ae7b187c2d0ce085fc3ede1a2dbfea0789eb SHA512 406e27d90ae26a2f8ade04172bf680f8786011c7e8357a40b15c8bbfd933d0f1c5e0c114e371036318439fcab999ec5f141dab2df4b498eb9d2548bf175f8502
DIST opencl-clang-10.0.0.2.tar.gz 53935 BLAKE2B a0f1c1d8f9e4be24e63318daf38fc70a0372ee1dc5cb2443831b6bf64dd3d44ac3f52ca70de5f52dabab2b34a53d4efafd9c19598b471e6f3b855355c03cf4af SHA512 817cc7d977629e63b9d61bdf7ec8e93596f28102a321927507b035397c99e6e6eda1e5f36d0ed59c9949ba12baab32b138f5053a6bc84ba74211e199ddbf3109
DIST opencl-clang-11.0.0.tar.gz 79487 BLAKE2B a5ec89c68dd31f53881a002fda0fa9f83b6355273a6f2085c6794a0c9a74ba44b8ac21175854a87427c30523f2dd024006050b77d90bbfa7041e4abfbf0bb9e5 SHA512 bd27d15d5e6f396f0b0a79fb1f2081033e26db1df701a37558f7b9976299e17cfb383beff8fb0f1a5ab63601648cac2a33e4de73100fd1ab8706161c52aabe3c
43 changes: 43 additions & 0 deletions dev-libs/opencl-clang/opencl-clang-11.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

CMAKE_ECLASS=cmake

inherit cmake-multilib llvm

MY_PV="$(ver_rs 3 -)"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="OpenCL-oriented thin wrapper library around clang"
HOMEPAGE="https://github.com/intel/opencl-clang"
SRC_URI="https://github.com/intel/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="UoI-NCSA"
SLOT="11"
KEYWORDS="~amd64"

S="${WORKDIR}/${MY_P}"

# Force a rebuild of this package once clang has been updated from 10.0.0 to 10.0.1
# in order to work around Bug #743992. Hopefully a one-time thing.
DEPEND="~sys-devel/clang-11.0.1:11=[static-analyzer,${MULTILIB_USEDEP}]
sys-devel/llvm:11=[${MULTILIB_USEDEP}]
>=dev-util/spirv-llvm-translator-11.0.0:11=[${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"

LLVM_MAX_SLOT=11

PATCHES=(
"${FILESDIR}"/${PN}-8.0.0-clang_library_dir.patch
"${FILESDIR}"/${PN}-10.0.0.1_find-llvm-tblgen.patch
)

multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
-DCLANG_LIBRARY_DIRS="${EPREFIX}"/usr/lib/clang
)
cmake_src_configure
}

0 comments on commit 157fe3d

Please sign in to comment.