forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-action/supermariowar: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
60 additions
and
46 deletions.
There are no files selected for viewing
18 changes: 18 additions & 0 deletions
18
games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
Fix linking with BUILD_SHARED_LIBS=ON default in EAPI-7 | ||
|
||
--- a/src/common_netplay/CMakeLists.txt | ||
+++ b/src/common_netplay/CMakeLists.txt | ||
@@ -1,4 +1,4 @@ | ||
|
||
if(NOT NO_NETWORK) | ||
- add_library(NetplayFiles platform_enet/NetPeerENet.cpp) | ||
+ add_library(NetplayFiles STATIC platform_enet/NetPeerENet.cpp) | ||
endif() | ||
--- a/src/common/CMakeLists.txt | ||
+++ b/src/common/CMakeLists.txt | ||
@@ -39,4 +39,4 @@ | ||
list(APPEND COMMON_SRCS src/savepng.cpp) | ||
endif() | ||
|
||
-add_library(CommonFiles ${COMMON_SRCS}) | ||
+add_library(CommonFiles STATIC ${COMMON_SRCS}) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters