Skip to content

Commit

Permalink
dev-db/lmdb: add 0.9.26 to the tree
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/768948
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Eray Aslan <[email protected]>
  • Loading branch information
erayaslan committed Feb 10, 2021
1 parent de47d3d commit 3a88c3e
Show file tree
Hide file tree
Showing 2 changed files with 76 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/lmdb/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST LMDB_0.9.23.tar.gz 143813 BLAKE2B 252acad974a7ed528fe0e52b8332845bc0b6076599bbc79ef2c3f41459acb6ccbe5f6030c6a258fe30633c4c0568fa05fa6d46dc05bab3f93ee3aab16e6faa89 SHA512 47466a96ce288d18d489acf1abf811aa973649848a4cac31f71e1f25ea781a055ebd6616d2d630214b2df2f146f12609c82d65be0196f49d6b46a6c96464e120
DIST LMDB_0.9.24.tar.gz 143916 BLAKE2B f075ec5f4dfb77685188229e20f12c4febe8295c7d35ed15c3db492b68af68cc7f76741078e9bb524d2c38587839f542e964af1e5d6d984bb28bd602caabbb8d SHA512 c3a96c27f13c072ef5861bcea045d82f0a220dbd938579411ea6c38ac0696b3620c71f1e2cc56d31db5105f3533da95aba1ac34653d8bdcfa4f2f1fb831cccb1
DIST openldap-LMDB_0.9.26.tar.gz 144029 BLAKE2B 07fe81cdaed7a402aaf485a2aa41d12c2c8cc8813d39d5304d8a1f5c8920f4695021eb586b4366a5f55010284227c7ac16487a8799c60f251ea97cd745b1261a SHA512 d7826f6d1a3144feb71eef65f843e8bcddf6cec384014bab3fc1d32a7f1b9316bcbb5b3a915b166cbdae2ffbd15f14b4eb783acd7eddbd2e321607f750efe94d
DIST openldap-LMDB_0.9.27.tar.gz 144104 BLAKE2B 76b7b66ca455f61f71b7c010de0b5437d02a245a5129184cf45bf5684a745888c88012fb73a219076b6c47adfda0804e6c7f603e4631c98034c01efda99ad3a9 SHA512 a27c0d26c801b172f3c207666940f86ecaae9d223843b72823d064f0ea0629a855150d049cb143981783710d3ca791c7f0f65df9d91732b2709e6107af403854
75 changes: 75 additions & 0 deletions dev-db/lmdb/lmdb-0.9.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic multilib-minimal toolchain-funcs

MY_P="${PN^^}_${PV}"

DESCRIPTION="An ultra-fast, ultra-compact key-value embedded data store"
HOMEPAGE="https://symas.com/lmdb/technical/"
SRC_URI="https://git.openldap.org/openldap/openldap/-/archive/${MY_P}/openldap-${MY_P}.tar.gz"

LICENSE="OPENLDAP"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
IUSE="static-libs"

DEPEND=""
RDEPEND=""

S="${WORKDIR}/openldap-${MY_P}/libraries/liblmdb"

src_prepare() {
default
if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -lt 10 ]] ; then
# posix_memalign isn't available before 10.6, but on OSX
# malloc is always aligned for any addressable type
sed -i -e '/(__APPLE__)/a#define HAVE_MEMALIGN 1\n#define memalign(X,Y) malloc(X)' mdb.c || die
fi
multilib_copy_sources
}

multilib_src_configure() {
local soname="-Wl,-soname,liblmdb$(get_libname 0)"
if [[ ${CHOST} == *-darwin* ]] ; then
soname="-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/liblmdb$(get_libname 0)"
replace-flags -O[123456789] -O1
fi
sed -i -e "s!^CC.*!CC = $(tc-getCC)!" \
-e "s!^CFLAGS.*!CFLAGS = ${CFLAGS}!" \
-e "s!^AR.*!AR = $(tc-getAR)!" \
-e "s!^SOEXT.*!SOEXT = $(get_libname)!" \
-e "/^prefix/s!/usr/local!${EPREFIX}/usr!" \
-e "/^libdir/s!lib\$!$(get_libdir)!" \
-e "s!shared!shared ${soname}!" \
"Makefile" || die

if [[ ${CHOST} == *-solaris* ]] ; then
# fdatasync lives in -lrt on Solaris 10
[[ ${CHOST#*-solaris2.} -le 10 ]] && append-ldflags -lrt
fi
}

multilib_src_compile() {
emake LDLIBS+=" -pthread"
}

multilib_src_install() {
emake DESTDIR="${D}" install

mv "${ED}"/usr/$(get_libdir)/liblmdb$(get_libname) \
"${ED}"/usr/$(get_libdir)/liblmdb$(get_libname 0) || die
dosym liblmdb$(get_libname 0) /usr/$(get_libdir)/liblmdb$(get_libname)

insinto /usr/$(get_libdir)/pkgconfig
doins "${FILESDIR}/lmdb.pc"
sed -i -e "s!@PACKAGE_VERSION@!${PV}!" \
-e "s!@prefix@!${EPREFIX}/usr!g" \
-e "s!@libdir@!$(get_libdir)!" \
"${ED}"/usr/$(get_libdir)/pkgconfig/lmdb.pc || die

if ! use static-libs; then
rm "${ED}"/usr/$(get_libdir)/liblmdb.a || die
fi
}

0 comments on commit 3a88c3e

Please sign in to comment.