forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/ament_cmake_target_dependencies: bump to 1.0.4
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
48 changes: 48 additions & 0 deletions
48
dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-1.0.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 2019-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{3_6,3_7,3_8} ) | ||
|
||
inherit cmake python-any-r1 | ||
|
||
ROS_PN="ament_cmake" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/ament/ament_cmake" | ||
SRC_URI="" | ||
S=${WORKDIR}/${P}/${PN} | ||
else | ||
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz" | ||
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}" | ||
fi | ||
|
||
DESCRIPTION="Add defs, include dirs and libs to a target in the ament buildsystem" | ||
HOMEPAGE="https://github.com/ament/ament_cmake" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
KEYWORDS="" | ||
else | ||
KEYWORDS="~amd64" | ||
fi | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-ros/ament_cmake_core | ||
dev-ros/ament_cmake_include_directories | ||
dev-ros/ament_cmake_libraries | ||
" | ||
DEPEND="${RDEPEND}" | ||
# Deps here are transitive from ament_cmake_core to have matching python support | ||
BDEPEND=" | ||
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]') | ||
${PYTHON_DEPS} | ||
" | ||
|
||
python_check_deps() { | ||
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \ | ||
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" | ||
} |