forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-base/gnome-desktop: Version bump to 3.38.2
Signed-off-by: Matt Turner <[email protected]>
- Loading branch information
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gnome-desktop-3.36.5.tar.xz 738956 BLAKE2B 6c419df487e908f57a1dc8798a8dfe8b574d8c5c9aa5d83e45aed233ba856ba398367a990aa83fb1b8966aad02c868cd0e41805908863ea8fef24cc3ade3687c SHA512 0b5ad42c0832d58552270e9e24dabf56668c4fbb84d07812e4a2a34cff0a67344a7c8ee963a53a703b2e4bb28c67035bf2ce854ea271194511dc66e051481b1b | ||
DIST gnome-desktop-3.36.7.tar.xz 739284 BLAKE2B fb64db72883ca6b5001b519f6ce3b5b26605e081530ff27728bc565e5d3ce832281adf3d10107e74028d14d9d1e5fa64f8e5d447c13690ff67aa3d2c2816c2e8 SHA512 20e3566ce1c36399a7fa359dd218f0357e1deef54ad613ce825d19f9266d98ed03c5ae59843100b36dcc6b3cdee8479ea9403514eb39e1f32d9b1fd4e53a7679 | ||
DIST gnome-desktop-3.38.1.tar.xz 745400 BLAKE2B 872b0cdd993ed8f8865ec02e8f4e818657f526caebb3cd1b772c1182a6655d1502f454b94acb0a1dc9e3a1b8f8b8308c5dcee7933a63600d7f8d93fa3876a1d2 SHA512 b3927f0b8571d2ecb528dbe3e096e816e4e90333ce4f1ab8682c8682bbaaf5fc3484dc0944a9437aca40036d29b0feace8ed3954fb17c0bfd7ce503c99af830b | ||
DIST gnome-desktop-3.38.2.tar.xz 745252 BLAKE2B cdbc3ae5bf78dfed0dcedfd83c01ab13f551c312d4eb5e680a9e22932d55ee9cf9334bec84cd99186d43afcf3fe707a12b469409d5c2094a8bbd8a1d36a75ed2 SHA512 93e98c10cac0f1c035af33fc61f945dfdbe12e88e4c42d44b5ba0570f8d81bb3f40f5e0d9fd6c4e4d9faf674f38ded0fc99dfffd57b824d62b92368df6239da8 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome.org gnome2-utils meson xdg | ||
|
||
DESCRIPTION="Library with common API for various GNOME modules" | ||
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-desktop/" | ||
|
||
LICENSE="GPL-2+ LGPL-2+ FDL-1.1+" | ||
SLOT="3/19" # subslot = libgnome-desktop-3 soname version | ||
IUSE="debug gtk-doc +introspection seccomp systemd udev" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris" | ||
|
||
COMMON_DEPEND=" | ||
>=x11-libs/gdk-pixbuf-2.36.5:2[introspection?] | ||
>=x11-libs/gtk+-3.3.6:3[X,introspection?] | ||
>=dev-libs/glib-2.53.0:2 | ||
>=gnome-base/gsettings-desktop-schemas-3.27.0[introspection?] | ||
x11-misc/xkeyboard-config | ||
app-text/iso-codes | ||
systemd? ( sys-apps/systemd:= ) | ||
udev? ( | ||
sys-apps/hwids | ||
virtual/libudev:= ) | ||
seccomp? ( sys-libs/libseccomp ) | ||
x11-libs/cairo:= | ||
introspection? ( >=dev-libs/gobject-introspection-1.54:= ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
media-libs/fontconfig | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
seccomp? ( sys-apps/bubblewrap ) | ||
" | ||
BDEPEND=" | ||
app-text/docbook-xml-dtd:4.1.2 | ||
dev-util/gdbus-codegen | ||
gtk-doc? ( >=dev-util/gtk-doc-1.14 ) | ||
dev-util/itstool | ||
>=sys-devel/gettext-0.19.8 | ||
x11-base/xorg-proto | ||
virtual/pkgconfig | ||
" | ||
# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xorg-proto | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/3.32.2-optional-introspection.patch # add introspection meson option | ||
) | ||
|
||
src_prepare() { | ||
# Don't build manual test programs that will never get run | ||
sed -i -e "/'test-.*'/d" libgnome-desktop/meson.build || die | ||
xdg_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
-Dgnome_distributor=Gentoo | ||
-Ddate_in_gnome_version=true | ||
-Ddesktop_docs=true | ||
$(meson_use debug debug_tools) | ||
$(meson_use introspection) | ||
$(meson_feature udev) | ||
$(meson_feature systemd) | ||
$(meson_use gtk-doc gtk_doc) | ||
-Dinstalled_tests=false | ||
) | ||
meson_src_configure | ||
} |