Skip to content

Commit

Permalink
app-mobilephone/wammu: Adjust gammu dependency (gentoo#775)
Browse files Browse the repository at this point in the history
Changelog of gammu 1.34.0 says:
"Removed deprecated Python modules gammu.Data and gammu.Worker".

Package-Manager: portage-2.2.27
  • Loading branch information
hartwork committed Feb 2, 2016
1 parent c3f265d commit 8324389
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 2 deletions.
66 changes: 66 additions & 0 deletions app-mobilephone/wammu/wammu-0.35-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="3"

PYTHON_DEPEND="2"

inherit distutils

DESCRIPTION="Front-end for gammu to access mobile phones easily"
HOMEPAGE="http://www.wammu.eu/"
SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"

RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
>=dev-python/wxpython-2.8
bluetooth? ( dev-python/pybluez
gnome? ( net-wireless/gnome-bluetooth )
)"
DEPEND="${RDEPEND}"

# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

pkg_setup() {
python_set_active_version 2
python_pkg_setup
}

src_prepare() {
local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -r locale/${lang} || die
fi
done
fi

python_convert_shebangs -r 2 .
}

src_compile() {
# SKIPWXCHECK: else 'import wx' results in
# Xlib: connection to ":0.0" refused by server
SKIPWXCHECK=yes distutils_src_compile
}

src_install() {
DOCS="AUTHORS FAQ"
SKIPWXCHECK=yes distutils_src_install
}
4 changes: 2 additions & 2 deletions app-mobilephone/wammu/wammu-0.36-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"

RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
>=dev-python/wxpython-2.8[${PYTHON_USEDEP}]
bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}]
gnome? ( net-wireless/gnome-bluetooth )
Expand Down

0 comments on commit 8324389

Please sign in to comment.