Skip to content

Commit

Permalink
media-video/griffith: fixes cannot import name InstrumentationManager
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/665068
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Πέτρος Σιλιγκούνας <[email protected]>
Closes: gentoo#9763
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Petross404 authored and Lars Wendler committed Feb 19, 2019
1 parent 826c96c commit 8a9a636
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 1 deletion.
17 changes: 17 additions & 0 deletions media-video/griffith/files/griffith-0.13-validators.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
--- a/griffith-0.13/lib/db/validators.py 2018-09-02 00:37:03.052248916 +0300
+++ b/griffith-0.13/lib/db/validators.py 2018-09-02 00:37:22.462248580 +0300
@@ -23,7 +23,13 @@

import logging

-from sqlalchemy.orm.interfaces import AttributeExtension, InstrumentationManager
+from sqlalchemy.orm.interfaces import AttributeExtension
+try:
+ # sql alchemy 0.8 (and above)
+ from sqlalchemy.ext.instrumentation import InstrumentationManager
+except:
+ # sql alchemy 0.7
+ from sqlalchemy.orm.interfaces import InstrumentationManager
from sqlalchemy.orm import ColumnProperty
from sqlalchemy.types import String

3 changes: 2 additions & 1 deletion media-video/griffith/griffith-0.13-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -46,6 +46,7 @@ src_prepare() {
"${S}"/lib/gconsole.py || die "sed failed"

epatch "${FILESDIR}/0.10-fix_lib_path.patch"
epatch "${FILESDIR}/griffith-0.13-validators.patch"
}

src_compile() {
Expand Down

0 comments on commit 8a9a636

Please sign in to comment.