Skip to content

Commit

Permalink
gnustep-base/gnustep-base: 1.25.1 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
voyageur committed Jan 9, 2018
1 parent 9161560 commit 91c3d7f
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-base/gnustep-base/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnustep-base-1.24.9.tar.gz 3561094 BLAKE2B a50e92ae774826082e743581425cfaab6bcbcdbf65a88df4d58988d3c6723e5d3d76d09cf57b4f9278c489e2ff0d178257e2be1c7147a284d8624f3629aaf4f4 SHA512 baaa3541edf48a5d902f706f9dad261378bf65e5d89f7308ece6a1fe55c348506df4b6d474ae17cdf0072f1e8dec1b2050d59413abe28bd001d5717c54a3ab96
DIST gnustep-base-1.25.0.tar.gz 3528599 BLAKE2B aa86de9dc26fb48f49bdd796fc25863e8b1baa48a7c8a1536cc39497843b8d37f02e1cc72ea343795d1be6392a6679a4810ae62e6f9c5ec6c34f9ee099f32746 SHA512 0c38baa439a87557e054e37ed7b337e9f90f349fd6683551cf6482a0a53c247e2ca23b7df9ab369e8819a7d0f9f29e8a8dc639b148ec1c0223764796dbbd3608
DIST gnustep-base-1.25.1.tar.gz 3475169 BLAKE2B 4e2d26ad5782e117f778d298add4c92d40f7c6c73d5aff9692d8eaf7cf06d6ccf6487282e03d4f86bb434d0c7c327b3d80187ca43fdc1c0ff282a246958448fc SHA512 a93c3b4c0fb7df4946ed52dc62c11dfa58f8606fc9666cc7ec7ff5e1c088b67608410b715680e801636bf5ce2caa08e172372f6cab94933459c5e870f962ab11
65 changes: 65 additions & 0 deletions gnustep-base/gnustep-base/gnustep-base-1.25.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils gnustep-base

DESCRIPTION="A library of general-purpose, non-graphical Objective C objects"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"

LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE="+gnutls +icu +libffi zeroconf"

RDEPEND="${GNUSTEP_CORE_DEPEND}
>=gnustep-base/gnustep-make-2.6.0
gnutls? ( net-libs/gnutls )
icu? ( >=dev-libs/icu-4.0:= )
!libffi? ( dev-libs/ffcall
gnustep-base/gnustep-make[-native-exceptions] )
libffi? ( virtual/libffi )
>=dev-libs/libxml2-2.6
>=dev-libs/libxslt-1.1
>=dev-libs/gmp-4.1:=
>=sys-libs/zlib-1.2
zeroconf? ( net-dns/avahi )"
DEPEND="${RDEPEND}
virtual/pkgconfig"

src_configure() {
egnustep_env

local myconf
if use libffi ; then
myconf="--enable-libffi --disable-ffcall --with-ffi-include=$(pkg-config --variable=includedir libffi)"
else
myconf="--disable-libffi --enable-ffcall"
fi

myconf="$myconf $(use_enable gnutls tls)"
myconf="$myconf $(use_enable icu)"
myconf="$myconf $(use_enable zeroconf)"
myconf="$myconf --with-xml-prefix=${EPREFIX}/usr"
myconf="$myconf --with-gmp-include=${EPREFIX}/usr/include --with-gmp-library=${EPREFIX}/usr/lib"
myconf="$myconf --with-default-config=${EPREFIX}/etc/GNUstep/GNUstep.conf"

econf $myconf
}

src_install() {
# We need to set LD_LIBRARY_PATH because the doc generation program
# uses the gnustep-base libraries. Since egnustep_env "cleans the
# environment" including our LD_LIBRARY_PATH, we're left no choice
# but doing it like this.

egnustep_env
egnustep_install

if use doc ; then
export LD_LIBRARY_PATH="${S}/Source/obj:${LD_LIBRARY_PATH}"
egnustep_doc
fi
egnustep_install_config
}

0 comments on commit 91c3d7f

Please sign in to comment.