Skip to content

Commit

Permalink
dev-db/pgrouting: Bump to 3.1.3
Browse files Browse the repository at this point in the history
Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
titanofold committed Feb 11, 2021
1 parent b195718 commit 9aeee07
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/pgrouting/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pgrouting-3.1.1.tar.gz 6133979 BLAKE2B b7657eeb88773773e6166190cda73d9e657774ff81ce7e9f005333a8dcb9d56587d4a793410356092bb1623ec287549dbc60d814b1d5156ff28301503acee776 SHA512 73285d2d47be844203df136b8a8c13d1672ad8c2dac44a1ff7ce16e4676043692a8f2a60a305542132891da83560c49c5eaeb7712e3e3dd250cd8fd550260d4a
DIST pgrouting-3.1.2.tar.gz 6063893 BLAKE2B a371fb9c744b14072c65af5ceb1ea73d2cdb69821626be3ac79e08c9dee854272ce8cb3816d1de3eade06d50a7520846dd6bccda06934b9db926f9092719f131 SHA512 3cf3e0a4a726f6f11887d15ad71b789a9067f3bc5a675288f22730215aa12d12b94d75f9bdc8ab3077de8368c45c55c0dc27128d0453c4c30965bfc0cf118dcd
DIST pgrouting-3.1.3.tar.gz 6057504 BLAKE2B 73bc5d810a2f7bb383ba4fef4ffa52ccb3f21dbc00c68f02665dc459c0e0a2810e0ed10ab73bb3099be5ea6dde86bad884d82039a50c9c4eb423b614845e94b6 SHA512 1051f0a91813ccb3c396c78a059b99839b3352e562372bcc459dfaf289e35ea08bdba8a159032a3df46913548fc717968c187b8c480187497a5b5f7327ca470e
52 changes: 52 additions & 0 deletions dev-db/pgrouting/pgrouting-3.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

CMAKE_BUILD_TYPE="Release"

POSTGRES_COMPAT=( 9.{5..6} {10..13} )
POSTGRES_USEDEP="server"

inherit cmake postgres-multi

DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
HOMEPAGE="https://pgrouting.org/"
LICENSE="GPL-2 MIT Boost-1.0"

SLOT="0"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
IUSE=""

RDEPEND="${POSTGRES_DEP}
>=dev-db/postgis-2.0
dev-libs/boost
sci-mathematics/cgal
"

DEPEND="${RDEPEND}"
# Needs a running psql instance, doesn't work out of the box
RESTRICT="test"

src_prepare() {
cmake_src_prepare
postgres-multi_src_prepare
}

my_src_configure() {
local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
cmake_src_configure
}

src_configure() {
postgres-multi_foreach my_src_configure
}

src_compile() {
postgres-multi_foreach cmake_build
}

src_install() {
postgres-multi_foreach cmake_src_install
}

0 comments on commit 9aeee07

Please sign in to comment.