forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-frameworks: Add KDE Frameworks 5.63.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
166 changed files
with
3,020 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST attica-5.60.0.tar.xz 63440 BLAKE2B e9aa0f3aa0a3e95c3db4a6d442f21db608caddc8c0f368dc453c308e2406d71714deda568b2edf97bf2a4e0256b2361d80fafcbd8cde9e76787d919a33871a55 SHA512 7473afaf2bf4d30feaf1948ea0e432af72090403ad53af48aa56dc30d1770ba1831aad7a106bf2f94ded33aa44c5269d4401ddbeb4126ba00f61af01e342829d | ||
DIST attica-5.62.0.tar.xz 63216 BLAKE2B 127167f132da85e7ea212bbbf9b01a70c75cc0ba907e833c6529230174bb47893e69c95e065845f7d937551a0d2b876a30c90b9d8d3ef53bc1afefb18cbacd2b SHA512 3a16882d272b888cf1eef5816336ac7119bb5da46ac84cd7a0b86b8d0858fdef6816c995864eb6717bbc8817cf26bdc4d47fea1c7bf946fb696e304abce9d6cc | ||
DIST attica-5.63.0.tar.xz 63376 BLAKE2B 35dbffeb7bbc044b074582c5b4e7850b95c8eff219dc3d17327672340f08e573cb4e2a802247b9810f7b44de5580b933bc6f715eb3d3e93778e60712eaa69139 SHA512 e133426298bbe3c645d559993305509bf14b262f2b2580c51fef25d0640f4ba809044066dfd5351eb864b2f5c70f463f55a57e8ad0a994acf1e5676423961215 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework providing access to Open Collaboration Services" | ||
LICENSE="LGPL-2.1+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
$(add_qt_dep qtnetwork) | ||
" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_test() { | ||
# requires network access, bug #661230 | ||
local myctestargs=( | ||
-E "(providertest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST baloo-5.60.0.tar.xz 268268 BLAKE2B 120f7497539384bc6f18683f9dbe8a6c209ce70902499936ac2668efc9bf35140195374ad9c13500f352db38e06015f8ee29fec1ffcf8b63bf1726997d856bf6 SHA512 a25b0cb80f7744c5aa9d22d4b4a8da3e228fb994f659dd04373cef86f45322a4d625d7390e32b3d1d0c178f40d56e9ce5a3263e2e997272e255d52f2adeb82ee | ||
DIST baloo-5.62.0.tar.xz 273412 BLAKE2B 310a652e22b6b506a122a3447ecef851ab1acaaea9aaf427df598d165cb9266acaa259108ca6610d52bf490e454f3453836e898e619aa8e64b384a59ad3d5d63 SHA512 f72193f4a75a2feebadd9006461bdf194842783f3ad93c16243fe6a1251cf5f761f352b585e6628f2dc23e543bf58d6ff5630e6ae5bb0a916ed0732a520c2ba0 | ||
DIST baloo-5.63.0.tar.xz 274384 BLAKE2B 3c743a8a70fd783a203cdc596e2c5ee784ceeef687ac663dc654083b1903f7bf1a8444b68d5d3791d179798af13f9568e714d9c18a6ce13eeeb01c288844c0af SHA512 16ed9956775fcae90a89e1d64e07e8fdd3d29c2c4420ef67ad390ded3a03e0f52c9c6c616ef8d5a363504be560bfe042a4a07a900741bbb36b5ca46885ccc637 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_TEST="forceoptional" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for searching and managing metadata" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kcrash) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep kfilemetadata) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kidletime) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep solid) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
>=dev-db/lmdb-0.9.17 | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-frameworks/baloo:4[-minimal(+)] | ||
" | ||
|
||
RESTRICT+=" test" # bug 624250 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST bluez-qt-5.60.0.tar.xz 99064 BLAKE2B 2895a9836fbacfc23a9c557cdb10e9f8aaac1c13fa5a8a9c158aec148d56d33730092f5f875d931bdae195263274ef8b64c0753e182356ddecb5badd2059928b SHA512 7a1ef70f2c95e51d0b9c8583f23c9bb07af02087bf291e90ff8f4b9d1702d3a12d38247950aef56ee6409bebfe94bc2ddf91da1fa0bb1ec75afa10b54a6cfd1a | ||
DIST bluez-qt-5.62.0.tar.xz 99036 BLAKE2B 31b172594060a7abd8557dd2aadf2b3abbebd4000a57630fbc34addfe4a42d959ee049de2a25fc035518cf4530ba81bb851edbe9c6bce796932cfc71e39323b6 SHA512 beb83a0d19a55770e2892b43b1afaf808c2905d3d35d8116c9f270c63bddbb6e5c6ae35b3c933e5551084f341364d3cd73bd5e5834afab48f9d289a18b108cf8 | ||
DIST bluez-qt-5.63.0.tar.xz 99296 BLAKE2B edea37a89dd5d2a6b7018b9d1e84fa6db7bcc8ea053c4f85fbc969125428400d8dcea36b0cfabc89dba9d28741232590846c33ceab92a4d0654147c722eb13e5 SHA512 2b8d36569ed4bb9de9b99a2badab174c11fc6208c85b38bec7eda962764fcce56a0c184f05199714ef236f2268e5f7f4c0863457cae2c6243bf80df406ef4008 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 udev | ||
|
||
DESCRIPTION="Qt wrapper for Bluez 5 DBus API" | ||
LICENSE="LGPL-2" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative) | ||
$(add_qt_dep qtnetwork) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DUDEV_RULES_INSTALL_DIR="$(get_udevdir)/rules.d" | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
src_test() { | ||
# parallel tests fail, bug 609248; managertest hangs, bug 668196 | ||
local myctestargs=( | ||
-j1 | ||
-E "(managertest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.60.0.tar.xz 2528776 BLAKE2B b2c1d762e3ec5a0523245daec6892a2b55cdaa6947792d389181c0310db592fbaec9e7dbf5eb8841623dffa82a62d286a72a11e2b99ce7640733b60d2bba6434 SHA512 ffed5778099ac6b735e80d24a8020871bb50c13a04fd437ab619fc8abc07ccd488a46fe7da0c67826ce5b2297a43e86ccbf38c79ffc1a86c5b6a11b72ea8108e | ||
DIST breeze-icons-5.62.0.tar.xz 2679576 BLAKE2B bd9bd906225fe86e9d9df9fd301177ccfe9b24ef0afe8e75a8b5db2dd4855ae3b9a6fc5acf6cf921e7ef346203467556adb7b31a888111f74f54e22f2a6b94a5 SHA512 6d1c67b5c92e8cec44c934383cad185f4d32dd1fd5f37214ea95536175bed7e4f39c1d7ce7737022fe0a891e0f8f15b650ad75ba078ad1abc2deb69dc145d343 | ||
DIST breeze-icons-5.63.0.tar.xz 2702100 BLAKE2B 4ea1e1fa30ed5d5985c9aef1902696a38a512b66db8b762547673302b4ee355ac221963d12ad6fb163127d44d750f32a38c905ecd4a8d9a7db14635039495b5c SHA512 a40d681202c5d9ff8d2e76a7a2ecb92f77bafd42df22dfe5285d07158effdc7ee92aa6aa3021ac94680acf07e8426a7b01660844451cdebed6c866052ab457da |
30 changes: 30 additions & 0 deletions
30
kde-frameworks/breeze-icons-rcc/breeze-icons-rcc-5.63.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
KMNAME="breeze-icons" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Breeze SVG icon theme binary resource" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="" | ||
|
||
BDEPEND=" | ||
$(add_frameworks_dep extra-cmake-modules) | ||
$(add_qt_dep qtcore) | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( $(add_qt_dep qttest) )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=ON | ||
-DSKIP_INSTALL_ICONS=ON | ||
) | ||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST breeze-icons-5.60.0.tar.xz 2528776 BLAKE2B b2c1d762e3ec5a0523245daec6892a2b55cdaa6947792d389181c0310db592fbaec9e7dbf5eb8841623dffa82a62d286a72a11e2b99ce7640733b60d2bba6434 SHA512 ffed5778099ac6b735e80d24a8020871bb50c13a04fd437ab619fc8abc07ccd488a46fe7da0c67826ce5b2297a43e86ccbf38c79ffc1a86c5b6a11b72ea8108e | ||
DIST breeze-icons-5.62.0.tar.xz 2679576 BLAKE2B bd9bd906225fe86e9d9df9fd301177ccfe9b24ef0afe8e75a8b5db2dd4855ae3b9a6fc5acf6cf921e7ef346203467556adb7b31a888111f74f54e22f2a6b94a5 SHA512 6d1c67b5c92e8cec44c934383cad185f4d32dd1fd5f37214ea95536175bed7e4f39c1d7ce7737022fe0a891e0f8f15b650ad75ba078ad1abc2deb69dc145d343 | ||
DIST breeze-icons-5.63.0.tar.xz 2702100 BLAKE2B 4ea1e1fa30ed5d5985c9aef1902696a38a512b66db8b762547673302b4ee355ac221963d12ad6fb163127d44d750f32a38c905ecd4a8d9a7db14635039495b5c SHA512 a40d681202c5d9ff8d2e76a7a2ecb92f77bafd42df22dfe5285d07158effdc7ee92aa6aa3021ac94680acf07e8426a7b01660844451cdebed6c866052ab457da |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Breeze SVG icon theme" | ||
LICENSE="LGPL-3" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
BDEPEND=" | ||
$(add_frameworks_dep extra-cmake-modules) | ||
$(add_qt_dep qtcore) | ||
test? ( app-misc/fdupes ) | ||
" | ||
DEPEND="test? ( $(add_qt_dep qttest) )" | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBINARY_ICONS_RESOURCE=OFF | ||
) | ||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST extra-cmake-modules-5.60.0.tar.xz 325768 BLAKE2B de99c37171d298ef8168403b9b27275171db142f204a2c2b3ff82942390b91510e16a19f0d366242f03259c0c045186a8a8f5bd598ef6051709a307423972fab SHA512 c505f765169d4e77a836d971cabe513f5fbda6c772bff10a97013dd14fb91167b461c7e01382e41c4e9ca050a20ab828f3090ef7cd64625fa784d81f2cbf2743 | ||
DIST extra-cmake-modules-5.62.0.tar.xz 330696 BLAKE2B d13ef20d9e7b148a5c75dbae5cb04ae704925a09ed136b9cba29cf7bfeae4316f8237e9a4d9eb528340a941853a14d265bc029cf1b8f1152254e095f05de6eee SHA512 9a9453fe25f5213e4f7349734486da61301b71198820318a1362bdc8ea95322f4900eb3781a311d5c250c3a4ca52ef88ec19a97122eb089ba6bdafca921facd8 | ||
DIST extra-cmake-modules-5.63.0.tar.xz 330556 BLAKE2B c5bdb0d5db78b0ffe3f5227bcc8ccc067904b2b648b66a4593776e93ba5bf500c69948daa3694ae1dcf8c15a8cf6f493976c3dcebe97934e51ab8e42ad804f9d SHA512 e2e50c43b6b639cebc11dfde7dbc8db6587d34cbcb4b4aa88edc683dbe16ca733aee8cd15de70f634af5d01ad774c882c58d43876d4177bf18b0ddd1c6a9db36 |
72 changes: 72 additions & 0 deletions
72
kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.63.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{6,7}} ) | ||
ECM_KDEINSTALLDIRS="false" | ||
KDE_AUTODEPS="false" | ||
KDE_DEBUG="false" | ||
KDE_QTHELP="false" | ||
KDE_TEST="false" | ||
inherit kde5 python-any-r1 | ||
|
||
DESCRIPTION="Extra modules and scripts for CMake" | ||
HOMEPAGE="https://cgit.kde.org/extra-cmake-modules.git" | ||
|
||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd" | ||
IUSE="doc test" | ||
|
||
BDEPEND=" | ||
doc? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') | ||
$(add_qt_dep qthelp) | ||
) | ||
test? ( | ||
$(add_qt_dep qtcore) | ||
$(add_qt_dep linguist-tools) | ||
) | ||
" | ||
RDEPEND=" | ||
app-arch/libarchive[bzip2] | ||
" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch" ) | ||
|
||
python_check_deps() { | ||
has_version "dev-python/sphinx[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use doc && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
# Requires PyQt5, bug #680256 | ||
sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \ | ||
tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests" | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_QTHELP_DOCS=$(usex doc) | ||
-DBUILD_HTML_DOCS=$(usex doc) | ||
-DBUILD_MAN_DOCS=$(usex doc) | ||
-DDOC_INSTALL_DIR=/usr/share/doc/"${PF}" | ||
) | ||
|
||
kde5_src_configure | ||
} | ||
|
||
src_test() { | ||
# ECMToolchainAndroidTest passes but then breaks src_install | ||
# ECMPoQmToolsTest is broken, bug #627806 | ||
local myctestargs=( | ||
-E "(ECMToolchainAndroidTest|ECMPoQmToolsTest)" | ||
) | ||
|
||
kde5_src_test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST frameworkintegration-5.60.0.tar.xz 1753424 BLAKE2B f0752ba701ad1bc3c447f1d7c17ab22b922efc570bf6ef84c51ef58ee9e3f32f68f0ef222c88991252db60a0b0e63cdec672b20b693807d50b3bed2b1b7c95b3 SHA512 4313e31789046e49d644a8613c0274c44f15ce7bfdee1e66240a1cbf6c625eba093fa0a2d922833a336c208aa75af8c949d0881bd17efe2c1007045d3a9288a5 | ||
DIST frameworkintegration-5.62.0.tar.xz 1754660 BLAKE2B ffb435d47c9e006f62be2c64caf69ef1c6aed97f47223a6e8ee29c0ac101c628e880f202ccfcd66f285d24749a675bc922dc59f240e4825ed2f0c9f86b25d9d9 SHA512 918ecb9ddf50cfa8b8fce3fb218a8b80a97d3e440e3c6faf5bb76e74ff1752448244da19da0367a6e077ee8f7e4599328da667d63d45c35490a0a7436570e336 | ||
DIST frameworkintegration-5.63.0.tar.xz 1754592 BLAKE2B 68000a87f67cc92704f349ec03e33bba9c9677e25210e42d6eb3e50ff825e593cf3b6c08fc22ee3db6562b93a9d9c495a22189bb6e3076a2b4d62ae37373bea0 SHA512 76edf9191fad80c19f5bc2bc40e91b16583219bf4dd79c0a722089195ef0325f95a6863723cbc7e1c46446d978ff812ce13afb78bd47fc0b96e0fe26f8716ea4 |
53 changes: 53 additions & 0 deletions
53
kde-frameworks/frameworkintegration/frameworkintegration-5.63.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
KDE_QTHELP="false" | ||
VIRTUALX_REQUIRED="test" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="appstream X" | ||
|
||
DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kiconthemes) | ||
$(add_frameworks_dep knewstuff) | ||
$(add_frameworks_dep knotifications) | ||
$(add_frameworks_dep kpackage) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtwidgets) | ||
appstream? ( | ||
app-admin/packagekit-qt | ||
dev-libs/appstream[qt5] | ||
) | ||
X? ( | ||
$(add_qt_dep qtx11extras) | ||
x11-libs/libxcb | ||
) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
# requires running kde environment | ||
RESTRICT+=" test" | ||
|
||
src_prepare() { | ||
punt_bogus_dep Qt5 DBus | ||
kde5_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package appstream AppStreamQt) | ||
$(cmake-utils_use_find_package appstream packagekitqt5) | ||
$(cmake-utils_use_find_package X XCB) | ||
) | ||
|
||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-stats-5.60.0.tar.xz 61072 BLAKE2B 1c43005e77c07bbb9c2f362c72426f89d7f55b9b185bc56036b7643889077cbdf94fdb691188c979a123d82ba25adbc97406c3116ab4f398e20e7f068cb913cd SHA512 b3de38928c6e191962dfbc4ff25e21c5dcfabc41b9c5b13b49ef495981ac8437e126ac7d72cea578d191eff7c66f9b07b915103186a77db0b46f75e432c095e7 | ||
DIST kactivities-stats-5.62.0.tar.xz 62920 BLAKE2B 1445d189239365a6f9225905b4dc05cf765dc7b173b47deacdb740cb743f0863cdb5d0ac291a767a3862c3f3957a49ab5aa89c0408fbd8d0dd7587670ad5336b SHA512 2ac404cfbadede0382a3ee012a987335b16b0b258ea4add0ce205268664e34b43c06e91181652842bc27a8fbbea5b7550d0f8c9b25fdd2626d71cf32cbab9402 | ||
DIST kactivities-stats-5.63.0.tar.xz 62548 BLAKE2B 461d0bfd4189ada2ea2601abd90cfc9e883e680bc4cc4b8b9f05d4cd796575ae50add793272d84cb8dee9c5bb1bb38183cddd88e806753e3d2113d0c48e52396 SHA512 90ad62904b4624aed0895ef48c74d42c5c77aa71b6d2e763b48f0c62f7a68426d45dc032716dab890c86313a5716d08b28b09f617beb5aca5521af2a7949b341 |
21 changes: 21 additions & 0 deletions
21
kde-frameworks/kactivities-stats/kactivities-stats-5.63.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for getting the usage statistics collected by the activities service" | ||
LICENSE="LGPL-2+" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtsql) | ||
$(add_frameworks_dep kactivities) | ||
$(add_frameworks_dep kconfig) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kactivities-5.60.0.tar.xz 61224 BLAKE2B 777b7357184baa1d5d34b1de033bf4c855db2fd55107d03a4e2ff69a167c48fbfa63f4d14da1ffeb4487d535cbea409d90c22bf32e0204065c1b4508b0c44aa7 SHA512 5b8f4b3165a40f43cd3c7cb8716a5d5d8a72fb754cb82c0d3ad8f36e765aea09d0b634bfdc8bc317556b8d14baec99f8f7f0efc16ab6ef575c611dc0f36b9e2b | ||
DIST kactivities-5.62.0.tar.xz 61424 BLAKE2B 5ee7ae65568a7cef258f5722f0d9473a35b65e1544fb00058457ec60f340f41cb468bd9d52fe057c92d1b9e67c84dfcafdfadbe3250847e7bc52a5cb6f1cfe29 SHA512 f452873b3aafd5665740588a3ee4b9740dc145a3a97714b3b560ca900a52ee63fe4f8cd541ae263e08c2486ab51e84a72051f4379e53f9de39c33f3f6a5e9f8e | ||
DIST kactivities-5.63.0.tar.xz 61516 BLAKE2B c9bf734c445b2f0783ae8a5a8a3bdd6aac91504cf80261153d29eb54d571a8b791a067221afa63bf4860bed4a16e2fdbea9c4c7eb9a385f2f65c1f8b7d4fde7f SHA512 fda4363e05234dadf2062c051165d38d3d1111edebab1022d368a679151e2aa5ecaeee22a6b8e5b8ee1c5ce8331e2ade2bc8c02f0c93f05bf8dc505acb9db5b8 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit kde5 | ||
|
||
DESCRIPTION="Framework for working with KDE activities" | ||
LICENSE="|| ( LGPL-2.1 LGPL-3 )" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="" | ||
|
||
COMMON_DEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtdeclarative widgets) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtsql) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
$(add_plasma_dep kactivitymanagerd) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.54 | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kapidox-5.60.0.tar.xz 396600 BLAKE2B e0bf009bb59de72f1bc7aba021c8c2751e4322702eea6912da55c745522d4981ad116a5baa22bf0a98148699d0fd738850a71e08989691101fad5d02eefdceec SHA512 f2ee7a486a3740ad2124f95264f83242b07454f189defc8eefac1cb20e7b6b1c37c579fd8b620148ee2197b8473d3a5a80e773fb0f0abd2f6cdfca7a4a1bcea6 | ||
DIST kapidox-5.62.0.tar.xz 397028 BLAKE2B bb38a66194977444a854e0aa3ad2dc5d60462fd72b4957b1330edd6b1e31e06369c047d42e1db729030ff423304692736de9ca8ffcb2b03b63a65d64780f2547 SHA512 d962d374530fcb264d83fc223b055a86a7bec6cc11c192cc8972e703a4a505520547c9eac2be758847cbfcf73ab63d6ba09dd70c7f1fa3ec5437d7ca844ec6da | ||
DIST kapidox-5.63.0.tar.xz 396748 BLAKE2B c65be0250154e7a2898fb68ae5887f898067e9e4f5feec4343db24aa366e341dbac4f85f133b0c567da3a8715553b2cba329b17bcbc59320925d7f6579bfe17e SHA512 408d03720b5511587c5246a263be276b8acda9fa892fac6b1956b7a9259aca695c145e7678fe5852e31fd162547051131c649bda884bd008d737136b7eba74fd |
Oops, something went wrong.